summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-08-03 20:26:40 +0800
committerlilac2022-08-03 20:26:40 +0800
commit79e28b83b3724d550532582194df62eed93588fb (patch)
tree81aefe04b5b121399a039e98893ab9bf7719bc94
parent44dae5551c85cea288631db32dcd0fd21e20d415 (diff)
downloadaur-79e28b83b3724d550532582194df62eed93588fb.tar.gz
[lilac] updated to 1:1.12.0-2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9b2bb8992c3..3280381c7a24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = python-tf2onnx
pkgdesc = Convert TensorFlow models to ONNX
- pkgver = 1.12.1
- pkgrel = 1
+ pkgver = 1.12.0
+ pkgrel = 2
+ epoch = 1
url = https://github.com/onnx/tensorflow-onnx
arch = any
license = MIT
@@ -20,9 +21,9 @@ pkgbase = python-tf2onnx
depends = python-onnx
depends = python-requests
depends = python-six
- source = https://github.com/onnx/tensorflow-onnx/archive/v1.12.1/tf2onnx-v1.12.1.tar.gz
+ source = https://github.com/onnx/tensorflow-onnx/archive/v.1.12.0/tf2onnx-v1.12.0.tar.gz
source = onnxruntime.diff
- sha256sums = 103948bf96d8861ebb9fbcc35bb46090007fc970de2411db8388ceb494e29b4a
+ sha256sums = 958c1bd50131e91d91a79629cfe70e13a02295a6c81486598b74cef9ba2000c6
sha256sums = 7e8ab46940aff7cac8d535436c8e201f37c66637416ae9b795706a4c3dd01232
pkgname = python-tf2onnx
diff --git a/PKGBUILD b/PKGBUILD
index fa4f8544f559..2eab420634d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
pkgname=python-tf2onnx
-pkgver=1.12.1
-pkgrel=1
+epoch=1
+pkgver=1.12.0
+pkgrel=2
pkgdesc='Convert TensorFlow models to ONNX'
arch=(any)
url='https://github.com/onnx/tensorflow-onnx'
@@ -10,13 +11,13 @@ license=(MIT)
depends=(python python-tensorflow python-numpy python-onnx python-requests python-six)
makedepends=(python-setuptools python-build python-installer python-wheel)
checkdepends=(python-pytest python-graphviz python-parameterized python-yaml python-onnxruntime)
-source=("https://github.com/onnx/tensorflow-onnx/archive/v$pkgver/tf2onnx-v$pkgver.tar.gz"
+source=("https://github.com/onnx/tensorflow-onnx/archive/v.$pkgver/tf2onnx-v$pkgver.tar.gz"
"onnxruntime.diff")
-sha256sums=('103948bf96d8861ebb9fbcc35bb46090007fc970de2411db8388ceb494e29b4a'
+sha256sums=('958c1bd50131e91d91a79629cfe70e13a02295a6c81486598b74cef9ba2000c6'
'7e8ab46940aff7cac8d535436c8e201f37c66637416ae9b795706a4c3dd01232')
prepare() {
- cd tensorflow-onnx-$pkgver
+ cd tensorflow-onnx-v.$pkgver
sed -i -r 's#--cov\S+##' setup.cfg
sed -i "s#'pytest-runner'##" setup.py
@@ -28,17 +29,17 @@ prepare() {
}
build() {
- cd tensorflow-onnx-$pkgver
+ cd tensorflow-onnx-v.$pkgver
python -m build --wheel --no-isolation
}
check() {
- cd tensorflow-onnx-$pkgver
+ cd tensorflow-onnx-v.$pkgver
PYTHONPATH="$PWD" pytest tests
}
package() {
- cd tensorflow-onnx-$pkgver
+ cd tensorflow-onnx-v.$pkgver
python -m installer --destdir="$pkgdir" --compile-bytecode 0 --compile-bytecode 1 --compile-bytecode 2 dist/*.whl
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}