summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Zardi2021-01-14 17:39:39 +0100
committerFrancesco Zardi2021-01-14 17:39:39 +0100
commit79e5c8af608acc322336f048b1cd6c2c83344a34 (patch)
tree4cc8a764b04f3a3cd76a9a01a4f86f286ebfab95
parentcc7f08d3e015c6aeeeaea91540c5f6d55aeb79d6 (diff)
downloadaur-79e5c8af608acc322336f048b1cd6c2c83344a34.tar.gz
Re-enable PostgreSQL and MariaDB/MySQL plugins, and import patches from Fedora pacakge
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD244
-rw-r--r--eastern_asian_languagues.diff39
-rw-r--r--gcc-4.6.patch33
-rw-r--r--qt-copy-kde-patches.tar.bz2bin29688 -> 0 bytes
-rw-r--r--qt-odbc.patch19
-rw-r--r--qt-patches.tar.bz2bin3708 -> 0 bytes
-rw-r--r--qt-x11-free-3.3.5-makelibshared.patch48
-rw-r--r--qt3-fedora-patches.tar.bz2bin0 -> 136711 bytes
-rw-r--r--qt3-other-patches.tar.bz2bin0 -> 23177 bytes
-rw-r--r--qt3-png15.patch212
11 files changed, 207 insertions, 414 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09e2a4ed9519..14915ea34ac8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = qt3
pkgdesc = A cross-platform application and UI framework
pkgver = 3.3.8b
- pkgrel = 13
+ pkgrel = 14
epoch = 1
url = http://qt.io
arch = i686
arch = x86_64
license = GPL
+ makedepends = mariadb
+ makedepends = postgresql
makedepends = unixodbc
- makedepends = sqlite
+ makedepends = sqlite2
makedepends = mesa
depends = libpng
depends = libxmu
@@ -22,24 +24,16 @@ pkgbase = qt3
depends = libnsl
depends = libtirpc
optdepends = qtchooser: set the default Qt toolkit
+ optdepends = libmariadbclient: MariaDB driver
+ optdepends = postgresql-libs: PostgreSQL driver
optdepends = unixodbc: ODBC driver
options = !docs
source = http://download.qt.io/archive/qt/3/qt-x11-free-3.3.8b.tar.gz
- source = qt3-png15.patch
- source = qt-copy-kde-patches.tar.bz2
- source = qt-patches.tar.bz2
- source = eastern_asian_languagues.diff
- source = qt-odbc.patch
- source = gcc-4.6.patch
- source = qt-x11-free-3.3.5-makelibshared.patch
+ source = qt3-other-patches.tar.bz2
+ source = qt3-fedora-patches.tar.bz2
sha256sums = 1b7a1ff62ec5a9cb7a388e2ba28fda6f960b27f27999482ebeceeadb72ac9f6e
- sha256sums = 1f8a1aa1d9c5eee8cdbc91b1c6d5a5bae62f422480fee383a1753bc7eac7741c
- sha256sums = bbef150acbb506eebb5e005fc0b5f3d3d7d970f673f4d3989c43947b52693a7e
- sha256sums = 7cc99dee873d074efef18a637529fec5ba2dc96a7474febe7b85698e41d35c9b
- sha256sums = 10a8449a55d02553ab8d61cbf51cbbb2cb9dc0e8c22036172c63a15736b8c5e0
- sha256sums = 5e5e2bbbd6273caa2c350542365ab3b5f904c6049ba4cd96c7ae2fb47c1f2ac2
- sha256sums = 49413093d37a0206870475943f14ac17e6309337eb02ce06de2e342f86523989
- sha256sums = 27e1482308912323aa8cd603d7f719bce47ae7caa9df68569b26ed3ba1e39418
+ sha256sums = d8a7c622b0a5054d85d465f7b1b6db03233fbcf9fd132f7f0bd7c6848ff906ce
+ sha256sums = 673b10f3652d72d65515f5a0c21c27d39d0c3b7fade30ae77ebd7facca6acacb
pkgname = qt3
diff --git a/PKGBUILD b/PKGBUILD
index d32d3083cf7e..689860898d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=qt3
pkgver=3.3.8b
-pkgrel=13
+pkgrel=14
epoch=1
pkgdesc="A cross-platform application and UI framework"
arch=('i686' 'x86_64')
@@ -13,57 +13,177 @@ url="http://qt.io"
license=('GPL')
depends=('libpng' 'libxmu' 'libxcursor' 'libxinerama' 'glu' 'libxft'
'libxrandr' 'libmng' 'libunistring' 'libnsl' 'libtirpc')
-makedepends=('unixodbc' 'sqlite' 'mesa')
+makedepends=('mariadb' 'postgresql' 'unixodbc' 'sqlite2' 'mesa')
optdepends=('qtchooser: set the default Qt toolkit'
+ 'libmariadbclient: MariaDB driver'
+ 'postgresql-libs: PostgreSQL driver'
'unixodbc: ODBC driver')
options=('!docs')
source=(http://download.qt.io/archive/qt/3/qt-x11-free-${pkgver}.tar.gz
- qt3-png15.patch
- qt-copy-kde-patches.tar.bz2
- qt-patches.tar.bz2
- eastern_asian_languagues.diff
- qt-odbc.patch
- gcc-4.6.patch
- qt-x11-free-3.3.5-makelibshared.patch)
+ qt3-other-patches.tar.bz2
+ qt3-fedora-patches.tar.bz2)
sha256sums=('1b7a1ff62ec5a9cb7a388e2ba28fda6f960b27f27999482ebeceeadb72ac9f6e'
- '1f8a1aa1d9c5eee8cdbc91b1c6d5a5bae62f422480fee383a1753bc7eac7741c'
- 'bbef150acbb506eebb5e005fc0b5f3d3d7d970f673f4d3989c43947b52693a7e'
- '7cc99dee873d074efef18a637529fec5ba2dc96a7474febe7b85698e41d35c9b'
- '10a8449a55d02553ab8d61cbf51cbbb2cb9dc0e8c22036172c63a15736b8c5e0'
- '5e5e2bbbd6273caa2c350542365ab3b5f904c6049ba4cd96c7ae2fb47c1f2ac2'
- '49413093d37a0206870475943f14ac17e6309337eb02ce06de2e342f86523989'
- '27e1482308912323aa8cd603d7f719bce47ae7caa9df68569b26ed3ba1e39418')
-
-# qt-copy-kde-patches come from http://websvn.kde.org/trunk/qt-copy/patches/
-# other qt-patches come from fedora and gentoo
+ 'd8a7c622b0a5054d85d465f7b1b6db03233fbcf9fd132f7f0bd7c6848ff906ce'
+ '673b10f3652d72d65515f5a0c21c27d39d0c3b7fade30ae77ebd7facca6acacb')
prepare() {
cd qt-x11-free-${pkgver}
- # apply qt patches from kde.org
- for i in ../qt-copy-kde-patches/*; do
- patch -p0 -i $i
- done
- # apply other qt patches and one security fix from debian/gentoo
- for i in ../qt-patches/*; do
- patch -p1 -i $i
- done
- # fix CJK font/chars select error (FS#11245)
- patch -p1 -i "${srcdir}"/eastern_asian_languagues.diff
- # fix build problem against new unixODBC
- patch -p1 -i "${srcdir}"/qt-odbc.patch
- # fix build with gcc 4.6.0
- patch -p1 -i "${srcdir}"/gcc-4.6.patch
- patch -p0 -i "${srcdir}"/qt3-png15.patch
- patch -p1 -i "${srcdir}"/qt-x11-free-3.3.5-makelibshared.patch
+ # Most of the patches come from the Fedora qt3 package at
+ # https://fedora.pkgs.org/33/fedora-aarch64/qt3-3.3.8b-84.fc33.aarch64.rpm.html
+ #
+ # qt-copy-kde-patches come from http://websvn.kde.org/trunk/qt-copy/patches/
+ #
+ # Other patches were taken from gentoo
+
+
+ # Apply patches from Fedora
+
+ # Patch application order copied from the "qt3.spec" file of the Fedora
+
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.4-print-CJK.patch # Patch1
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.0.5-nodebug.patch # Patch2
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.1.0-makefile.patch # Patch3
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.7-umask.patch # Patch4
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.6-strip.patch # Patch5
+
+ # drop backup file(s), else they get installed too, http://bugzilla.redhat.com/639459
+ rm -fv mkspecs/linux-g++*/qmake.conf.strip
+
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.2-quiet.patch # Patch7
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.3-qembed.patch # Patch8
+ patch -p1 -i ../../qt3-fedora-patches/qt-uic-nostdlib.patch # Patch12
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.6-qfontdatabase_x11.patch # Patch13
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.3-gl.patch # Patch14
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.3-gtkstyle.patch # Patch19
+ # hardcode the compiler version in the build key once and for all
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-hardcode-buildkey.patch # Patch20
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.5-uic.patch # Patch24
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-uic-multilib.patch # Patch25
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.6-fontrendering-ml_IN-209097.patch # Patch27
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.8-fontrendering-as_IN-209972.patch # Patch29
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.6-fontrendering-te_IN-211259.patch # Patch31
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.6-fontrendering-214371.patch # Patch32
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.8-fontrendering-#214570.patch # Patch33
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.6-fontrendering-ml_IN-209974.patch # Patch34
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.6-fontrendering-ml_IN-217657.patch # Patch35
+ patch -p1 -i ../../qt3-fedora-patches/qt-3.3.6-fontrendering-gu-228452.patch # Patch37
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8-odbc.patch # Patch38
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.7-arm.patch # Patch39
+ # See http://bugzilla.redhat.com/549820
+ # Try to set some sane defaults, for style, fonts, plugin path
+ # FIXME: style doesn't work. use kde3 plastik, if available
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-sane_defaults.patch # Patch40
+ sed -i.KDE3_PLUGIN_PATH \
+ -e "s|@@KDE3_PLUGIN_PATH@@|%{_libdir}/kde3/plugins|" \
+ src/kernel/qapplication.cpp
+ # and/or just use qtrc to do the same thing
+
+ # add missing #include <cstdef> to make gcc-4.6 happier
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-cstddef.patch # Patch41
+ # fix aliasing issue in qlocale.cpp
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-qlocale-aliasing.patch # Patch42
+ # use the system SQLite 2 (Debian's 91_system_sqlite.diff)
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-system-sqlite2.patch # Patch43
+ # silence compiler warning in qimage.h by adding parentheses
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-qimage-parentheses.patch # Patch44
+ ## fix the include path for zlib.h in qcstring.cpp to pick up the system version
+ #patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-system-zlib-header.patch # Patch45
+ # fix FTBFS with libpng 1.5 (patch from NetBSD)
+ patch -p0 -i ../../qt3-fedora-patches/qt-3.3.8-libpng15.patch # Patch46
+ # work around -Werror=format-security false positives (#1037297)
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-#1037297.patch # Patch47
+ # search for FreeType using pkg-config, fixes FTBFS with freetype >= 2.5.1
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-freetype251.patch # Patch48
+ # rename the struct Param in qsqlextension_p.h that conflicts with PostgreSQL 11
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-postgresql11.patch # Patch49
+
+ # immodule patches
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-immodule-unified-qt3.3.8-20071116.diff # Patch50
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-immodule-unified-qt3.3.5-20051012-quiet.patch # Patch51
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-fix-key-release-event-with-imm.diff # Patch52
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.6-qt-x11-immodule-unified-qt3.3.5-20060318-resetinputcontext.patch # Patch53
+
+ # mariadb support
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-mariadb.patch # Patch60
+
+ # compile with postgresql 12
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-PostgreSQL12.patch # Patch70
+
+ patch -p0 -i ./../qt3-other-patches/0001-dnd_optimization.patch
+ patch -p0 -i ./../qt3-other-patches/0002-dnd_active_window_fix.patch
+ patch -p0 -i ./../qt3-other-patches/0005-qpixmap_mitshm.patch
+ patch -p0 -i ./../qt3-other-patches/0007-qpixmap_constants.patch
+ patch -p0 -i ./../qt3-other-patches/0015-qiconview-finditem.patch
+ patch -p0 -i ./../qt3-other-patches/0016-qiconview-rebuildcontainer.patch
+ patch -p0 -i ./../qt3-other-patches/0017-qiconview-ctrl_rubber.patch
+ patch -p0 -i ./../qt3-other-patches/0020-designer-deletetabs.patch
+ patch -p0 -i ./../qt3-other-patches/0032-fix_rotated_randr.diff
+ patch -p0 -i ./../qt3-other-patches/0035-qvaluelist-streaming-operator.patch
+ patch -p0 -i ./../qt3-other-patches/0036-qprogressbar-optimization.patch
- sed -i "s|-O2|$CXXFLAGS|" mkspecs/linux-g++{,-32,-64}/qmake.conf
+ # qt-copy patches
+ patch -p0 -i ../../qt3-fedora-patches/0038-dragobject-dont-prefer-unknown.patch # Patch100
+ patch -p0 -i ./../qt3-other-patches/0044-qscrollview-windowactivate-fix.diff
+ patch -p0 -i ./../qt3-other-patches/0046-qiconview-no-useless-scrollbar.diff
+ patch -p0 -i ../../qt3-fedora-patches/0047-fix-kmenu-width.diff # Patch101
+ patch -p0 -i ../../qt3-fedora-patches/0048-qclipboard_hack_80072.patch # Patch102
+ patch -p0 -i ./../qt3-other-patches/0049-qiconview-rubber_on_move.diff
+ patch -p0 -i ../../qt3-fedora-patches/0056-khotkeys_input_84434.patch # Patch103
+ patch -p0 -i ./../qt3-other-patches/0059-qpopup_has_mouse.patch
+ patch -p0 -i ./../qt3-other-patches/0060-qpopup_ignore_mousepos.patch
+ patch -p0 -i ./../qt3-other-patches/0061-qscrollview-propagate-horizontal-wheelevent.patch
+ patch -p0 -i ../../qt3-fedora-patches/0073-xinerama-aware-qpopup.patch # Patch105
+ patch -p0 -i ./../qt3-other-patches/0078-argb-visual-hack.patch
+ patch -p0 -i ../../qt3-fedora-patches/0079-compositing-types.patch # Patch107
+ patch -p0 -i ../../qt3-fedora-patches/0080-net-wm-sync-request-2.patch # Patch108
+ patch -p0 -i ../../qt3-fedora-patches/0084-compositing-properties.patch # Patch110
+
+ # upstream patches
+ patch -p1 -i ./../qt3-other-patches/qt-no-rpath.patch
+ patch -p1 -i ./../qt3-other-patches/qt-visibility.patch
+ patch -p1 -i ./../qt3-other-patches/qt-x11-free-3.3.4-gcc4.patch
+ patch -p1 -i ./../qt3-other-patches/qt-x11-free-3.3.5-makelibshared.patch
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.4-fullscreen.patch # Patch200
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-gcc43.patch # Patch201
+
+ # security patches
+ # fix for CVE-2013-4549 backported from Qt 4
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-CVE-2013-4549.patch # Patch300
+ # fix for CVE-2014-0190 (QTBUG-38367) backported from Qt 4
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-CVE-2014-0190.patch # Patch301
+ # fix for CVE-2015-0295 backported from Qt 4
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-CVE-2015-0295.patch # Patch302
+ # fix for CVE-2015-1860 backported from Qt 4
+ patch -p1 -i ../../qt3-fedora-patches/qt-x11-free-3.3.8b-CVE-2015-1860.patch # Patch303
+
+
+ # Fix CJK font/chars select error (FS#11245)
+ patch -p1 -i ../../qt3-other-patches/eastern_asian_languagues.diff
+
+ # For immodule
+ sh ./make-symlinks.sh
+
+ # set correct X11 prefix
+ sed -i "s,QMAKE_LIBDIR_X11.*,QMAKE_LIBDIR_X11\t=," mkspecs/*/qmake.conf
+ sed -i "s,QMAKE_INCDIR_X11.*,QMAKE_INCDIR_X11\t=," mkspecs/*/qmake.conf
+ sed -i "s,QMAKE_INCDIR_OPENGL.*,QMAKE_INCDIR_OPENGL\t=," mkspecs/*/qmake.conf
+ sed -i "s,QMAKE_LIBDIR_OPENGL.*,QMAKE_LIBDIR_OPENGL\t=," mkspecs/*/qmake.conf
+
+ # don't use rpath
+ sed -i "s|-Wl,-rpath,| |" mkspecs/*/qmake.conf
+
+ # sed -i "s|-O2|$INCLUDES %{optflags} -fno-strict-aliasing|g" mkspecs/*/qmake.conf
+
+ sed -i "s|-O2|$CXXFLAGS -fno-strict-aliasing|" mkspecs/linux-g++{,-32,-64}/qmake.conf
sed -i "s|-I. |$CXXFLAGS -I. |" qmake/Makefile.unix
sed -i "s|read acceptance|acceptance=yes|" configure
}
build() {
- export QTDIR="${srcdir}"/qt-x11-free-${pkgver}
+ cd "qt-x11-free-${pkgver}" || exit 1
+
+ export QTDIR="${srcdir}/qt-x11-free-${pkgver}"
export PATH=${QTDIR}/bin:${PATH}
export LD_LIBRARY_PATH=${QTDIR}/lib:${LD_LIBRARY_PATH}
export QMAKESPEC=$QTDIR/mkspecs/linux-g++
@@ -73,7 +193,6 @@ build() {
else unset ARCH
fi
- cd qt-x11-free-${pkgver}
./configure \
-prefix /usr \
-bindir /usr/lib/qt3/bin \
@@ -81,41 +200,72 @@ build() {
-plugindir /usr/lib/qt3/plugins \
-datadir /usr/share/qt3 \
-translationdir /usr/share/qt3/translations \
- -I/usr/include/mysql -I/usr/include/postgresql/server \
+ -I/usr/include/mysql \
+ -I/usr/include/postgresql/server \
-I/usr/include/tirpc \
+ -I/usr/include \
-platform linux-g++$ARCH \
- -system-zlib \
+ -enable-styles \
+ -enable-tools \
+ -enable-kernel \
+ -enable-widgets \
+ -enable-dialogs \
+ -enable-iconview \
+ -enable-workspace \
+ -enable-network \
+ -enable-canvas \
+ -enable-table \
+ -enable-xml \
+ -enable-opengl \
+ -enable-sql \
-qt-gif \
+ -qt-style-motif \
-release \
+ -largefile \
-shared \
-sm \
-nis \
-thread \
-stl \
- -system-lib{png,jpeg,mng} \
+ -cups \
+ -xinerama \
+ -xrender \
+ -xkb \
+ -ipv6 \
+ -dlopen-opengl \
+ -xft \
+ -tablet \
+ -system-zlib \
+ -system-libpng \
+ -system-libmng \
+ -system-libjpeg \
+ -no-exceptions \
-no-g++-exceptions \
- -plugin-sql-{sqlite,odbc} #-plugin-sql-{mysql,psql,sqlite,odbc}
+ -plugin-sql-mysql \
+ -plugin-sql-psql \
+ -plugin-sql-sqlite \
+ -plugin-sql-odbc
make
}
package() {
- cd qt-x11-free-${pkgver}
+ cd qt-x11-free-${pkgver} || exit 1
make INSTALL_ROOT="${pkgdir}" install
sed -i -e "s|-L${srcdir}/qt-x11-free-${pkgver}/lib ||g" -e "s|${srcdir}/||g" "${pkgdir}"/usr/lib/*.prl
rm -rf "${pkgdir}"/usr/share/qt3/{phrasebooks,templates,translations}
rm -rf "${pkgdir}"/usr/share/qt3/mkspecs/{aix*,*bsd*,cygwin*,dgux*,darwin*,hpux*,hurd*,irix*,linux-g++$ARCH/linux-g++$ARCH,lynxos*,macx*,qnx*,reliant*,sco*,solaris*,tru64*,unixware*,win32*}
-# install man pages
+ # install man pages
install -d -m755 "${pkgdir}"/usr/share/man
cp -r "${srcdir}"/qt-x11-free-${pkgver}/doc/man/{man1,man3} "${pkgdir}"/usr/share/man/
for i in "${pkgdir}"/usr/share/man/man1/*; do
- mv $i ${i%.*}-qt3.1
+ mv "$i" "${i%.*}-qt3.1"
done
-# Useful symlinks for cmake and configure scripts
+ # Useful symlinks for cmake and configure scripts
install -d "${pkgdir}"/usr/bin
for b in "${pkgdir}"/usr/lib/qt3/bin/*; do
- ln -s /usr/lib/qt3/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt3
+ ln -s "/usr/lib/qt3/bin/$(basename "$b")" "${pkgdir}/usr/bin/$(basename "$b")-qt3"
done
}
diff --git a/eastern_asian_languagues.diff b/eastern_asian_languagues.diff
deleted file mode 100644
index 7c25eef7d532..000000000000
--- a/eastern_asian_languagues.diff
+++ /dev/null
@@ -1,39 +0,0 @@
---- qt-x11-free-3.3.8b/src/kernel/qfontdatabase.cpp 2008-01-15 21:09:13.000000000 +0200
-+++ qt-x11-free-3.3.8b/src/kernel/qfontdatabase.cpp 2008-03-10 11:34:22.000000000 +0200
-@@ -966,20 +966,22 @@
-
- #ifdef Q_WS_X11
- if (script == QFont::Han) {
-- // modify script according to locale
-- static QFont::Script defaultHan = QFont::UnknownScript;
-- if (defaultHan == QFont::UnknownScript) {
-- QCString locale = setlocale(LC_ALL, NULL);
-- if (locale.contains("ko"))
-- defaultHan = QFont::Han_Korean;
-- else if (locale.contains("zh_TW") || locale.contains("zh_HK"))
-- defaultHan = QFont::Han_TraditionalChinese;
-- else if (locale.contains("zh"))
-- defaultHan = QFont::Han_SimplifiedChinese;
-- else
-- defaultHan = QFont::Han_Japanese;
-- }
-- script = defaultHan;
-+ // modify script according to locale
-+ static QFont::Script defaultHan;
-+ QCString locale = setlocale(LC_ALL, NULL);
-+
-+ if (locale.contains("ko"))
-+ defaultHan = QFont::Han_Korean;
-+ else if (locale.contains("zh_TW") || locale.contains("zh_HK"))
-+ defaultHan = QFont::Han_TraditionalChinese;
-+ else if (locale.contains("zh"))
-+ defaultHan = QFont::Han_SimplifiedChinese;
-+ else if (locale.contains("ja"))
-+ defaultHan = QFont::Han_Japanese;
-+ else
-+ defaultHan = QFont::Han; // don't change
-+
-+ script = defaultHan;
- }
- #endif
-
diff --git a/gcc-4.6.patch b/gcc-4.6.patch
deleted file mode 100644
index bcbffcea6ab5..000000000000
--- a/gcc-4.6.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -up qt-x11-free-3.3.8b/src/tools/qmap.h.cstddef qt-x11-free-3.3.8b/src/tools/qmap.h
---- qt-x11-free-3.3.8b/src/tools/qmap.h.cstddef 2008-01-15 13:09:13.000000000 -0600
-+++ qt-x11-free-3.3.8b/src/tools/qmap.h 2011-01-30 21:14:29.275088725 -0600
-@@ -49,6 +49,7 @@
- #include "qvaluelist.h"
- #endif // QT_H
-
-+#include <cstddef>
- #ifndef QT_NO_STL
- #include <iterator>
- #include <map>
-diff -up qt-x11-free-3.3.8b/src/tools/qvaluelist.h.cstddef qt-x11-free-3.3.8b/src/tools/qvaluelist.h
---- qt-x11-free-3.3.8b/src/tools/qvaluelist.h.cstddef 2008-01-15 13:09:13.000000000 -0600
-+++ qt-x11-free-3.3.8b/src/tools/qvaluelist.h 2011-01-30 21:14:01.765846592 -0600
-@@ -47,6 +47,7 @@
- #include "qdatastream.h"
- #endif // QT_H
-
-+#include <cstddef>
- #ifndef QT_NO_STL
- #include <iterator>
- #include <list>
-diff -up qt-x11-free-3.3.8b/src/tools/qvaluevector.h.cstddef qt-x11-free-3.3.8b/src/tools/qvaluevector.h
---- qt-x11-free-3.3.8b/src/tools/qvaluevector.h.cstddef 2008-01-15 13:09:13.000000000 -0600
-+++ qt-x11-free-3.3.8b/src/tools/qvaluevector.h 2011-01-30 21:14:01.765846592 -0600
-@@ -45,6 +45,7 @@
- #include "qdatastream.h"
- #endif // QT_H
-
-+#include <cstddef>
- #ifndef QT_NO_STL
- #include <vector>
- #endif
diff --git a/qt-copy-kde-patches.tar.bz2 b/qt-copy-kde-patches.tar.bz2
deleted file mode 100644
index 519f7173ac9c..000000000000
--- a/qt-copy-kde-patches.tar.bz2
+++ /dev/null
Binary files differ
diff --git a/qt-odbc.patch b/qt-odbc.patch
deleted file mode 100644
index 6f21e3cf1ac1..000000000000
--- a/qt-odbc.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -up qt-x11-free-3.3.8/src/sql/drivers/odbc/qsql_odbc.cpp.orig qt-x11-free-3.3.8/src/sql/drivers/odbc/qsql_odbc.cpp
---- qt-x11-free-3.3.8/src/sql/drivers/odbc/qsql_odbc.cpp.orig 2009-02-24 11:32:27.000000000 +0100
-+++ qt-x11-free-3.3.8/src/sql/drivers/odbc/qsql_odbc.cpp 2009-02-24 11:33:43.000000000 +0100
-@@ -57,13 +57,13 @@
- #endif
-
- // newer platform SDKs use SQLLEN instead of SQLINTEGER
--#ifdef SQLLEN
-+#if defined(SQLLEN) || defined(Q_OS_WIN64) || defined(Q_OS_UNIX)
- # define QSQLLEN SQLLEN
- #else
- # define QSQLLEN SQLINTEGER
- #endif
-
--#ifdef SQLULEN
-+#if defined(SQLULEN) || defined(Q_OS_WIN64) || defined(Q_OS_UNIX)
- # define QSQLULEN SQLULEN
- #else
- # define QSQLULEN SQLUINTEGER
diff --git a/qt-patches.tar.bz2 b/qt-patches.tar.bz2
deleted file mode 100644
index 3f4aee171389..000000000000
--- a/qt-patches.tar.bz2
+++ /dev/null
Binary files differ
diff --git a/qt-x11-free-3.3.5-makelibshared.patch b/qt-x11-free-3.3.5-makelibshared.patch
deleted file mode 100644
index fd4adf7f0f55..000000000000
--- a/qt-x11-free-3.3.5-makelibshared.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- qt-x11-free-3.3.5/tools/assistant/lib/lib.pro.orig 2005-10-21 10:09:12.000000000 -0200
-+++ qt-x11-free-3.3.5/tools/assistant/lib/lib.pro 2005-10-21 10:09:34.000000000 -0200
-@@ -3,8 +3,7 @@
- VERSION = 1.0
-
- CONFIG += qt warn_on release
--CONFIG += staticlib
--CONFIG -= dll
-+CONFIG += dll
-
- SOURCES = qassistantclient.cpp
- HEADERS += $$QT_SOURCE_TREE/include/qassistantclient.h
-*** qt-x11-free-qt-copy-3.3.5/tools/designer/editor/editor.pro 2003-12-20 22:48:51.000000000 -0200
---- qt-x11-free-qt-copy-3.3.5/tools/designer/editor/editor.pro.new 2005-12-06 18:47:04.000000000 -0200
-***************
-*** 1,6 ****
- TEMPLATE = lib
-! CONFIG += qt warn_on staticlib
-! CONFIG -= dll
- HEADERS = editor.h \
- parenmatcher.h \
- completion.h \
---- 1,6 ----
- TEMPLATE = lib
-! CONFIG += qt warn_on
-! CONFIG += dll
- HEADERS = editor.h \
- parenmatcher.h \
- completion.h \
-*** qt-x11-free-qt-copy-3.3.5/tools/designer/designer/designer.pro 2004-04-29 19:31:32.000000000 -0300
---- qt-x11-free-qt-copy-3.3.5/tools/designer/designer/designer.pro.new 2005-12-06 18:46:29.000000000 -0200
-***************
-*** 1,7 ****
- TEMPLATE = lib
-
-! CONFIG += qt warn_on staticlib qmake_cache
-! CONFIG -= dll
- !force_static:!win32:contains(QT_PRODUCT,qt-internal) {
- CONFIG -= staticlib
- CONFIG += dll
---- 1,7 ----
- TEMPLATE = lib
-
-! CONFIG += qt warn_on qmake_cache
-! CONFIG += dll
- !force_static:!win32:contains(QT_PRODUCT,qt-internal) {
- CONFIG -= staticlib
- CONFIG += dll
diff --git a/qt3-fedora-patches.tar.bz2 b/qt3-fedora-patches.tar.bz2
new file mode 100644
index 000000000000..931f4f2b0c40
--- /dev/null
+++ b/qt3-fedora-patches.tar.bz2
Binary files differ
diff --git a/qt3-other-patches.tar.bz2 b/qt3-other-patches.tar.bz2
new file mode 100644
index 000000000000..07821192b814
--- /dev/null
+++ b/qt3-other-patches.tar.bz2
Binary files differ
diff --git a/qt3-png15.patch b/qt3-png15.patch
deleted file mode 100644
index e64fea36a480..000000000000
--- a/qt3-png15.patch
+++ /dev/null
@@ -1,212 +0,0 @@
-$NetBSD: patch-as,v 1.5 2011/03/25 15:28:26 wiz Exp $
-
---- src/kernel/qpngio.cpp.orig 2007-02-02 10:01:15.000000000 -0400
-+++ src/kernel/qpngio.cpp
-@@ -43,6 +43,7 @@
- #include "qiodevice.h"
-
- #include <png.h>
-+#include <zlib.h>
-
-
- #ifdef Q_OS_TEMP
-@@ -123,9 +124,24 @@ void setup_qt( QImage& image, png_struct
- png_get_IHDR(png_ptr, info_ptr, &width, &height, &bit_depth, &color_type,
- 0, 0, 0);
-
-+ png_colorp info_ptr_palette = NULL;
-+ int info_ptr_num_palette = 0;
-+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_PLTE)) {
-+ png_get_PLTE(png_ptr, info_ptr, &info_ptr_palette, &info_ptr_num_palette);
-+ }
-+
-+ png_bytep info_ptr_trans_alpha = NULL;
-+ int info_ptr_num_trans = 0;
-+ png_color_16p info_ptr_trans_color = NULL;
-+
-+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {
-+ png_get_tRNS(png_ptr, info_ptr, &info_ptr_trans_alpha, &info_ptr_num_trans, &info_ptr_trans_color);
-+ }
-+
-+
- if ( color_type == PNG_COLOR_TYPE_GRAY ) {
- // Black & White or 8-bit grayscale
-- if ( bit_depth == 1 && info_ptr->channels == 1 ) {
-+ if ( bit_depth == 1 && png_get_channels(png_ptr, info_ptr) == 1 ) {
- png_set_invert_mono( png_ptr );
- png_read_update_info( png_ptr, info_ptr );
- if (!image.create( width, height, 1, 2, QImage::BigEndian ))
-@@ -159,7 +175,7 @@ void setup_qt( QImage& image, png_struct
- image.setColor( i, qRgba(c,c,c,0xff) );
- }
- if ( png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS) ) {
-- const int g = info_ptr->trans_values.gray;
-+ const int g = info_ptr_trans_color->gray;
- if (g < ncols) {
- image.setAlphaBuffer(TRUE);
- image.setColor(g, image.color(g) & RGB_MASK);
-@@ -168,7 +184,7 @@ void setup_qt( QImage& image, png_struct
- }
- } else if ( color_type == PNG_COLOR_TYPE_PALETTE
- && png_get_valid(png_ptr, info_ptr, PNG_INFO_PLTE)
-- && info_ptr->num_palette <= 256 )
-+ && info_ptr_num_palette <= 256 )
- {
- // 1-bit and 8-bit color
- if ( bit_depth != 1 )
-@@ -176,28 +192,28 @@ void setup_qt( QImage& image, png_struct
- png_read_update_info( png_ptr, info_ptr );
- png_get_IHDR(png_ptr, info_ptr,
- &width, &height, &bit_depth, &color_type, 0, 0, 0);
-- if (!image.create(width, height, bit_depth, info_ptr->num_palette,
-+ if (!image.create(width, height, bit_depth, info_ptr_num_palette,
- QImage::BigEndian))
- return;
- int i = 0;
- if ( png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS) ) {
- image.setAlphaBuffer( TRUE );
-- while ( i < info_ptr->num_trans ) {
-+ while ( i < info_ptr_num_trans ) {
- image.setColor(i, qRgba(
-- info_ptr->palette[i].red,
-- info_ptr->palette[i].green,
-- info_ptr->palette[i].blue,
-- info_ptr->trans[i]
-+ info_ptr_palette[i].red,
-+ info_ptr_palette[i].green,
-+ info_ptr_palette[i].blue,
-+ info_ptr_trans_alpha[i]
- )
- );
- i++;
- }
- }
-- while ( i < info_ptr->num_palette ) {
-+ while ( i < info_ptr_num_palette ) {
- image.setColor(i, qRgba(
-- info_ptr->palette[i].red,
-- info_ptr->palette[i].green,
-- info_ptr->palette[i].blue,
-+ info_ptr_palette[i].red,
-+ info_ptr_palette[i].green,
-+ info_ptr_palette[i].blue,
- 0xff
- )
- );
-@@ -284,7 +300,7 @@ void read_png_image(QImageIO* iio)
- return;
- }
-
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
- iio->setStatus(-4);
- return;
-@@ -469,7 +485,7 @@ bool QPNGImageWriter::writeImage(const Q
- return FALSE;
- }
-
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_write_struct(&png_ptr, &info_ptr);
- return FALSE;
- }
-@@ -491,10 +507,16 @@ bool QPNGImageWriter::writeImage(const Q
-
- png_set_write_fn(png_ptr, (void*)this, qpiw_write_fn, qpiw_flush_fn);
-
-+#warning XXXtnn not too sure about this
-+/*
-+according to png.h, channels is only used on read, not writes, so we
-+should be able to comment this out.
-+
- info_ptr->channels =
- (image.depth() == 32)
- ? (image.hasAlphaBuffer() ? 4 : 3)
- : 1;
-+*/
-
- png_set_IHDR(png_ptr, info_ptr, image.width(), image.height(),
- image.depth() == 1 ? 1 : 8 /* per channel */,
-@@ -504,11 +526,12 @@ bool QPNGImageWriter::writeImage(const Q
- : PNG_COLOR_TYPE_RGB
- : PNG_COLOR_TYPE_PALETTE, 0, 0, 0);
-
-+ png_color_8 sig_bit;
-+ sig_bit.red = 8;
-+ sig_bit.green = 8;
-+ sig_bit.blue = 8;
-+ png_set_sBIT(png_ptr, info_ptr, &sig_bit);
-
-- //png_set_sBIT(png_ptr, info_ptr, 8);
-- info_ptr->sig_bit.red = 8;
-- info_ptr->sig_bit.green = 8;
-- info_ptr->sig_bit.blue = 8;
-
- if (image.depth() == 1 && image.bitOrder() == QImage::LittleEndian)
- png_set_packswap(png_ptr);
-@@ -522,11 +545,14 @@ bool QPNGImageWriter::writeImage(const Q
- png_set_PLTE(png_ptr, info_ptr, palette, num_palette);
- int* trans = new int[num_palette];
- int num_trans = 0;
-+ png_colorp info_ptr_palette = NULL;
-+ int tmp;
-+ png_get_PLTE(png_ptr, info_ptr, &info_ptr_palette, &tmp);
- for (int i=0; i<num_palette; i++) {
- QRgb rgb=image.color(i);
-- info_ptr->palette[i].red = qRed(rgb);
-- info_ptr->palette[i].green = qGreen(rgb);
-- info_ptr->palette[i].blue = qBlue(rgb);
-+ info_ptr_palette[i].red = qRed(rgb);
-+ info_ptr_palette[i].green = qGreen(rgb);
-+ info_ptr_palette[i].blue = qBlue(rgb);
- if (image.hasAlphaBuffer()) {
- trans[i] = rgb >> 24;
- if (trans[i] < 255) {
-@@ -534,6 +560,7 @@ bool QPNGImageWriter::writeImage(const Q
- }
- }
- }
-+ png_set_PLTE(png_ptr, info_ptr, info_ptr_palette, num_palette);
- if (num_trans) {
- copy_trans = new png_byte[num_trans];
- for (int i=0; i<num_trans; i++)
-@@ -544,7 +571,10 @@ bool QPNGImageWriter::writeImage(const Q
- }
-
- if ( image.hasAlphaBuffer() ) {
-- info_ptr->sig_bit.alpha = 8;
-+ png_color_8p sig_bit;
-+ png_get_sBIT(png_ptr, info_ptr, &sig_bit);
-+ sig_bit->alpha = 8;
-+ png_set_sBIT(png_ptr, info_ptr, sig_bit);
- }
-
- // Swap ARGB to RGBA (normal PNG format) before saving on
-@@ -1030,7 +1060,7 @@ int QPNGFormat::decode(QImage& img, QIma
- return -1;
- }
-
-- if (setjmp((png_ptr)->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_read_struct(&png_ptr, &info_ptr, 0);
- image = 0;
- return -1;
-@@ -1057,7 +1087,7 @@ int QPNGFormat::decode(QImage& img, QIma
-
- if ( !png_ptr ) return 0;
-
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_read_struct(&png_ptr, &info_ptr, 0);
- image = 0;
- state = MovieStart;
-@@ -1117,7 +1147,7 @@ void QPNGFormat::end(png_structp png, pn
- consumer->frameDone(QPoint(offx,offy),r);
- consumer->end();
- state = FrameStart;
-- unused_data = (int)png->buffer_size; // Since libpng doesn't tell us
-+ unused_data = png_process_data_pause(png, 0);
- }
-
- #ifdef PNG_USER_CHUNKS_SUPPORTED