summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryhfudev2015-06-09 12:37:45 -0400
committeryhfudev2015-06-09 12:37:45 -0400
commit7a17ff2b2f711651faf3bc1a66b5e91fb19527b8 (patch)
treed3bee4db7771d5a4cbe2da36ceffeea4109f0bcf
downloadaur-7a17ff2b2f711651faf3bc1a66b5e91fb19527b8.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD56
-rw-r--r--apache.example.conf15
-rw-r--r--nginx.example.conf7
-rw-r--r--webui-aria2.install7
6 files changed, 122 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..622f6c33dcef
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = webui-aria2
+ pkgdesc = Aria2 Web UI in pure HTML/CSS/Javascirpt
+ pkgver = 20140225
+ pkgrel = 1
+ url = https://github.com/ziahamza/webui-aria2
+ install = webui-aria2.install
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = webui-aria2
+ conflicts = webui-aria2
+ source = apache.example.conf
+ source = nginx.example.conf
+ source = webui-aria2.install
+
+pkgname = webui-aria2
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edfb0079604d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = webui-aria2
+ pkgdesc = Aria2 Web UI in pure HTML/CSS/Javascirpt
+ pkgver = 20140225
+ pkgrel = 1
+ url = https://github.com/ziahamza/webui-aria2
+ install = webui-aria2.install
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = webui-aria2
+ conflicts = webui-aria2
+ source = apache.example.conf
+ source = nginx.example.conf
+ source = webui-aria2.install
+ md5sums = 30500125861a5a0ccf6070aaec3eba51
+ md5sums = 99649ccdbf8b8e17ba1a2534550a0848
+ md5sums = c5b1c527ba1a95cfeb4c8dd653cacd07
+
+pkgname = webui-aria2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb39c25cb315
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Yunhui Fu
+
+pkgname="webui-aria2"
+pkgver=20140225
+pkgrel=1
+pkgdesc="Aria2 Web UI in pure HTML/CSS/Javascirpt"
+arch=(any)
+url="https://github.com/ziahamza/webui-aria2"
+license=("MIT")
+makedepends=("git")
+provides=("webui-aria2")
+conflicts=("webui-aria2")
+source=("apache.example.conf"
+ "nginx.example.conf"
+ "$pkgname.install")
+install=$pkgname.install
+
+_gitroot="https://github.com/ziahamza/webui-aria2.git"
+_gitname="webui-aria2"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+
+ mkdir -p "$pkgdir/usr/share/webapps/webui-aria2"
+ cp -r * "$pkgdir/usr/share/webapps/webui-aria2"
+
+ mkdir -p "$pkgdir/etc/webapps/webui-aria2"
+ cp ../*.example.conf "$pkgdir/etc/webapps/webui-aria2"
+
+ chown http:http -R "$pkgdir/usr/share/webapps/webui-aria2"
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('30500125861a5a0ccf6070aaec3eba51'
+ '99649ccdbf8b8e17ba1a2534550a0848'
+ 'c5b1c527ba1a95cfeb4c8dd653cacd07')
+
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..4db5143d022a
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,15 @@
+<IfModule alias_module>
+ Alias /webui-aria2 /usr/share/webapps/webui-aria2
+ <Directory "/usr/share/webapps/webui-aria2">
+ AllowOverride None
+ Options None
+ Order allow,deny
+ #Allow from all
+ Allow from 127.0.0.1 localhost
+
+ #AuthType Basic
+ #AuthName "Restricted Files"
+ #AuthUserFile htpasswd
+ #Require user foo
+ </Directory>
+</IfModule>
diff --git a/nginx.example.conf b/nginx.example.conf
new file mode 100644
index 000000000000..a8da779b7bb1
--- /dev/null
+++ b/nginx.example.conf
@@ -0,0 +1,7 @@
+location /webui-aria2/ {
+ allow 127.0.0.1;
+ deny all;
+
+ #auth_basic "Restricted";
+ #auth_basic_user_file htpasswd;
+}
diff --git a/webui-aria2.install b/webui-aria2.install
new file mode 100644
index 000000000000..74c43e04ce75
--- /dev/null
+++ b/webui-aria2.install
@@ -0,0 +1,7 @@
+post_install() {
+ ln -s /usr/share/webapps/webui-aria2 /srv/http/
+}
+
+post_remove() {
+ rm -f /srv/http/webui-aria2
+}