summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfoi2018-03-20 20:55:54 +0700
committerfoi2018-03-20 20:55:54 +0700
commit7a58e74e7330ab4a78d629345fc6c771f6564743 (patch)
tree8fc2f2b5b6b348d469da099f08ae0731164534b5
downloadaur-7a58e74e7330ab4a78d629345fc6c771f6564743.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a863e2ac8f05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = osquery-bin
+ pkgdesc = osquery is an operating system instrumentation framework.
+ pkgver = 2.11.2
+ pkgrel = 1
+ url = https://osquery.io/
+ arch = x86_64
+ license = Apache License 2.0
+ depends = glibc
+ depends = bash
+ depends = zlib
+ provides = osquery-git
+ provides = kolide-git
+ conflicts = osquery-git
+ conflicts = kolide-git
+ source = https://osquery-packages.s3.amazonaws.com/linux/osquery-2.11.2_1.linux_x86_64.tar.gz
+ sha256sums = 6b9f032bf04a0a938c4cd2a7f24f0f4fef1aca8593661f3801822760b178fdbd
+
+pkgname = osquery-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7224478d6eeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: foi <foi@live.ru>
+
+pkgname=osquery-bin
+pkgver=2.11.2
+pkgrel=1
+pkgdesc="osquery is an operating system instrumentation framework."
+arch=('x86_64')
+url="https://osquery.io/"
+license=('Apache License 2.0')
+provides=('osquery-git' 'kolide-git')
+depends=('glibc' 'bash' 'zlib')
+conflicts=('osquery-git' 'kolide-git')
+sha256sums=('6b9f032bf04a0a938c4cd2a7f24f0f4fef1aca8593661f3801822760b178fdbd')
+source=("https://osquery-packages.s3.amazonaws.com/linux/osquery-${pkgver}_${pkgrel}.linux_x86_64.tar.gz")
+
+package() {
+ cp -r etc "$pkgdir/"
+ cp -r usr "$pkgdir/"
+ cp -r var "$pkgdir/"
+}
+
+post_install() {
+ systemctl daemon-reload
+}