summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2019-08-10 02:33:29 +0100
committerJonathon Fernyhough2019-08-10 02:33:29 +0100
commit7a59abc02e59b6a01f99d71ba28ce3126094ed5a (patch)
treefc4faa878f0ff350fb86e6a72986a7487f7d1d2f
parent3b66f1f08fc40954db203d4c8dabbe1aeadf0e30 (diff)
downloadaur-7a59abc02e59b6a01f99d71ba28ce3126094ed5a.tar.gz
Point deps.jl to native libzmq.so library
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e2689a0c263..13f347d0651f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = julia-zmq
pkgdesc = Julia binding to the native API of ØMQ project
pkgver = 1.0.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/JuliaInterop/ZMQ.jl
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 66364424365f..532c4929d4f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=julia-zmq
_pkgname=ZMQ
pkgver=1.0.0
-pkgrel=5
+pkgrel=6
pkgdesc='Julia binding to the native API of ØMQ project'
arch=(any)
url=https://github.com/JuliaInterop/ZMQ.jl
@@ -32,6 +32,25 @@ _project() {
prepare() {
# Generate a Project.toml from Registry metadata
rm -f Project.toml && _project
+
+ cat >$_pkgname.jl-$pkgver/deps/deps.jl << 'EOF'
+if isdefined((@static VERSION < v"0.7.0-DEV.484" ? current_module() : @__MODULE__), :Compat)
+ import Compat.Libdl
+elseif VERSION >= v"0.7.0-DEV.3382"
+ import Libdl
+end
+const libzmq = "/usr/lib/libzmq.so"
+function check_deps()
+ global libzmq
+ if !isfile(libzmq)
+ error("$(libzmq) does not exist, please report an issue with this PKGBUILD")
+ end
+
+ if Libdl.dlopen_e(libzmq) in (C_NULL, nothing)
+ error("$(libzmq) cannot be opened, please report an issue with this PKGBUILD")
+ end
+end
+EOF
}
package() {