summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrantic10482021-08-12 13:57:35 +0800
committerfrantic10482021-08-12 13:57:35 +0800
commit7a67e236db19ec96c0ac2f799acef429dd605de1 (patch)
tree3e357ad0d45bcccf9a244895faabd47b247cdfa6
parent93f02d3722c064d98df37c1f63dab34b1b1d60b3 (diff)
downloadaur-7a67e236db19ec96c0ac2f799acef429dd605de1.tar.gz
upgpkg: code-transparent 1.59.0-1
update to 1.59 with jnbooth's patch reference: - https://aur.archlinux.org/packages/code-transparent/#comment-821427 - https://github.com/jnbooth/code-transparent/commit/d43d4cf0c0a7aa492055573d6e5b94fcc7539682
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--transparent.diff35
3 files changed, 43 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c64c9e19aa55..4f440a075b78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = code-transparent
pkgdesc = The Open Source build of Visual Studio Code (vscode) editor - with transparency enabled.
- pkgver = 1.56.2
- pkgrel = 2
+ pkgver = 1.59.0
+ pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-transparent.install
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = code-transparent
makedepends = npm
makedepends = python2
makedepends = yarn
- makedepends = nodejs-lts-dubnium
+ makedepends = nodejs-lts-fermium
depends = electron12
depends = libsecret
depends = libx11
@@ -23,7 +23,7 @@ pkgbase = code-transparent
provides = code
provides = vscode
conflicts = code
- source = code::git+https://github.com/microsoft/vscode.git#tag=1.56.2
+ source = code::git+https://github.com/microsoft/vscode.git#tag=1.59.0
source = code.js
source = code.sh
source = product_json.diff
@@ -33,7 +33,7 @@ pkgbase = code-transparent
sha512sums = 6e8ee1df4dd982434a8295ca99e786a536457c86c34212546e548b115081798c5492a79f99cd5a3f1fa30fb71d29983aaabc2c79f4895d4a709d8354e9e2eade
sha512sums = b8bdb0e53cf8748140ed444c9b02cb6a57a7e1e120d96861d4cc9f79744a987f0253c052a238c78aa2c3f86459c4afb6f3b687435f0588d8f640822a9908b257
sha512sums = b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7
- sha512sums = 1ad5dd5090f33fe4f45f13ac7f20384869bb26f5e207933de8bfdea503386a331be9fd233205502aa742a7b90a3c15f8bd02a70a3c046c759c59d0d0b9f7f4bc
+ sha512sums = 74f6b4a95cd7552e43bce3b6a0db72771741ccc141b2a46db3d8eee1157b4b47d5bb5d55ccfd60559f17d234f51f85de9dc52070be4865ee170a6e7d36a8d2f1
sha512sums = e662f0bf3f55a82ce9bce98f22c6be80ee83c1e2241d2eca596326478887ec6b73c7d0041903e17f35a424578ccc22674354931166dc7c7d7e76bb97135e009e
pkgname = code-transparent
diff --git a/PKGBUILD b/PKGBUILD
index a0d9ccd7f81e..a5d6d23f144b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,8 @@ pkgdesc='The Open Source build of Visual Studio Code (vscode) editor - with tran
# - fermium: 14
# Important: Remember to check https://github.com/microsoft/vscode/blob/master/.yarnrc (choose correct tag) for target electron version
_electron=electron12
-pkgver=1.56.2
-pkgrel=2
+pkgver=1.59.0
+pkgrel=1
arch=('x86_64')
url='https://github.com/microsoft/vscode'
license=('MIT')
@@ -23,7 +23,7 @@ depends=($_electron 'libsecret' 'libx11' 'libxkbfile' 'ripgrep')
optdepends=('bash-completion: Bash completions'
'zsh-completions: ZSH completitons'
'x11-ssh-askpass: SSH authentication')
-makedepends=('git' 'gulp' 'npm' 'python2' 'yarn' 'nodejs-lts-dubnium')
+makedepends=('git' 'gulp' 'npm' 'python2' 'yarn' 'nodejs-lts-fermium')
conflicts=('code')
provides=('code' 'vscode')
install='code-transparent.install'
@@ -37,7 +37,7 @@ sha512sums=('SKIP'
'6e8ee1df4dd982434a8295ca99e786a536457c86c34212546e548b115081798c5492a79f99cd5a3f1fa30fb71d29983aaabc2c79f4895d4a709d8354e9e2eade'
'b8bdb0e53cf8748140ed444c9b02cb6a57a7e1e120d96861d4cc9f79744a987f0253c052a238c78aa2c3f86459c4afb6f3b687435f0588d8f640822a9908b257'
'b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7'
- '1ad5dd5090f33fe4f45f13ac7f20384869bb26f5e207933de8bfdea503386a331be9fd233205502aa742a7b90a3c15f8bd02a70a3c046c759c59d0d0b9f7f4bc'
+ '74f6b4a95cd7552e43bce3b6a0db72771741ccc141b2a46db3d8eee1157b4b47d5bb5d55ccfd60559f17d234f51f85de9dc52070be4865ee170a6e7d36a8d2f1'
'e662f0bf3f55a82ce9bce98f22c6be80ee83c1e2241d2eca596326478887ec6b73c7d0041903e17f35a424578ccc22674354931166dc7c7d7e76bb97135e009e')
# Even though we don't officially support other archs, let's
diff --git a/transparent.diff b/transparent.diff
index 3043379192d2..d543f763d9d0 100644
--- a/transparent.diff
+++ b/transparent.diff
@@ -7,11 +7,44 @@ diff --git a/src/main.js b/src/main.js
+ // enable transparent
+ app.commandLine.appendSwitch('enable-transparent-visuals');
-+ app.commandLine.appendSwitch('disable-gpu');
++ app.commandLine.appendSwitch('use-gl', 'desktop');
+
// Support JS Flags
const jsFlags = getJSFlags(cliArgs);
if (jsFlags) {
+diff --git a/src/vs/platform/theme/electron-main/themeMainService.ts b/src/vs/platform/theme/electron-main/themeMainService.ts
+index 189811d6fdf..d10bd05bced 100644
+--- a/src/vs/platform/theme/electron-main/themeMainService.ts
++++ b/src/vs/platform/theme/electron-main/themeMainService.ts
+@@ -3,7 +3,7 @@
+ * Licensed under the MIT License. See License.txt in the project root for license information.
+ *--------------------------------------------------------------------------------------------*/
+
+-import { BrowserWindow, nativeTheme } from 'electron';
++import { nativeTheme } from 'electron';
+ import { isWindows, isMacintosh } from 'vs/base/common/platform';
+ import { IStateMainService } from 'vs/platform/state/electron-main/state';
+ import { createDecorator } from 'vs/platform/instantiation/common/instantiation';
+@@ -68,19 +68,6 @@ export class ThemeMainService implements IThemeMainService {
+ { key: THEME_WINDOW_SPLASH, data: splash }
+ ]);
+
+- // Update in opened windows
+- if (typeof windowId === 'number') {
+- this.updateBackgroundColor(windowId, splash);
+- }
+- }
+-
+- private updateBackgroundColor(windowId: number, splash: IPartsSplash): void {
+- for (const window of BrowserWindow.getAllWindows()) {
+- if (window.id === windowId) {
+- window.setBackgroundColor(splash.colorInfo.background);
+- break;
+- }
+- }
+ }
+
+ getWindowSplash(): IPartsSplash | undefined {
diff --git a/src/vs/platform/windows/electron-main/window.ts b/src/vs/platform/windows/electron-main/window.ts
--- a/src/vs/platform/windows/electron-main/window.ts
+++ b/src/vs/platform/windows/electron-main/window.ts