summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-18 16:19:09 +0100
committerAlexander F. Rødseth2019-03-18 16:19:09 +0100
commit7a6881c9787577d0681b8534ec2748a5bada3dd7 (patch)
tree0a3b5a0e9e34317b107f319d030d4fc7f376d09f
parent9e5445627dd4cc93aa25cee3f220f649b81eb88b (diff)
downloadaur-7a6881c9787577d0681b8534ec2748a5bada3dd7.tar.gz
Add optdep
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46399967e070..cddb9a0b6cd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Mar 18 13:18:06 UTC 2019
+# Mon Mar 18 15:19:02 UTC 2019
pkgbase = python-ludwig
pkgdesc = Train and test deep learning models
pkgver = 0.1.0
- pkgrel = 3
+ pkgrel = 5
url = https://github.com/uber/ludwig
arch = any
license = MIT
@@ -26,6 +26,8 @@ pkgbase = python-ludwig
depends = python-seaborn
depends = python-spacy-en_core_web_sm
depends = python-spacy>=2.0
+ depends = python2-numba
+ optdepends = ludwig-example: example use of Ludwig
source = git+https://github.com/uber/ludwig#tag=v0.1.0
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 60cca425b86d..9b14f7a357a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=python-ludwig
pkgver=0.1.0
-pkgrel=4
+pkgrel=5
pkgdesc='Train and test deep learning models'
arch=(any)
url='https://github.com/uber/ludwig'
license=(MIT)
depends=(cython python-cloudpickle python-dask python-h5py python-matplotlib python-numpy python-pandas python-scipy python-scikit-learn python-tqdm python-tabulate python-tensorflow python-yaml python-pytest python-scikit-image python-seaborn python-spacy-en_core_web_sm 'python-spacy>=2.0')
-# python2-numba is requored for the check() function in python-sparse to pass
-depends+=(python2-numba)
+depends+=(python2-numba) # python2-numba is requored for the check() function in python-sparse to pass
makedepends=(git)
+optdepends=('ludwig-example: example use of Ludwig')
source=("git+https://github.com/uber/ludwig#tag=v$pkgver")
sha256sums=('SKIP')
@@ -21,8 +21,11 @@ build() {
package() {
cd ludwig
+
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # fix issue where spacy >= 2.0 is not detected
find "$pkgdir" -name requires.txt -type f -exec sed -i '/spacy/d' {} \;
}