summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 15:52:47 +0200
committersl1pkn072015-06-08 15:52:47 +0200
commit7a6b6cf7095cc4aaeedff813f43dbc3e633a42e4 (patch)
treebc24e887e8bb5244d758b6a64be599ab2a09e75f
downloadaur-7a6b6cf7095cc4aaeedff813f43dbc3e633a42e4.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b980bfcfea94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = avxsynth-plugin-fft3dfilter-git
+ pkgdesc = Plugin for Avxsynth. fft3dfilter (GIT Version)
+ pkgver = 20120611.5c2028d
+ pkgrel = 1
+ url = https://github.com/fundies/fft3dfilter-linux
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = avxsynth
+ depends = fftw
+ provides = avxsynth-plugin-fft3dfilter
+ conflicts = avxsynth-plugin-fft3dfilter
+ source = fft3dfilter::git://github.com/fundies/fft3dfilter-linux.git
+ md5sums = SKIP
+
+pkgname = avxsynth-plugin-fft3dfilter-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa9cc38e3207
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=fft3dfilter
+pkgname=avxsynth-plugin-${_plug}-git
+pkgver=20120611.5c2028d
+pkgrel=1
+pkgdesc="Plugin for Avxsynth. ${_plug} (GIT Version)"
+arch=('i686' 'x86_64')
+url="https://github.com/fundies/fft3dfilter-linux"
+license=('GPL')
+depends=('avxsynth' 'fftw')
+makedepends=('git')
+provides=("avxsynth-plugin-${_plug}")
+conflicts=("avxsynth-plugin-${_plug}")
+
+source=("${_plug}::git://github.com/fundies/fft3dfilter-linux.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_gitname}"
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+build() {
+ cd "${_gitname}"
+ make
+}
+
+package(){
+ cd "${_gitname}"
+ install -Dm775 fft3dfilter.so "${pkgdir}/usr/lib/avxsynth/fft3dfilter.so"
+ install -Dm664 README "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/README"
+}
+