summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2022-12-27 22:12:25 +0100
committerMartin Diehl2022-12-28 00:06:09 +0100
commit7a7152eb0a81afddf98593fe3e8ee361c48ce92a (patch)
treeed15b1ff230bb615b68b2d74032620504d2383de
parent5fcc995a699afd1d7ab60d3539cc38e4ec43fd4a (diff)
downloadaur-7a7152eb0a81afddf98593fe3e8ee361c48ce92a.tar.gz
7.0.2
using CMake as build systems, headers are now in /usr/include, not /usr/include/scotch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD68
2 files changed, 20 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1dab6fb252d4..f53380b0c531 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = scotch
pkgdesc = Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps).
- pkgver = 7.0.1
+ pkgver = 7.0.2
pkgrel = 1
- url = https://gitlab.inria.fr/scotch/scotch
+ url = https//gitlab.inria.fr/scotch/scotch
arch = i686
arch = x86_64
license = custom:CeCILL-C
makedepends = gcc-fortran
+ makedepends = cmake
depends = zlib
depends = openmpi
depends = bzip2
@@ -18,7 +19,7 @@ pkgbase = scotch
conflicts = scotch_esmumps
conflicts = scotch_esmumps5
options = !emptydirs
- source = https://gitlab.inria.fr/scotch/scotch/-/archive/v7.0.1/scotch-v7.0.1.tar.gz
- sha256sums = 0618e9bc33c02172ea7351600fce4fccd32fe00b3359c4aabb5e415f17c06fed
+ source = https://gitlab.inria.fr/scotch/scotch/-/archive/v7.0.2/scotch-v7.0.2.tar.gz
+ sha256sums = 17db72097dea75522570fe26ece62d99d480a2ea49954181d87b3e1dc913e05b
pkgname = scotch
diff --git a/PKGBUILD b/PKGBUILD
index 5186862fb7eb..f603567bc500 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,78 +1,40 @@
# Maintainer: Martin Diehl <aur@martin-diehl.net>
# Contributor: Samuel Williams <samuel.williams@oriontransfer.co.nz>
pkgname=scotch
-pkgver=7.0.1
+pkgver=7.0.2
pkgrel=1
pkgdesc="Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps)."
-url="https://gitlab.inria.fr/scotch/scotch"
+url="https//gitlab.inria.fr/scotch/scotch"
license=("custom:CeCILL-C")
depends=('zlib' 'openmpi' 'bzip2')
-makedepends=('gcc-fortran')
+makedepends=('gcc-fortran' 'cmake')
provides=('ptscotch' 'ptscotch-openmpi' 'scotch_esmumps' 'scotch_ptesmumps')
conflicts=('ptscotch-openmpi' 'scotch_esmumps' 'scotch_esmumps5')
arch=('i686' 'x86_64')
source=("https://gitlab.inria.fr/scotch/scotch/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
-sha256sums=('0618e9bc33c02172ea7351600fce4fccd32fe00b3359c4aabb5e415f17c06fed')
+sha256sums=('17db72097dea75522570fe26ece62d99d480a2ea49954181d87b3e1dc913e05b')
options=(!emptydirs)
-prepare() {
- cd "${srcdir}/${pkgname}-v${pkgver}/src"
-
- [ -e Makefile.inc ] && rm Makefile.inc
- cp "Make.inc/Makefile.inc.${CARCH/_/-}_pc_linux2.shlib" Makefile.inc
-
- # Apply patch to fix shared library ldflags
- sed -i 's/$(AR) $(ARFLAGS) $(@) $(?)/$(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)/g' libscotch/Makefile
-
- # Use the CFLAGS defined /etc/makepkg.conf
- sed -i "s/-O3/${CFLAGS}/g" Makefile.inc
-
- # Fix C compiler
- sed -i "s/CCD\t.*=.*gcc/CCD = mpicc/" Makefile.inc
-
- # Also enable bzip2 compression
- sed -i "s/-DCOMMON_FILE_COMPRESS_GZ/-DCOMMON_FILE_COMPRESS_GZ -DCOMMON_FILE_COMPRESS_BZ2/" Makefile.inc
- sed -i "s/-lz/-lz -lbz2/" Makefile.inc
-
- # avoid SIGABRT in dgord, https://stackoverflow.com/questions/38269659
- sed -i "s/-DSCOTCH_PTHREAD/-DSCOTCH_PTHREAD -DSCOTCH_PTHREAD_MPI/" Makefile.inc
-
- # Fix the creation of directories
- sed -i "s/mkdir/mkdir\ -p/" Makefile.inc
-
- # To install headers and libs also for esmumps
- sed -i 's/scotch\*/{scotch,esmumps}\*/g' Makefile
+prepare(){
+ sed -i 's/DESTINATION man/DESTINATION share\/man/g' ${pkgname}-v${pkgver}/CMakeLists.txt
}
-
-build() {
- cd "${srcdir}/${pkgname}-v${pkgver}/src"
-
- make scotch
- make -j1 esmumps
- make ptscotch
- make -j1 ptesmumps
+build() {
+ cmake -S ${pkgname}-v${pkgver} -B build -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=ON -DINSTALL_METIS_HEADERS=OFF
+ cmake --build build --parallel
}
-
+
check() {
- cd "${srcdir}/${pkgname}-v${pkgver}/src"
-
if [ -z $(ldconfig -p | grep libcuda.so.1) ]; then
- export OMPI_MCA_opal_warn_on_missing_libcuda=0
+ export _libcuda=0
fi
- make check FC=gfortran LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../../lib"
- make ptcheck FC=mpifort LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../../lib"
+ cmake --build build --parallel --target test
}
-
+
package() {
- cd "${srcdir}/${pkgname}-v${pkgver}/src"
-
- make install prefix="${pkgdir}/usr" includedir="${pkgdir}/usr/include/scotch"
-
+ DESTDIR=${pkgdir} cmake --install build
# To avoid conflict with extra/gpart, maybe move the package to /opt/scotch ?
- mv "${pkgdir}/usr/bin/gpart" "${pkgdir}/usr/bin/gpart-scotch"
-
- install -m 644 -D "../doc/CeCILL-C_V1-en.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m 644 -D "${pkgname}-v${pkgver}/doc/CeCILL-C_V1-en.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}