summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-11 08:27:21 +1100
committerPumpkinCheshire2020-11-11 08:27:21 +1100
commit7aaf31a80c07c77fc987bc487d973d6f52e9f59f (patch)
tree2d2ba0c4c361ea5ffa2f9ab761ae650403730d7b
parenta2bda76b6cc188964738e0eb2aa1f6339fedf247 (diff)
downloadaur-7aaf31a80c07c77fc987bc487d973d6f52e9f59f.tar.gz
fix optdepends
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD8
3 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94b7824a1862..a041d602da5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-mapclassify
pkgdesc = Classification schemes for choropleth mapping.
pkgver = 2.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pysal/mapclassify
arch = any
license = BSD
@@ -17,11 +17,11 @@ pkgbase = python-mapclassify
optdepends = python-sphinxcontrib-bibtex: documents
optdepends = python-numpydoc: documents
optdepends = python-pytest: tests
- optdepends = pytest-cov: tests
+ optdepends = python-pytest-cov: tests
optdepends = python-codecov: tests
optdepends = python-geopandas: tests
- optdepends = libpysal: tests
- optdepends = palettable: tests
+ optdepends = python-libpysal: tests
+ optdepends = python-palettable: tests
source = https://files.pythonhosted.org/packages/source/m/mapclassify/mapclassify-2.3.0.tar.gz
sha256sums = bfe1ec96afe7f866560d25f9f00e5c4dae97d5b69dfe758dbe02c4993261365b
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..78b3a645e298
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*.log
+*.rpm
+*.deb
+*.tar*
+*.gz
+*.zip
+*.run
+*.whl
+*.AppImage
+*.jar
+*.tgz
+*.pdf
+
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 9f8b62f86d33..49bcd55772ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=mapclassify
pkgname=python-mapclassify
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Classification schemes for choropleth mapping."
arch=('any')
url="https://github.com/pysal/mapclassify"
@@ -15,11 +15,11 @@ optdepends=('python-sphinx: documents'
'python-sphinxcontrib-bibtex: documents'
'python-numpydoc: documents'
'python-pytest: tests'
- 'pytest-cov: tests'
+ 'python-pytest-cov: tests'
'python-codecov: tests'
'python-geopandas: tests'
- 'libpysal: tests'
- 'palettable: tests')
+ 'python-libpysal: tests'
+ 'python-palettable: tests')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha256sums=('bfe1ec96afe7f866560d25f9f00e5c4dae97d5b69dfe758dbe02c4993261365b')