summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2018-05-15 12:38:52 -0600
committerSam Burgos2018-05-15 12:38:52 -0600
commit7ae0f66fcd90c29db4462ee89295510654b0ecf3 (patch)
treeb7c8a2068a6fa9f68655cb12f86c9ab36fcb7656
downloadaur-7ae0f66fcd90c29db4462ee89295510654b0ecf3.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD44
-rw-r--r--add_cinnamon_settings_online_support.patch26
-rw-r--r--null-icaltime.diff14
4 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71ee6c8af792
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = gnome-calendar-linuxmint
+ pkgdesc = Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches
+ pkgver = 3.28.2
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Calendar
+ arch = x86_64
+ license = GPL
+ makedepends = python
+ makedepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ makedepends = gtk-doc
+ makedepends = evolution
+ makedepends = evolution-data-server
+ depends = gsettings-desktop-schemas
+ depends = libdazzle
+ provides = gnome-calendar
+ conflicts = gnome-calendar
+ source = git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=c4d1f984758e77787ef97b71fe2dede8477809c2
+ source = null-icaltime.diff
+ source = add_cinnamon_settings_online_support.patch
+ sha256sums = SKIP
+ sha256sums = c1aa738a4ff275f725d0aa5406312600503b2b59270448a9e6b30b82a924dc27
+ sha256sums = 2445f754a044dd1ccb8c948b5d5b43248b61ec3570fc76416f74148abc5abf4d
+
+pkgname = gnome-calendar-linuxmint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a53cffc0fa2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Sam Burgos < sam dot burgos1089 at gmail dot com >
+
+pkgname=gnome-calendar-linuxmint
+_pkgname=gnome-calendar
+pkgver=3.28.2
+pkgrel=1
+pkgdesc="Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches"
+url="https://wiki.gnome.org/Apps/Calendar"
+arch=(x86_64)
+license=(GPL)
+depends=(gsettings-desktop-schemas libdazzle)
+makedepends=(python appstream-glib git meson gtk-doc evolution evolution-data-server)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+_commit=c4d1f984758e77787ef97b71fe2dede8477809c2 # tags/3.28.2^0
+source=("git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit"
+ null-icaltime.diff
+ add_cinnamon_settings_online_support.patch)
+sha256sums=('SKIP'
+ 'c1aa738a4ff275f725d0aa5406312600503b2b59270448a9e6b30b82a924dc27'
+ '2445f754a044dd1ccb8c948b5d5b43248b61ec3570fc76416f74148abc5abf4d')
+
+prepare() {
+ cd $_pkgname
+ #Set datetime to NULL in case there is no available date
+ patch -Np1 -i ../null-icaltime.diff
+
+ #Add support so that gnome-calendar can call this when run within Cinnamon by calling cinnamon-settings online-accounts
+ patch -Np1 -i ../add_cinnamon_settings_online_support.patch
+}
+
+build() {
+ arch-meson $_pkgname build -D gtk_doc=true
+ ninja -C build
+}
+
+check() {
+ cd build
+ meson test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
diff --git a/add_cinnamon_settings_online_support.patch b/add_cinnamon_settings_online_support.patch
new file mode 100644
index 000000000000..e1aae0c00644
--- /dev/null
+++ b/add_cinnamon_settings_online_support.patch
@@ -0,0 +1,26 @@
+--- src/gcal-source-dialog.c
++++ src/gcal-source-dialog.c
+@@ -696,6 +696,17 @@
+ const gchar *arg)
+ {
+ GDBusProxy *proxy;
++ gchar *desktop_environment;
++
++ desktop_environment = getenv ("XDG_CURRENT_DESKTOP");
++ if (desktop_environment)
++ {
++ if (g_strcmp0 (desktop_environment, "X-Cinnamon") == 0 || g_strcmp0 (desktop_environment, "Cinnamon") == 0)
++ {
++ g_spawn_command_line_async ("cinnamon-settings online-accounts", NULL);
++ return;
++ }
++ }
+
+ proxy = g_dbus_proxy_new_for_bus_sync (G_BUS_TYPE_SESSION,
+ G_DBUS_PROXY_FLAGS_NONE,
+@@ -2338,4 +2349,4 @@
+ g_return_if_fail (source && E_IS_SOURCE (source));
+
+ g_set_object (&dialog->source, source);
+-}
++}
diff --git a/null-icaltime.diff b/null-icaltime.diff
new file mode 100644
index 000000000000..60539d9bdb12
--- /dev/null
+++ b/null-icaltime.diff
@@ -0,0 +1,14 @@
+diff --git i/src/gcal-utils.c w/src/gcal-utils.c
+index c7646565..8070034c 100644
+--- i/src/gcal-utils.c
++++ w/src/gcal-utils.c
+@@ -181,6 +181,9 @@ icaltime_to_datetime (const icaltimetype *date)
+ GDateTime *dt;
+ GTimeZone *tz;
+
++ if (!date)
++ return NULL;
++
+ tz = date->zone ? g_time_zone_new (icaltime_get_tzid (*date)) : g_time_zone_new_utc ();
+ dt = g_date_time_new (tz,
+ date->year,