summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-17 07:10:51 +0100
committerGustavo Alvarez2016-01-17 07:10:51 +0100
commit7aef7c146762cf9f659bb77213e06ab631d16967 (patch)
tree2f76731075a2f930f9f7ded3107731df7196da52
downloadaur-7aef7c146762cf9f659bb77213e06ab631d16967.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a7760303063
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jan 17 06:10:51 UTC 2016
+pkgbase = vapoursynth-plugin-mcdegrainsharp-git
+ pkgdesc = Plugin for Vapoursynth: mcdegrainsharp (GIT version)
+ pkgver = r4
+ pkgrel = 1
+ url = https://gist.github.com/4re
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-genericfilters-git
+ depends = vapoursynth-plugin-mvtools
+ provides = vapoursynth-plugin-mcdegrainsharp
+ conflicts = vapoursynth-plugin-mcdegrainsharp
+ source = mcdegrainsharp::git+https://gist.github.com/b5399b1801072458fc80.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-mcdegrainsharp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f61ee391ff02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=mcdegrainsharp
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r4
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://gist.github.com/4re'
+license=('GPL')
+depends=('vapoursynth-plugin-genericfilters-git'
+ 'vapoursynth-plugin-mvtools'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://gist.github.com/b5399b1801072458fc80.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+}