summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-04-11 12:40:06 -0500
committerDan Beste2017-04-11 12:40:34 -0500
commit7af8c6ad1d5760f5290ca9d6b54a836ca7e6da36 (patch)
tree17a7561ed1a36259e2b93d3302689ffe0e0b6825
downloadaur-7af8c6ad1d5760f5290ca9d6b54a836ca7e6da36.tar.gz
Init
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD50
-rwxr-xr-xgog-yooka-laylee24
-rw-r--r--gog-yooka-laylee.desktop10
5 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9a924d18df1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gog-yooka-laylee
+ pkgdesc = Yooka-Laylee is an all-new open-world platformer from key creative talent behind the Banjo-Kazooie and Donkey Kong Country games!
+ pkgver = 2.0.0.1
+ pkgrel = 1
+ url = http://www.playtonicgames.com/games/yooka-laylee/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sdl2
+ optdepends = firejail: Automatically sandbox this application from your OS
+ source = gog://gog_yooka_laylee_2.0.0.1.sh
+ source = gog-yooka-laylee.desktop
+ source = gog-yooka-laylee
+ sha256sums = SKIP
+ sha256sums = eab3d609d3146cb69b32e9b9c894164323c3eab45628a33e9d1e6e75cd9ebbca
+ sha256sums = 4e4c5428a1d929007fea2204b688a4dcd97a13c992b5f92a0c7866f11adc8adc
+
+pkgname = gog-yooka-laylee
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3745bb129131
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!gog-yooka-laylee
+!gog-yooka-laylee.desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5b629917b7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+# Thanks to: Ainola for the base PKGBUILD (gog-undertale)
+
+pkgname=gog-yooka-laylee
+pkgver=2.0.0.1
+pkgrel=1
+pkgdesc="Yooka-Laylee is an all-new open-world platformer from key creative talent behind the Banjo-Kazooie and Donkey Kong Country games!"
+url="http://www.playtonicgames.com/games/yooka-laylee/"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('sdl2')
+optdepends=('firejail: Automatically sandbox this application from your OS')
+source=(
+ "gog://${pkgname//-/_}_${pkgver}.sh"
+ "${pkgname}.desktop"
+ "${pkgname}"
+)
+sha256sums=(
+ 'SKIP'
+ 'eab3d609d3146cb69b32e9b9c894164323c3eab45628a33e9d1e6e75cd9ebbca'
+ '4e4c5428a1d929007fea2204b688a4dcd97a13c992b5f92a0c7866f11adc8adc'
+)
+DLAGENTS=(
+ "gog::/usr/bin/echo %u Download the GOG file to $PWD or set up a gog:// DLAGENT."
+)
+
+package(){
+ cd "${srcdir}"
+
+ # Install game
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support"
+ install -d "${pkgdir}/usr/bin/"
+ cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
+
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+ install -Dm755 "data/noarch/start.sh" "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 data/noarch/support/*.{sh,shlib} -t \
+ "${pkgdir}/opt/${pkgname}/support"
+
+ # Desktop integration
+ install -Dm 644 "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm755 "${srcdir}/${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/gog-yooka-laylee b/gog-yooka-laylee
new file mode 100755
index 000000000000..1222f7eeec93
--- /dev/null
+++ b/gog-yooka-laylee
@@ -0,0 +1,24 @@
+#! /bin/bash
+
+pkgname='gog-yooka-laylee'
+pkgdir="/opt/${pkgname}/"
+run="${pkgdir}/start.sh"
+
+if hash firejail; then
+ echo "Firejail detected; attempting to enforce a sandbox..."
+ if [[ -f "${XDG_CONFIG_HOME}/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in ${XDG_CONFIG_HOME}/firejail/"
+ echo "Enforcing a sandbox!"
+ firejail "${run}"
+ elif [[ -f "/etc/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in /etc/firejail/"
+ echo "Enforcing a sandbox!"
+ firejail "${run}"
+ else
+ echo "No Firejail profile detected!"
+ echo "Skipping Firejail sandbox..."
+ "${run}"
+ fi
+else
+ "${run}"
+fi
diff --git a/gog-yooka-laylee.desktop b/gog-yooka-laylee.desktop
new file mode 100644
index 000000000000..77fe3466fb00
--- /dev/null
+++ b/gog-yooka-laylee.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=YOOKA-LAYLEE
+Comment=Yooka-Laylee is an all-new open-world platformer from key creative talent behind the Banjo-Kazooie and Donkey Kong Country games!
+Exec=gog-yooka-laylee
+Icon=gog-yooka-laylee
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;AudioVideo;
+Encoding=UTF-8