summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2022-03-17 17:12:27 +0100
committerFrank Siegert2022-03-17 17:12:27 +0100
commit7b190ad2469a304b535d7f2f8e956a60f9890c47 (patch)
tree5c78543f591b001b38eb1dab127106475d51ef4d
parentd9fecdcd374844f3b5480e2707dfd645499879d0 (diff)
downloadaur-7b190ad2469a304b535d7f2f8e956a60f9890c47.tar.gz
Update to 3.1.5-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7431023ca2d..ef17f00683ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rivet
pkgdesc = A particle physics package for data analysis and validation of Monte Carlo event generators
- pkgver = 3.1.4
+ pkgver = 3.1.5
pkgrel = 1
url = http://rivet.hepforge.org
arch = x86_64
@@ -16,9 +16,9 @@ pkgbase = rivet
optdepends = texlive-core: Plotting functionality
optdepends = ghostscript: PDF plot output
optdepends = imagemagick: PNG plot output
- optdepends = python2: For Python2 module in addition to Python3
- source = http://www.hepforge.org/archive/rivet/Rivet-3.1.4.tar.gz
- md5sums = 43ff4bcab2209d483417ed878d1e6483
+ source = http://www.hepforge.org/archive/rivet/Rivet-3.1.5.tar.gz
+ source = https://gitlab.com/hepcedar/rivet/-/commit/efb47ae662431c08ae4deec046bff0c56a8119ab.diff
+ md5sums = 7f3397b16386c0bfcb49420c2eb395b1
+ md5sums = f2ffdbf1800e2ba8eec23e10d3785d33
pkgname = rivet
-
diff --git a/PKGBUILD b/PKGBUILD
index 3a632d76826c..65edde1b0cac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=rivet
-pkgver=3.1.4
+pkgver=3.1.5
pkgrel=1
pkgdesc="A particle physics package for data analysis and validation of Monte Carlo event generators"
arch=('x86_64' 'i686')
@@ -9,24 +9,19 @@ license=('GPL3')
depends=('python' 'yoda>=1.8.0' 'fastjet' 'gsl' 'hepmc' 'fastjet-contrib')
optdepends=('texlive-core: Plotting functionality'
'ghostscript: PDF plot output'
- 'imagemagick: PNG plot output'
- 'python2: For Python2 module in addition to Python3')
+ 'imagemagick: PNG plot output')
makedepends=('cython')
source=(http://www.hepforge.org/archive/rivet/Rivet-$pkgver.tar.gz
+ https://gitlab.com/hepcedar/rivet/-/commit/efb47ae662431c08ae4deec046bff0c56a8119ab.diff
)
-md5sums=('43ff4bcab2209d483417ed878d1e6483')
+md5sums=('7f3397b16386c0bfcb49420c2eb395b1'
+ 'f2ffdbf1800e2ba8eec23e10d3785d33')
package() {
cd "$srcdir/Rivet-$pkgver"
+ patch -p1 < $srcdir/efb47ae662431c08ae4deec046bff0c56a8119ab.diff
+ autoreconf -i
- # If python2 is present, also build a library for it
- # Have to do this first, such that files like rivet-config get overwritten with the "proper" Python3 version
- if [ -x /usr/bin/python2 ]; then
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr --with-hepmc3=/usr
- make DESTDIR="$pkgdir/" install
- make clean
- fi
-
./configure --prefix=/usr --with-hepmc3=/usr
make
make DESTDIR="$pkgdir/" install