summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-11-18 21:37:57 +0100
committerM0Rf302019-11-18 21:37:57 +0100
commit7b1e36b3c00dd29afdcdb58c7db22ab1ed24288c (patch)
treeeb680fe3c1538ba0f76f7e7fd0dc4df796f869e0
parent37771efbebbfc2f9e475d188d2dd3453caf25e79 (diff)
downloadaur-7b1e36b3c00dd29afdcdb58c7db22ab1ed24288c.tar.gz
xash3d-hlsdk: updated
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3a5df80a96c..cfa0f0cc104b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xash3d-hlsdk
pkgdesc = Half-Life SDK from original Xash3D engine
- pkgver = r322.43d63a1
+ pkgver = r428.52b067fd
pkgrel = 1
url = http://xash.su/
arch = i686
@@ -9,11 +9,9 @@ pkgbase = xash3d-hlsdk
makedepends = make
makedepends = binutils
makedepends = cmake
+ makedepends = gcc
source = xash3d-hlsdk::git+https://github.com/FWGS/hlsdk-xash3d
md5sums = SKIP
- makedepends_i686 = gcc
- makedepends_x86_64 = gcc-multilib
- makedepends_x86_64 = lib32-gcc-libs
pkgname = xash3d-hlsdk
diff --git a/PKGBUILD b/PKGBUILD
index f1d860888eb5..387796474406 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: robertfoster
pkgname=xash3d-hlsdk
-pkgver=r322.43d63a1
+pkgver=r428.52b067fd
pkgrel=1
pkgdesc="Half-Life SDK from original Xash3D engine"
arch=('i686' 'x86_64')
url="http://xash.su/"
license=('GPL3')
-makedepends=('make' 'binutils' 'cmake')
-makedepends_i686=('gcc')
-makedepends_x86_64=('gcc-multilib' 'lib32-gcc-libs')
+makedepends=('make' 'binutils' 'cmake' 'gcc')
source=("$pkgname::git+https://github.com/FWGS/hlsdk-xash3d")
+_args="--libdir=/usr/lib \
+--build-type=release"
+
+if [ $CARCH == "x86_64" ]; then
+ _args+=" -8"
+fi
+
pkgver() {
cd $srcdir/$pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -20,24 +25,17 @@ pkgver() {
prepare() {
cd $srcdir/$pkgname
git submodule init && git submodule update
+ ./waf configure ${_args}
}
build() {
cd $srcdir/$pkgname
- if [ -d build ]; then
- rm -rf build
- fi
- mkdir build
- cd build
- cmake ../ -DCMAKE_INSTALL_PREFIX="/usr/lib32"
- make
-
+ ./waf build
}
package() {
cd $srcdir/$pkgname/
- cd build
- make DESTDIR=$pkgdir install
+ ./waf install --destdir="$pkgdir/usr/lib"
}
md5sums=('SKIP')