summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzebulon2021-06-01 06:45:23 +0200
committerzebulon2021-06-01 06:45:23 +0200
commit7b45f3be6e5f495f83b5669e16257425abc0f768 (patch)
tree0eb1d878098b3821fe5816e153f6f2245ef37a1d
parent277577d51047c357b617c57e946d9689e60a254f (diff)
downloadaur-7b45f3be6e5f495f83b5669e16257425abc0f768.tar.gz
new driver v5.8.5.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c55b76ea98ea..51b716edf808 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = rtl8814au-dkms-git
- pkgdesc = RTL8814AU and RTL8813AU chipset driver with firmware v4.3.21
- pkgver = 4.3.21.r34.ga0c4479
- pkgrel = 2
- url = https://github.com/zebulon2/rtl8814au
+ pkgdesc = RTL8814AU and RTL8813AU chipset driver with firmware v5.8.5.1
+ pkgver = 5.8.5.1.r98.gc5fd13c
+ pkgrel = 1
+ url = https://github.com/morrownr/8814au
arch = x86_64
arch = i686
arch = arm
@@ -14,7 +14,7 @@ pkgbase = rtl8814au-dkms-git
depends = dkms
depends = bc
conflicts = rtl8814au
- source = git+https://github.com/zebulon2/rtl8814au.git
+ source = git+https://github.com/morrownr/8814au.git
source = dkms.conf
source = arm.patch
sha256sums = SKIP
@@ -22,4 +22,3 @@ pkgbase = rtl8814au-dkms-git
sha256sums = 2911f6c1285277d0507b2ad7a09c20edd682476be67502db63f63663cac97efb
pkgname = rtl8814au-dkms-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3087678774a3..3b16d1391113 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,16 @@
pkgname=rtl8814au-dkms-git
_pkgbase=rtl8814au
-pkgver=4.3.21.r34.ga0c4479
-pkgrel=2
-pkgdesc="RTL8814AU and RTL8813AU chipset driver with firmware v4.3.21"
+pkgver=5.8.5.1.r98.gc5fd13c
+pkgrel=1
+pkgdesc="RTL8814AU and RTL8813AU chipset driver with firmware v5.8.5.1"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/zebulon2/rtl8814au"
+url="https://github.com/morrownr/8814au"
license=('GPL2')
depends=('dkms' 'bc')
makedepends=('git')
conflicts=("${_pkgbase}")
-source=("git+https://github.com/zebulon2/rtl8814au.git"
+source=("git+https://github.com/morrownr/8814au.git"
'dkms.conf'
'arm.patch')
sha256sums=('SKIP'
@@ -21,8 +21,8 @@ sha256sums=('SKIP'
'2911f6c1285277d0507b2ad7a09c20edd682476be67502db63f63663cac97efb')
pkgver() {
- cd ${srcdir}/rtl8814au
- printf '%s.r%s.g%s' '4.3.21' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${srcdir}/8814au
+ printf '%s.r%s.g%s' '5.8.5.1' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
@@ -30,7 +30,7 @@ package() {
msg2 "Applying patch for ARM architecture..."
patch ${srcdir}/rtl8814au/Makefile -i ${srcdir}/arm.patch
fi
- cd ${srcdir}/rtl8814au
+ cd ${srcdir}/8814au
mkdir -p ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
cp -pr * ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
cp ${srcdir}/dkms.conf ${pkgdir}/usr/src/${_pkgbase}-${pkgver}