summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-07-24 21:51:54 +0200
committerCarl Smedstad2023-07-24 21:52:43 +0200
commit7bb6206c24e3aa41f4a4d7add9da7511e6255a9a (patch)
tree77d37471fae2fe433511184cbfe344023aa5b748
parent90e89bcfecf7e2d84ac4cdefc03f35530ffc7702 (diff)
downloadaur-7bb6206c24e3aa41f4a4d7add9da7511e6255a9a.tar.gz
Publish version 0.2.11-2 - PEP 517 & missing dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2540d7ecfa1b..e840c0e45778 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = python-xhtml2pdf
pkgdesc = A library for converting HTML into PDFs using ReportLab
pkgver = 0.2.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xhtml2pdf/xhtml2pdf
arch = any
license = Apache
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
depends = python-arabic-reshaper
+ depends = python-asn1crypto
depends = python-bidi
depends = python-html5lib
depends = python-pillow
diff --git a/PKGBUILD b/PKGBUILD
index f5e54c3de401..18d713d6c523 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,15 @@
pkgname=python-xhtml2pdf
_name=${pkgname#python-}
pkgver=0.2.11
-pkgrel=1
+pkgrel=2
pkgdesc="A library for converting HTML into PDFs using ReportLab"
arch=(any)
url="https://github.com/xhtml2pdf/xhtml2pdf"
license=(Apache)
depends=(
+ python
python-arabic-reshaper
+ python-asn1crypto
python-bidi
python-html5lib
python-pillow
@@ -22,7 +24,10 @@ depends=(
python-svglib
)
makedepends=(
+ python-build
+ python-installer
python-setuptools
+ python-wheel
# python-sphinx_rtd_theme
# python-sphinxcontrib-pdfembed
# texlive-latexextra
@@ -49,7 +54,8 @@ prepare() {
build() {
cd "$_archive"
- python setup.py build
+ python -m build --wheel --no-isolation
+
#(cd docs && make html)
#(cd docs && make latexpdf)
}
@@ -63,8 +69,7 @@ check() {
package() {
cd "$_archive"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
# mkdir -p ${pkgdir}/usr/share/doc/${pkgname}
# cp ${srcdir}/${_name}-${pkgver}/docs/build/html ${pkgdir}/usr/share/doc/${pkgname} -R