summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViech2018-08-26 14:10:32 +0200
committerViech2018-08-26 14:12:32 +0200
commit7bc33f1f51314c0e3e27a1153ff890e8f847e9b0 (patch)
tree8168d9822f843ad6c4ab5647a89b1a71b9e5812f
downloadaur-7bc33f1f51314c0e3e27a1153ff890e8f847e9b0.tar.gz
Initial package.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d69d307434f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Aug 26 12:12:27 UTC 2018
+pkgbase = crunch-unv-git
+ pkgdesc = DXTn texture compression tool. Modified version from Unvanquished Development.
+ pkgver = daemon.17.g95415e8
+ pkgrel = 1
+ url = https://github.com/DaemonEngine/crunch
+ arch = x86_64
+ arch = i686
+ license = ZLIB
+ makedepends = git
+ depends = glibc
+ source = crunch::git+https://github.com/DaemonEngine/crunch.git
+ md5sums = SKIP
+
+pkgname = crunch-unv-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1f782615a193
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/src
+/crunch
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f148b0817105
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Viech <viech unvanquished net>
+
+pkgname=crunch-unv-git
+pkgver=daemon.17.g95415e8
+pkgrel=1
+pkgdesc='DXTn texture compression tool. Modified version from Unvanquished Development.'
+arch=('x86_64' 'i686')
+url='https://github.com/DaemonEngine/crunch'
+license=('ZLIB')
+makedepends=('git')
+depends=('glibc')
+source=("crunch::git+https://github.com/DaemonEngine/crunch.git")
+
+pkgver() {
+ cd "${srcdir}/crunch/"
+ local ver="$(git describe --tags --long)"
+ printf "%s" "${ver//-/.}"
+}
+
+build() {
+ cd "${srcdir}/crunch/crnlib"
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin" "${pkgdir}/usr/share/licenses/crunch"
+
+ install -m755 "${srcdir}/crunch/crnlib/crunch" "${pkgdir}/usr/bin/crunch"
+ install -m644 "${srcdir}/crunch/license.txt" "${pkgdir}/usr/share/licenses/crunch/LICENSE"
+}
+
+md5sums=('SKIP')