summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-05-08 17:20:30 -0600
committerBrian Bidulock2018-06-01 14:37:44 -0600
commit7bd8e965e66f0bdb55a49a37c5ec9c8ae64bcfd6 (patch)
treef8c6d4f989be4fcb46d159b6ac7ca0161bedc407
parentf88c3466e05822dd680df39222a383b8fb5bcaaf (diff)
downloadaur-7bd8e965e66f0bdb55a49a37c5ec9c8ae64bcfd6.tar.gz
version 3.5.2.12.geffa866-1
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD66
-rw-r--r--openbox-git.install9
3 files changed, 47 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 872e337019a7..84679b4f08da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,30 @@
pkgbase = openbox-git
- pkgdesc = Highly configurable and lightweight X11 window manager
- pkgver = 3.5.2.76.g9e8813e1
+ pkgdesc = A window manager for the X11 windowing system
+ pkgver = 3.5.2.12.geffa866
pkgrel = 1
- url = http://openbox.org
- arch = x86_64
+ url = http://openbox.org/
+ install = openbox-git.install
arch = i686
- groups = lxde
- groups = lxde-gtk3
- groups = lxqt
- license = GPL
+ arch = x86_64
+ license = GPL2
makedepends = docbook-to-man
makedepends = git
- depends = startup-notification
- depends = libxml2
+ depends = libsm
+ depends = libxcursor
depends = libxinerama
+ depends = libxml2
depends = libxrandr
- depends = libxcursor
depends = pango
- depends = imlib2
- depends = librsvg
- depends = libsm
- optdepends = plasma-workspace: for the KDE/Openbox xsession
- optdepends = python2-xdg: for the openbox-xdg-autostart script
- provides = openbox=3.5.2.76.g9e8813e1
- provides = libobrender.so
+ depends = startup-notification
+ optdepends = pyxdg: for the xdg-autostart script
+ provides = openbox=3.5.2.12.geffa866
conflicts = openbox
+ options = !libtool
backup = etc/xdg/openbox/menu.xml
backup = etc/xdg/openbox/rc.xml
- backup = etc/xdg/openbox/autostart
- backup = etc/xdg/openbox/environment
source = openbox-git::git://git.openbox.org/dana/openbox.git
- md5sums = SKIP
+ sha256sums = SKIP
+ sha512sums = SKIP
pkgname = openbox-git
diff --git a/PKGBUILD b/PKGBUILD
index 35a6e9fd6396..c193d648b003 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,43 @@
-# Maintainer: Brian Bidulock <bidulock@openss7.org>
-# Contributor: Florian pritz <bluewind@xinu.at>
-# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
-# Contributor: Brad Fanella <bradfanella@archlinux.us>
-# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Maintainer: Limao Luo <luolimao+AUR@gmail.com>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: tobias <tobias@archlinux.org>
# Contributor: Lauri Jäntti <janttilauri@gmail.com>
pkgname=openbox-git
-pkgver=3.5.2.76.g9e8813e1
+pkgver=3.5.2.12.geffa866
pkgrel=1
-pkgdesc='Highly configurable and lightweight X11 window manager'
-arch=('x86_64' 'i686')
-url='http://openbox.org'
-license=('GPL')
-provides=(${pkgname%-*}=$pkgver libobrender.so)
-conflicts=(${pkgname%-*})
-depends=('startup-notification' 'libxml2' 'libxinerama' 'libxrandr'
- 'libxcursor' 'pango' 'imlib2' 'librsvg' 'libsm')
-optdepends=('plasma-workspace: for the KDE/Openbox xsession'
- 'python2-xdg: for the openbox-xdg-autostart script')
-groups=('lxde' 'lxde-gtk3' 'lxqt')
-backup=('etc/xdg/openbox/menu.xml' 'etc/xdg/openbox/rc.xml'
- 'etc/xdg/openbox/autostart' 'etc/xdg/openbox/environment')
+pkgdesc="A window manager for the X11 windowing system"
+arch=(i686 x86_64)
+url=http://openbox.org/
+license=(GPL2)
+depends=(libsm libxcursor libxinerama libxml2 libxrandr pango startup-notification)
makedepends=(docbook-to-man git)
+optdepends=('pyxdg: for the xdg-autostart script')
+provides=(${pkgname%-*}=$pkgver)
+conflicts=(${pkgname%-*})
+backup=(etc/xdg/openbox/menu.xml
+ etc/xdg/openbox/rc.xml)
+options=(!libtool)
+install=$pkgname.install
source=($pkgname::git://git.openbox.org/dana/${pkgname%-*}.git)
-md5sums=('SKIP')
+sha256sums=('SKIP')
+sha512sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd $pkgname/
git describe | sed 's/^release-//;s/-/./g'
}
-prepare() {
- cd $pkgname
-
- autoreconf -fi
-}
-
build() {
- cd $pkgname
- ./configure --prefix=/usr \
+ cd $pkgname/
+ autoreconf -fi
+ ./configure \
+ --prefix=/usr \
--with-x \
--enable-startup-notification \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib/openbox
+ --sysconfdir=/etc
make
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
-
- # GNOME Panel is no longer available in the official repositories
- rm -r "$pkgdir"/usr/bin/{gdm-control,gnome-panel-control,openbox-gnome-session} \
- "$pkgdir"/usr/share/gnome{,-session} \
- "$pkgdir"/usr/share/man/man1/openbox-gnome-session.1 \
- "$pkgdir"/usr/share/xsessions/openbox-gnome.desktop
-
- sed -i 's:startkde:/usr/bin/\0:' \
- "$pkgdir"/usr/share/xsessions/openbox-kde.desktop
+ make -C $pkgname DESTDIR="$pkgdir" install
}
diff --git a/openbox-git.install b/openbox-git.install
new file mode 100644
index 000000000000..301c2212704f
--- /dev/null
+++ b/openbox-git.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Place menu.xml, rc.xml and autostart.sh in ~/.config/openbox"
+ echo "They can be found in /etc/xdg/openbox"
+}
+
+post_upgrade() {
+ post_install
+}
+