summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-19 01:01:42 -0800
committerxiota2023-12-19 01:13:43 -0800
commit7bf95aecca3beb3194f0892ee2116484826579ba (patch)
tree53012c7007df334097ffb75562dad5dc38ec0b63
parentc2237e226d3c09ac7c1d08a89dc2a974c7085ff2 (diff)
downloadaur-7bf95aecca3beb3194f0892ee2116484826579ba.tar.gz
minor revision
-rw-r--r--PKGBUILD38
1 files changed, 18 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b4eb0afc0be..e303b2ec541d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,12 +40,11 @@ _main_package() {
'qt5-graphicaleffects: Display the conversation history at startup'
)
- if [ "$pkgname" == "$_pkgname" ] ; then
+ if [ "${_build_git::1}" != "t" ] ; then
_main_stable
else
_main_git
fi
-
}
## stable package
@@ -63,7 +62,7 @@ _main_stable() {
'SKIP'
)
- prepare() {
+ _prepare_package() {
_prepare_submodules_quoternion
}
@@ -103,45 +102,44 @@ _main_git() {
| sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
- prepare() {
+ _prepare_package() {
_prepare_submodules_quoternion
_prepare_submodules_libquotient
}
}
## submodules
-_prepare_submodules_quoternion() {
- (
- # submodules for quaternion
+_prepare_submodules_quoternion() (
cd "$_pkgsrc"
local -A _submodules=(
['libquotient']='lib'
)
- for key in ${!_submodules[@]} ; do
- git submodule init "${_submodules[${key}]}"
- git submodule set-url "${_submodules[${key}]}" "${srcdir}/${key}"
- git -c protocol.file.allow=always submodule update "${_submodules[${key}]}"
- done
- )
-}
+ _submodule_update
+)
-_prepare_submodules_libquotient() {
- (
- # submodules for libquotient
+_prepare_submodules_libquotient() (
cd "$_pkgsrc/lib"
local -A _submodules=(
['doxygen-awesome-css']='doxygen-awesome-css'
['gtad']='gtad/gtad'
)
- for key in ${!_submodules[@]} ; do
+ _submodule_update
+)
+
+## common functions
+prepare() {
+ _submodule_update() {
+ local key
+ for key in ${!_submodules[@]} ; do
git submodule init "${_submodules[${key}]}"
git submodule set-url "${_submodules[${key}]}" "${srcdir}/${key}"
git -c protocol.file.allow=always submodule update "${_submodules[${key}]}"
done
- )
+ }
+
+ _prepare_package
}
-## common functions
build() {
local _cmake_options=(
-B build