summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2022-10-27 13:00:06 +0100
committergetzze2022-10-27 13:00:06 +0100
commit7c13bc5dd72a70ed97acf5e73016528207cae33c (patch)
tree501d8f1bb861f7c01a497479119c03ec495dfbb6
parent5190caaf6e62b937c00668568ca2eae8917e596e (diff)
downloadaur-7c13bc5dd72a70ed97acf5e73016528207cae33c.tar.gz
change fork and correct bug with GTK wayland
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
-rw-r--r--bug-egg.patch16
-rw-r--r--bug-gtk.patch31
4 files changed, 72 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b96e08e07c9d..4c2796d3e082 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = deluge-labelplus
pkgdesc = LabelPlus is a plugin for Deluge for labeling torrent, with much more functionalities that the builtin Labels.
pkgver = 0.3.2.4
- pkgrel = 2
- url = https://github.com/bdutro/deluge-labelplus
+ pkgrel = 3
+ url = https://github.com/laur89/deluge-labelplus
arch = any
license = GPL3
makedepends = python-setuptools
depends = deluge
- source = https://github.com/bdutro/deluge-labelplus/archive/v0.3.2.4.tar.gz
- sha256sums = 1b100872c14c2507bc9e58a1d13e2b8e47cfaf9a6bf4688a665cc1b4acd775fc
+ source = https://github.com/laur89/deluge-labelplus/archive/refs/tags/0.3.2.4.tar.gz
+ source = bug-gtk.patch
+ source = bug-egg.patch
+ sha256sums = 8122daab527c02987ed602b9687fd46b306f60f9e0f044a2ed2bb1a342178e07
+ sha256sums = 9d3700d54c579dc20f766dcc6a2702bbfc2c98992a216a16053c074bc38f6d0e
+ sha256sums = b5fd58c6ba2ca0765094763695d919fe1bf861e361d29d0ba8a3ec7773a47069
pkgname = deluge-labelplus
-
diff --git a/PKGBUILD b/PKGBUILD
index 1db93c08021b..de9c849b546a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,29 @@
pkgname=deluge-labelplus
pkgver=0.3.2.4
-pkgrel=2
+pkgrel=3
pkgdesc="LabelPlus is a plugin for Deluge for labeling torrent, with much more functionalities that the builtin Labels."
arch=('any')
## Set to fork until included upstream
-url="https://github.com/bdutro/deluge-labelplus"
+url="https://github.com/laur89/deluge-labelplus"
+#url="https://github.com/bdutro/deluge-labelplus"
#url="https://github.com/ratanakvlun/deluge-labelplus"
license=(GPL3)
depends=('deluge')
makedepends=('python-setuptools')
-source=($url/archive/v$pkgver.tar.gz)
-sha256sums=('1b100872c14c2507bc9e58a1d13e2b8e47cfaf9a6bf4688a665cc1b4acd775fc')
+#source=($url/archive/v$pkgver.tar.gz)
+source=("$url/archive/refs/tags/$pkgver.tar.gz"
+ bug-gtk.patch
+ bug-egg.patch)
+sha256sums=('8122daab527c02987ed602b9687fd46b306f60f9e0f044a2ed2bb1a342178e07'
+ '9d3700d54c579dc20f766dcc6a2702bbfc2c98992a216a16053c074bc38f6d0e'
+ 'b5fd58c6ba2ca0765094763695d919fe1bf861e361d29d0ba8a3ec7773a47069')
+
+prepare() {
+ cd "${srcdir}/$pkgname-$pkgver"
+ patch -p0 -i "${srcdir}/bug-egg.patch"
+ patch -p0 -i "${srcdir}/bug-gtk.patch"
+}
build() {
cd "${srcdir}/$pkgname-$pkgver"
@@ -20,8 +32,7 @@ build() {
}
package() {
- cd "${srcdir}/$pkgname-$pkgver"/dist
+ cd "${srcdir}/$pkgname-$pkgver"/dist
local _pyver=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
install -Dm644 "LabelPlus-$pkgver-py${_pyver}.egg" "${pkgdir}/usr/lib/python${_pyver}/site-packages/deluge/plugins/LabelPlus-$pkgver-py${_pyver}.egg"
}
-
diff --git a/bug-egg.patch b/bug-egg.patch
new file mode 100644
index 000000000000..853446a27fd6
--- /dev/null
+++ b/bug-egg.patch
@@ -0,0 +1,16 @@
+--- setup.py 2022-10-07 18:10:29.000000000 +0100
++++ setup2.py 2022-10-19 12:48:33.437435609 +0100
+@@ -74,13 +75,3 @@
+ )
+
+ # original setup-generated filename: LabelPlus-0.3.2.4-py3.9.egg
+-
+-# rename generated.egg to exclude the py version from filename:
+-list_of_eggs = glob.glob('./dist/*.egg')
+-if list_of_eggs:
+- newest_egg = max(list_of_eggs, key=os.path.getmtime)
+-
+- os.rename(
+- newest_egg,
+- os.path.join('dist', __plugin_name__ + '-' + version + '.egg')
+- )
diff --git a/bug-gtk.patch b/bug-gtk.patch
new file mode 100644
index 000000000000..cb3b8cc004de
--- /dev/null
+++ b/bug-gtk.patch
@@ -0,0 +1,31 @@
+--- labelplus/gtkui/common/gtklib/dnd.py 2022-10-07 18:10:29.000000000 +0100
++++ labelplus/gtkui/common/gtklib/dnd-new.py 2022-10-27 12:49:17.865003272 +0100
+@@ -242,9 +242,7 @@
+
+ def _do_drag_button_press(self, widget, event):
+
+- _, x, y, _ = widget.get_bin_window().get_device_position(event.get_source_device())
+- pos = widget.convert_bin_window_to_tree_coords(x, y)
+- if pos[1] < 0:
++ if event.y < 0:
+ return False
+
+ log.debug("%s Do button-press at b(%d, %d), Button: %s",
+@@ -655,14 +653,9 @@
+ if src and not same:
+
+ targets = src.drag_source_get_target_list() or Gtk.TargetList.new()
+- for t in targets:
+-
+- if t[0] == target.name:
+-
+- if t[1] & Gtk.TargetFlags.SAME_WIDGET:
+- target = None
+-
+- break
++ res, info = targets.find(atom)
++ if res and info & Gtk.TargetFlags.SAME_WIDGET:
++ target = None
+
+ return target
+