summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro Veloso2017-06-04 18:58:30 +0100
committerPedro Veloso2017-06-04 18:58:30 +0100
commit7c15607cede8bf091724f070eb75ae8d2e288954 (patch)
treef60ee354d4920e99054db11dc98a32d74942d98a
downloadaur-7c15607cede8bf091724f070eb75ae8d2e288954.tar.gz
Pidcat git version as of April 25, 2017
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rw-r--r--pidcat.patch8
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75358f2044ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pidcat-git
+ pkgdesc = Pidcat is a colored logcat script with improved readability that only shows log entries for a specific Android package.
+ pkgver = 04.2017
+ pkgrel = 1
+ url = https://github.com/JakeWharton/pidcat
+ arch = any
+ license = Apache
+ depends = python2
+ source = git+https://github.com/JakeWharton/pidcat.git
+ source = pidcat.patch
+ md5sums = SKIP
+ md5sums = 88dd654d600d8de4ff42174d042f0a77
+
+pkgname = pidcat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2878903b0e18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Pedro Veloso <pedro.n.veloso at gmail dot com>
+
+pkgname=pidcat-git
+pkgver=04.2017
+pkgrel=1
+pkgdesc="Pidcat is a colored logcat script with improved readability that only shows log entries for a specific Android package."
+arch=('any')
+url="https://github.com/JakeWharton/pidcat"
+license=('Apache')
+depends=('python2')
+
+source=("git+$url.git" "pidcat.patch")
+md5sums=('SKIP' "88dd654d600d8de4ff42174d042f0a77")
+
+build() {
+ patch -N ${srcdir}/pidcat/pidcat.py pidcat.patch
+}
+
+package() {
+ # Install license
+ install -Dm644 ${srcdir}/pidcat/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+
+ # Install run script
+ install -Dm755 ${srcdir}/pidcat/pidcat.py ${pkgdir}/usr/bin/pidcat
+}
diff --git a/pidcat.patch b/pidcat.patch
new file mode 100644
index 000000000000..9308937f1663
--- /dev/null
+++ b/pidcat.patch
@@ -0,0 +1,8 @@
+--- pidcat.py 2014-02-09 15:14:50.481729244 -0600
++++ pidcat.new 2014-02-09 15:14:36.381617069 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python -u
++#!/usr/bin/python2 -u
+
+ '''
+ Copyright 2009, The Android Open Source Project