summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-01-02 11:35:03 +0100
committersoloturn2023-01-02 11:35:46 +0100
commit7c94d21516f45458501b8380d3c0108a57396d1e (patch)
tree517dd0f89e1d1ccbf70e043d4ecb5fd6e6b91bfb
downloadaur-7c94d21516f45458501b8380d3c0108a57396d1e.tar.gz
1.0 initial, not working yet as no download available
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
-rw-r--r--easytax-ag-2022.desktop7
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b1609cffddf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = easytax-ag-2022
+ pkgdesc = Aargau tax declaration software.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.ag.ch/de/dfr/steuern/natuerliche_personen/steuererklaerung__easytax/steuererklaerung_easytax1.jsp
+ arch = any
+ license = custom
+ depends = java-environment
+ depends = bash
+ source = https://msg-easytax.ch/ag/2022/EasyTax2022AG_unix_1_0.tar.gz
+ source = easytax-ag-2022.desktop
+ sha256sums = 1dce65837fe258fda921035f11e724d6d19680c6ca6cab94e0551a8dd406be18
+ sha256sums = 1e2cb8dcefd5c891339d064997d2ffd4370bee8def3dee37b962e8e6b487f342
+
+pkgname = easytax-ag-2022
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b47135f6ba4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jeremy Stucki <dev@jeremystucki.ch>
+# Maintainer: Daniel Wilhelm <concat(shield, wed) @ outlook.com>
+# Maintainer: soloturn@gmail.com
+
+yyyy=2022
+pkgname=easytax-ag-${yyyy}
+pkgver=1.0
+pkgrel=1
+pkgdesc="Aargau tax declaration software."
+arch=(any)
+url="https://www.ag.ch/de/dfr/steuern/natuerliche_personen/steuererklaerung__easytax/steuererklaerung_easytax1.jsp"
+license=('custom')
+depends=("java-environment" "bash")
+source=(
+ "https://msg-easytax.ch/ag/${yyyy}/EasyTax${yyyy}AG_unix_$(echo ${pkgver} | sed 's/\./_/').tar.gz"
+ "$pkgname.desktop"
+)
+sha256sums=(
+ '1dce65837fe258fda921035f11e724d6d19680c6ca6cab94e0551a8dd406be18'
+ '1e2cb8dcefd5c891339d064997d2ffd4370bee8def3dee37b962e8e6b487f342'
+)
+
+package() {
+ # package the software, the xdg desktop file so GUI finds it
+ # and the link in bin so commandline finds it.
+ mkdir -p "$pkgdir"/usr/lib
+ mv "$srcdir"/EasyTax${yyyy}AG/ "$pkgdir"/usr/lib/$pkgname/
+
+ mkdir -p "$pkgdir"/usr/share/applications
+ cp *.desktop "$pkgdir"/usr/share/applications/
+
+ mkdir -p "$pkgdir"/usr/bin
+ binname=$(basename "$pkgdir"/usr/lib/$pkgname/EasyTax*)
+ ln -sf /usr/lib/${pkgname}/$binname "$pkgdir"/usr/bin/$pkgname
+}
diff --git a/easytax-ag-2022.desktop b/easytax-ag-2022.desktop
new file mode 100644
index 000000000000..0249eddb1883
--- /dev/null
+++ b/easytax-ag-2022.desktop
@@ -0,0 +1,7 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Type=Application
+Name=EasyTax 2022 AG
+Exec=INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-8-openjdk/jre /bin/sh -c /usr/bin/easytax-ag-2022
+Categories=Office;
+