summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:37:13 +0200
committerTim Rakowski2017-05-22 19:26:28 +0200
commit7cb91258f558298688c5ac3a9f2bfa7f46533816 (patch)
treeca61d26be572cde8a74c5e4294618018c7b49259
downloadaur-7cb91258f558298688c5ac3a9f2bfa7f46533816.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD63
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28e00d0d70fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:37 UTC 2017
+pkgbase = ros-lunar-cpp-common
+ pkgdesc = ROS - cpp_common contains C++ code for doing things that are not necessarily ROS related, but are useful for multiple packages.
+ pkgver = 0.6.3
+ pkgrel = 1
+ url = http://www.ros.org/wiki/cpp_common
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ makedepends = boost
+ makedepends = console-bridge
+ depends = boost
+ depends = console-bridge
+ source = ros-lunar-cpp-common-0.6.3-0.tar.gz::https://github.com/ros-gbp/roscpp_core-release/archive/release/lunar/cpp_common/0.6.3-0.tar.gz
+ sha256sums = aba789eca5e2090b6d13e7416d789d32f95b2da54e462ed49df3e3093081e5b1
+
+pkgname = ros-lunar-cpp-common
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2139784d8aa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - cpp_common contains C++ code for doing things that are not necessarily ROS related, but are useful for multiple packages."
+url='http://www.ros.org/wiki/cpp_common'
+
+pkgname='ros-lunar-cpp-common'
+pkgver='0.6.3'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost
+ console-bridge)
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ boost
+ console-bridge)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/cpp_common/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/roscpp_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="roscpp_core-release-release-lunar-cpp_common-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/roscpp_core-release/archive/release/lunar/cpp_common/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('aba789eca5e2090b6d13e7416d789d32f95b2da54e462ed49df3e3093081e5b1')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}