aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan James Jenkins2015-06-14 14:13:37 +0100
committerAlan James Jenkins2015-06-14 14:13:37 +0100
commit7cc9fe6d42c5e51c449c4def6f1dde10c4629d24 (patch)
tree9446fa974a04b9687a342ecee0be0465771c4344
downloadaur-7cc9fe6d42c5e51c449c4def6f1dde10c4629d24.tar.gz
First AUR4 release.
-rw-r--r--.SRCINFO29
-rw-r--r--ChangeLog20
-rw-r--r--PKGBUILD93
-rw-r--r--README.md4
-rw-r--r--ut2004-install.sh18
-rw-r--r--ut2004-update.sh12
-rw-r--r--ut2004.desktop8
-rw-r--r--ut2004.install14
-rw-r--r--ut2004.sh4
9 files changed, 202 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a23c16cf4a72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = ut2004-steam
+ pkgdesc = Popular first person shooter, native Linux version, installing data files from Steam (requires you having had purchased the Steam version).
+ pkgver = 3369_2
+ pkgrel = 4
+ epoch = 1
+ url = http://www.unrealtournament2004.com
+ install = ut2004.install
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sdl
+ depends = openal
+ depends = steamcmd
+ depends = libstdc++5
+ conflicts = ut2004
+ source = https://github.com/demon012/archlinux-package-ut2004-steam/raw/master/ut2004-lnxpatch3369-2.tar.bz2
+ source = ut2004.desktop
+ source = ut2004-install.sh
+ source = ut2004-update.sh
+ source = ut2004.sh
+ md5sums = 0fa447e05fe5a38e0e32adf171be405e
+ md5sums = b4ca5855b8fc6d283b49c8df469d61c2
+ md5sums = 5608b9b891788ae3d6a53afaf2a370d2
+ md5sums = 1119a2bbec7211ee11c939941af3cb48
+ md5sums = 85623fe9fecd0678e4f12902c22d7272
+
+pkgname = ut2004-steam
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..f88cbf326263
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,20 @@
+2011-04-15 NiteHogg <keith.b.elliott [at] gmail [dot] com>
+
+ * ut2003 3369.2-1 :
+ Overhauled this package build,
+ fixed sound and permissions.
+ Tested with UT2004 ECE DVD
+ on x86_64.
+
+2011-04-25 NiteHogg <keith.b.elliott [at] gmail [dot] com>
+
+ * ut2003 3369.2-3 :
+ Updated the PKGBUILD to remove
+ the 64-bit launch bins if ran
+ on a 32-bit system. 32-bit strip
+ doesn't like the 64-bit compiled
+ bins. Thanks node357.
+
+2014-06-04 demon012 <alan.james.jenkins [at] gmail [dot] com>
+
+ First Steam version of the package.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a5566d2b701
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,93 @@
+# Maintainer: Alan Jenkins <alan.james.jenkins [at] gmail [dot] com>
+# Contributor: NiteHogg <keith.b.elliott [at] gmail [dot] com>
+# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
+# Contributor: Karsten Anderson <orbitcoder@gmail.com>
+
+pkgname=ut2004-steam
+epoch=1
+pkgver=3369_2
+_pkgvermaj=3369
+_pkgvermin=2
+pkgrel=4
+pkgdesc="Popular first person shooter, native Linux version, installing data files from Steam (requires you having had purchased the Steam version)."
+epoch=1
+arch=('i686' 'x86_64')
+url="http://www.unrealtournament2004.com"
+license=('custom')
+depends=('sdl' 'openal' 'steamcmd' 'libstdc++5')
+conflicts=('ut2004')
+install=ut2004.install
+changelog=ChangeLog
+#source=("http://planet64bit.de/fileZ/ut2004-lnxpatch3369.tar.bz2"
+source=("https://github.com/demon012/archlinux-package-ut2004-steam/raw/master/ut2004-lnxpatch$_pkgvermaj-$_pkgvermin.tar.bz2"
+ "ut2004.desktop"
+ "ut2004-install.sh"
+ "ut2004-update.sh"
+ "ut2004.sh")
+
+ md5sums=('0fa447e05fe5a38e0e32adf171be405e'
+ 'b4ca5855b8fc6d283b49c8df469d61c2'
+ '5608b9b891788ae3d6a53afaf2a370d2'
+ '1119a2bbec7211ee11c939941af3cb48'
+ '85623fe9fecd0678e4f12902c22d7272')
+
+package() {
+
+ # Making sure directories exist.
+ install -d $pkgdir/usr/share/{applications,pixmaps,licenses}
+ install -d $pkgdir/opt/ut2004
+ install -d $pkgdir/opt/ut2004/{Animations,Help,Textures,Web,Benchmark,ForceFeedback,KarmaData,Maps,Music,StaticMeshes,Sounds,Speech,System}
+ install -d $pkgdir/usr/bin/
+
+ # Install UT2004 Linux patch data. Will later do a non-clobber
+ # move over the top of it.
+ cp -R $srcdir/UT2004-Patch/* $pkgdir/opt/ut2004
+
+ # Install helper scripts.
+ install -D -m 755 $srcdir/ut2004-install.sh \
+ $pkgdir/opt/ut2004/Scripts/ut2004-install
+ install -D -m 755 $srcdir/ut2004-update.sh \
+ $pkgdir/opt/ut2004/Scripts/ut2004-update
+ install -D -m 755 $srcdir/ut2004.sh \
+ $pkgdir/opt/ut2004/Scripts/ut2004
+
+ # Install license.
+ install -D -m 644 $srcdir/UT2004-Patch/System/License.int \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ # Install desktop file.
+ install -D -m 644 $srcdir/ut2004.desktop \
+ $pkgdir/usr/share/applications/ut2004.desktop
+
+ # Create symlinks to add the ut2004 startup and utility scripts to usr/bin
+ ln -s /opt/ut2004/Scripts/ut2004 $pkgdir/usr/bin/ut2004 || return 1
+ ln -s /opt/ut2004/Scripts/ut2004-install $pkgdir/usr/bin/ut2004-install || return 1
+ ln -s /opt/ut2004/Scripts/ut2004-update $pkgdir/usr/bin/ut2004-update || return 1
+ # chmod 755 $pkgdir/usr/bin/*
+
+
+ if [ "$CARCH" == "x86_64" ]
+ then
+ sed 's/ut2004-bin/&-linux-amd64/g' $pkgdir/opt/ut2004/Scripts/ut2004 > $pkgdir/opt/ut2004/Scripts/ut2004.TMP
+
+ install -D -m 755 $pkgdir/opt/ut2004/Scripts/ut2004.TMP $pkgdir/opt/ut2004/Scripts/ut2004
+ else
+ rm $pkgdir/opt/ut2004/System/ucc-bin-linux-amd64
+ rm $pkgdir/opt/ut2004/System/ut2004-bin-linux-amd64
+ fi
+
+ # Installing empty icon and cd key file placeholders.
+ cat /dev/null > $pkgdir/usr/share/pixmaps/Unreal.ico
+ chmod 644 $pkgdir/usr/share/pixmaps/Unreal.ico || return 1
+ cat /dev/null > $pkgdir/opt/ut2004/System/CDkey
+ chmod 644 $pkgdir/opt/ut2004/System/CDkey || return 1
+
+
+ # Create symbolic links to system libraries in game directory.
+ ln -s /usr/lib/libSDL-1.2.so.0 $pkgdir/opt/ut2004/System || return 1
+ chmod 644 $pkgdir/opt/ut2004/System/libSDL-1.2.so.0 || return 1
+ ln -s /usr/lib/libopenal.so $pkgdir/opt/ut2004/System/openal.so || return 1
+ chmod 644 $pkgdir/opt/ut2004/System/openal.so || return 1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..e0d55dde0d59
--- /dev/null
+++ b/README.md
@@ -0,0 +1,4 @@
+archlinux-package-ut2004-steam
+==============================
+
+An AUR package for installing the native Linux version of Unreal Tournament from the Windows version in Steam using steamcmd.
diff --git a/ut2004-install.sh b/ut2004-install.sh
new file mode 100644
index 000000000000..04a7e04d5fc4
--- /dev/null
+++ b/ut2004-install.sh
@@ -0,0 +1,18 @@
+#! /bin/bash
+
+if [ "$(whoami)" != "root" ]
+then
+ echo "Must be ran as root"
+ exit 1
+fi
+
+export UT2004_PATH="/opt/ut2004"
+
+# Create CD key file.
+echo
+printf "Enter CD Key [XXXXX-XXXXX-XXXXX-XXXXX]: "
+read cd_key
+
+echo "$cd_key" > "$UT2004_PATH"/System/CDkey
+
+$UT2004_PATH/Scripts/ut2004-update
diff --git a/ut2004-update.sh b/ut2004-update.sh
new file mode 100644
index 000000000000..df03c3694443
--- /dev/null
+++ b/ut2004-update.sh
@@ -0,0 +1,12 @@
+#!/bin/bash
+if [ "$(whoami)" != "root" ]
+then
+ echo "Must be ran as root"
+ exit 1
+fi
+
+export UT2004_PATH="/opt/ut2004"
+
+printf "Enter your Steam username:"
+read steam_username
+steamcmd +@sSteamCmdForcePlatformType windows +@ShutdownOnFailedCommand 1 +force_install_dir $UT2004_PATH +login $steam_username "+app_update 13230 validate" +quit
diff --git a/ut2004.desktop b/ut2004.desktop
new file mode 100644
index 000000000000..93b636dc972d
--- /dev/null
+++ b/ut2004.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Unreal Tournament 2004
+Comment=popular first person shooter
+Exec=/opt/ut2004/Scripts/ut2004
+Icon=/usr/share/pixmaps/Unreal.ico
+Terminal=false
+Type=Application
+Categories=Application;Game;
diff --git a/ut2004.install b/ut2004.install
new file mode 100644
index 000000000000..c21846557f89
--- /dev/null
+++ b/ut2004.install
@@ -0,0 +1,14 @@
+post_install() {
+
+ echo "To complete installation, run /opt/ut2004/Scripts/ut2004-install as root. This prompts for the CD key and then triggers the update script to install and update ut2004.
+This requires approximately 6G of disk space."
+}
+
+post_remove() {
+
+ # Cleaning up the post install files.
+ rm -r /opt/ut2004 >& /dev/null
+}
+
+
+# vim:set ts=2 sw=2 et:
diff --git a/ut2004.sh b/ut2004.sh
new file mode 100644
index 000000000000..25ff94537ab5
--- /dev/null
+++ b/ut2004.sh
@@ -0,0 +1,4 @@
+#! /bin/bash
+
+cd /opt/ut2004/System
+./ut2004-bin