summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hai2015-12-04 12:14:54 +0800
committerZhang Hai2015-12-04 12:14:54 +0800
commit7d0245aa477b38d320cff73fc4a6c343d2683b73 (patch)
tree016cd1a9a592a555ecab90ef8fb07b48245422e8
downloadaur-7d0245aa477b38d320cff73fc4a6c343d2683b73.tar.gz
Initial commit.
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD77
-rw-r--r--ttf-wps-win10.install15
3 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6efa140768d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = ttf-wps-win10
+ pkgdesc = Symbol fonts required by wps-office from Microsoft Windows 10
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.microsoft.com/typography/fonts/product.aspx?PID=164
+ install = ttf-wps-win10.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = ttf-font
+ provides = ttf-wps-fonts
+ conflicts = ttf-wps-fonts
+ source = file://MTEXTRA.TTF
+ source = file://symbol.ttf
+ source = file://webdings.ttf
+ source = file://wingding.ttf
+ source = file://WINGDNG2.TTF
+ source = file://WINGDNG3.TTF
+ source = file://license.rtf
+ sha256sums = 6c469962f33b7222f07b8d1ae8025f177f4a5f5db3eb62fa1523f261a270991f
+ sha256sums = bffdc2fd675d9af414824ae84d8456504542480afb34fbc6bfd6903656c4f854
+ sha256sums = 1161ce511c44eb5464a4f8144aaf3eb965a50ed66957ad7d38e497ab9d958e5a
+ sha256sums = d7c38355bd52f52e043ed904f3463d476925300d1bdca9e842b28077ca3549b8
+ sha256sums = fa671b6fddedd57f158ab90b6aa6a7c33db6f41ab620db72b7ad1e57c38bda5f
+ sha256sums = ac9ee085920a3d8b076d5e0c61dc9df42c4bac28d1fc968344f9ceddb3972f69
+ sha256sums = d7772b57a65afc23005af09349d7d8fc2b933a52bf24230767bcb3e53e317799
+
+pkgname = ttf-wps-win10
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..703ccd3bd902
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Zhang Hai <dreaming.in.code.zh@gmail.com>
+
+# Instructions were copied from ttf-ms-win8 and slightly modified:
+#
+# BUILD INSTRUCTIONS:
+# -------------------
+#
+# Please note, that usage of Microsoft fonts outside running Windows
+# system is prohibited by EULA (although in certain countries EULA is invalid).
+# Please consult Microsoft license before using fonts.
+#
+# You can acquire fonts either from an installed and up-to-date Windows 10
+# system or the most recent install medium.
+#
+# On the installed Windows 10 system fonts are usually located in
+# C:\Windows\Fonts
+# and license file is
+# C:\Windows\System32\license.rtf
+#
+# How to acquire fonts from Windows 10 install medium:
+#
+# You can freely download the Windows 10 Enterprise 90-day evaluation from:
+#
+# http://www.microsoft.com/en-us/evalcenter/evaluate-windows-10-enterprise
+#
+# Fonts are located in 'sources/install.wim' file on the ISO, which
+# is a 'Windows Imaging Format' (WIM) archive.
+#
+# You can extract WIM using wimextract ('wimlib' package from AUR) or
+# 7z ('p7zip').
+#
+# Put the following script together with previously extracted
+# 'install.wim' and execute:
+#
+# wimextract install.wim 1 /Windows/{Fonts/"*".{ttf,ttc},System32/Licenses/neutral/"*"/"*"/license.rtf} --dest-dir fonts
+#
+# Fonts and license will be located in the 'fonts' dir.
+#
+# You need all files listed in the _ttf_wps_win10[_*] arrays.Place them in the
+# same directory as this PKGBUILD file, then run makepkg.
+
+pkgname=ttf-wps-win10
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Symbol fonts required by wps-office from Microsoft Windows 10'
+arch=(any)
+url='http://www.microsoft.com/typography/fonts/product.aspx?PID=164'
+license=(custom)
+depends=(fontconfig xorg-font-utils)
+provides=(ttf-font ttf-wps-fonts)
+conflicts=(ttf-wps-fonts)
+install="${pkgname}.install"
+
+_ttf_wps_win10=(MTEXTRA.TTF
+ symbol.ttf
+ webdings.ttf
+ wingding.ttf
+ WINGDNG2.TTF
+ WINGDNG3.TTF)
+DLAGENTS+=("file::/usr/bin/echo ${BOLD}${RED} Unable to find %u, please read the PKGBUILD ${ALL_OFF}")
+source=(${_ttf_wps_win10[@]/#/file://}
+ file://license.rtf)
+
+sha256sums=('6c469962f33b7222f07b8d1ae8025f177f4a5f5db3eb62fa1523f261a270991f'
+ 'bffdc2fd675d9af414824ae84d8456504542480afb34fbc6bfd6903656c4f854'
+ '1161ce511c44eb5464a4f8144aaf3eb965a50ed66957ad7d38e497ab9d958e5a'
+ 'd7c38355bd52f52e043ed904f3463d476925300d1bdca9e842b28077ca3549b8'
+ 'fa671b6fddedd57f158ab90b6aa6a7c33db6f41ab620db72b7ad1e57c38bda5f'
+ 'ac9ee085920a3d8b076d5e0c61dc9df42c4bac28d1fc968344f9ceddb3972f69'
+ 'd7772b57a65afc23005af09349d7d8fc2b933a52bf24230767bcb3e53e317799')
+
+package() {
+ for font in "${_ttf_wps_win10[@]}"; do
+ install -Dm644 "${font}" -t "${pkgdir}/usr/share/fonts/TTF/"
+ done
+ install -Dm644 license.rtf -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/ttf-wps-win10.install b/ttf-wps-win10.install
new file mode 100644
index 000000000000..f4e2bde61fa1
--- /dev/null
+++ b/ttf-wps-win10.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ post_install "$1"
+}