summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2022-12-16 10:39:16 +0530
committertxtsd2022-12-16 10:39:16 +0530
commit7d07e5c7fea4b741808d83fcaff3a79397ffb591 (patch)
treef0e7e77315d155d63712f48dc51804134dcb7fd7
parent49b1b0e37135e6c2da0891d04c98cbc43f5ef2cc (diff)
downloadaur-7d07e5c7fea4b741808d83fcaff3a79397ffb591.tar.gz
chore: Brace variables
Also, quote directories Signed-off-by: txtsd <code@ihavea.quest>
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2568bc963565..c77ef2166bfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ sha256sums=('4b8771e36b3ec6c36a7f5447b05638418636c0ae6e90049568737f999f3f0850'
DEST="/opt/soundsense"
prepare() {
- cd $srcdir/$pkgname
+ cd "${srcdir}/${pkgname}"
# fix line breaks
sed -i $'s/\r$//' soundSense.sh
@@ -34,15 +34,14 @@ prepare() {
package() {
# install runner
- install -Dm755 ${srcdir}/${pkgname}/soundSense.sh $pkgdir/usr/bin/soundsense
+ install -Dm755 "${srcdir}/${pkgname}/soundSense.sh" "${pkgdir}/usr/bin/soundsense"
# rm unneeded files
- rm $srcdir/$pkgname/*.{cmd,exe,zip,sh}
+ rm "${srcdir}/${pkgname}/"*.{cmd,exe,zip,sh}
# copy over and set permissions
- install -dm755 -o root -g games ${pkgdir}${DEST}
- cp -r $srcdir/$pkgname/. ${pkgdir}${DEST}
- chown root:games -R ${pkgdir}${DEST}
- find ${pkgdir}${DEST}/ -type d -exec chmod 6775 {} +
- find ${pkgdir}${DEST}/ -type f -exec chmod 664 {} +
+ install -dm755 -o root -g games "${pkgdir}${DEST}"
+ cp -r "${srcdir}/${pkgname}/." "${pkgdir}${DEST}"
+ chown root:games -R "${pkgdir}${DEST}"
+ find "${pkgdir}${DEST}/" -type d -exec chmod 6775 {} +
+ find "${pkgdir}${DEST}/" -type f -exec chmod 664 {} +
}
-# vim:set ts=2 sw=2 et: