summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Coffin2019-06-14 11:18:08 -0600
committerGenki Sky2019-06-14 15:30:38 -0700
commit7d56f39aebf300f57d28e6c9affa90827f48fab8 (patch)
tree4525699694f49df02f65b15409f7b7d63488ac2f
parent4359abf51378a371284fd7823e62d2bcf2e464e6 (diff)
downloadaur-7d56f39aebf300f57d28e6c9affa90827f48fab8.tar.gz
meson: Use release builds
We should be using release builds on meson so that it doesn't potentially add unneeded debug info, or strip off optimization flags added by makepkg. While -O3 is passed by makepkg via the environment, we don't want meson to add debug info.
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d7c1068c162..2495c868564c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,10 @@ pkgver() {
build() {
cd slurp
- meson --prefix=/usr build
+ meson \
+ --prefix=/usr \
+ --buildtype release \
+ build
ninja -C build
}