summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2016-03-24 17:45:15 -0400
committerLeo P2016-03-24 17:45:15 -0400
commit7d8252e4ae820b4fae318bbd2e7dc46d84b1b80e (patch)
tree136f60b34f8ebcc9a656afc6c8840d1de0ae7e4c
downloadaur-7d8252e4ae820b4fae318bbd2e7dc46d84b1b80e.tar.gz
first
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--CorsixTH.desktop11
-rw-r--r--PKGBUILD47
-rw-r--r--corsix-th.install6
-rw-r--r--corsix-th.sh3
6 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56564e4cfbb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = corsix-th-git
+ pkgdesc = Reimplementation of the game engine of Theme Hospital, git version
+ pkgver = 0.50.r228.ge8bb00e
+ pkgrel = 1
+ url = https://github.com/CorsixTH/CorsixTH
+ install = corsix-th.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = cmake
+ depends = lua
+ depends = lua-lpeg
+ depends = lua-filesystem
+ depends = sdl2_mixer
+ depends = ffmpeg
+ depends = timidity-freepats
+ source = git+https://github.com/CorsixTH/CorsixTH.git
+ source = CorsixTH.desktop
+ source = corsix-th.sh
+ sha256sums = SKIP
+ sha256sums = 71f882fc453f3df2ebda089ab9994f7698f212c98686098944743aedc1b882ea
+ sha256sums = 3614197a30498774fff4055ee54d82a812a8b88eba353b70c3288a09ff700158
+
+pkgname = corsix-th-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1c580bcc27f2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+CorsixTH/
+*.tar.*
+src/
+pkg/ \ No newline at end of file
diff --git a/CorsixTH.desktop b/CorsixTH.desktop
new file mode 100644
index 000000000000..9ecc8d669560
--- /dev/null
+++ b/CorsixTH.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=CorsixTH
+Version=0.41-r1078
+Exec=/usr/games/CorsixTH/CorsixTH
+Comment=A Theme Hospital Clone
+Icon=/usr/games/CorsixTH/CorsixTH.ico
+Type=Application
+Terminal=false
+StartupNotify=true
+Encoding=UTF-8
+Categories=Game;StrategyGame;
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b902f2867301
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+#original package by:
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributors: jdc, rayman2200
+
+pkgname=corsix-th-git
+pkgver=0.50.r228.ge8bb00e
+pkgrel=1
+pkgdesc='Reimplementation of the game engine of Theme Hospital, git version'
+url='https://github.com/CorsixTH/CorsixTH'
+arch=('i686' 'x86_64' 'armv7h')
+license=('MIT')
+makedepends=('cmake')
+depends=('lua' 'lua-lpeg' 'lua-filesystem' 'sdl2_mixer' 'ffmpeg' 'timidity-freepats')
+install=corsix-th.install
+source=("git+https://github.com/CorsixTH/CorsixTH.git"
+ "CorsixTH.desktop"
+ "corsix-th.sh")
+
+sha256sums=('SKIP'
+ '71f882fc453f3df2ebda089ab9994f7698f212c98686098944743aedc1b882ea'
+ '3614197a30498774fff4055ee54d82a812a8b88eba353b70c3288a09ff700158')
+
+pkgver() {
+ cd "CorsixTH"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd CorsixTH
+
+ cmake -DCMAKE_BUILD_TYPE=Release -Wno-dev \
+ -DLUA_PROGRAM_PATH=/usr/bin/lua -DLUA_INCLUDE_DIR=/usr/include -DLUA_LIBRARY=/usr/lib/liblua.so \
+ -DCMAKE_INSTALL_PREFIX=/usr/share/ .
+ cd CorsixTH
+ make
+}
+
+package() {
+ make -C CorsixTH/CorsixTH DESTDIR="$pkgdir/" install
+ # launcher
+ install -Dm0755 corsix-th.sh "$pkgdir"/usr/bin/CorsixTH
+ # license
+ install -Dm0644 CorsixTH/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ # .desktop integration
+ install -Dm0644 CorsixTH.desktop "$pkgdir"/usr/share/applications/CorsixTH.desktop
+}
diff --git a/corsix-th.install b/corsix-th.install
new file mode 100644
index 000000000000..f8f0a14586ba
--- /dev/null
+++ b/corsix-th.install
@@ -0,0 +1,6 @@
+
+post_install() {
+ echo "=> If you do not have a copy of Theme Hospital,"
+ echo "=> you can download the data files of the demo:"
+ echo "=> http://th.corsix.org/Demo.zip"
+}
diff --git a/corsix-th.sh b/corsix-th.sh
new file mode 100644
index 000000000000..545bab32e5d6
--- /dev/null
+++ b/corsix-th.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/share/CorsixTH/CorsixTH