summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Maguire2015-10-20 19:31:28 -0400
committerJohn Maguire2015-10-20 19:34:54 -0400
commit7d9bddde48870473d45a0f5df1aaef9f9d65dd0e (patch)
tree949fe157677e3beed3c81761dc366e96d82f4528
downloadaur-7d9bddde48870473d45a0f5df1aaef9f9d65dd0e.tar.gz
Add initial libfxqmlhelpers package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--libfxqmlhelpers.install0
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c9896b369e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libfxqmlhelpers
+ pkgdesc = QML Controls library from FX
+ pkgver = 0.1.0.46aa9d6
+ pkgrel = 2
+ url = https://bitbucket.org/fx_/fx-qml-helpers
+ install = libfxqmlhelpers.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ source = libfxqmlhelpers::git+https://bitbucket.org/fx_/fx-qml-helpers.git
+ sha256sums = SKIP
+
+pkgname = libfxqmlhelpers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ea78ef02382
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: John Maguire <contact@johnmaguire.me>
+pkgname=libfxqmlhelpers
+pkgver=0.1.0.46aa9d6
+pkgrel=2
+pkgdesc="QML Controls library from FX"
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/fx_/fx-qml-helpers"
+license=('GPL3')
+makedepends=('git')
+install="$pkgname.install"
+source=("$pkgname::git+https://bitbucket.org/fx_/fx-qml-helpers.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo 0.1.0.$(git log -1 --format="%h")
+}
+
+build() {
+ cd "$srcdir/$pkgname/fxqmlhelpers"
+ qmake fxqmlhelpers.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/fxqmlhelpers"
+ make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
+}
diff --git a/libfxqmlhelpers.install b/libfxqmlhelpers.install
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/libfxqmlhelpers.install