summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarsten Pufahl2023-08-10 15:33:04 +0200
committerKarsten Pufahl2023-08-10 15:33:04 +0200
commit7dba3c962c285a40a2d938e881dabad3ac9211e4 (patch)
tree96fcbf1e23cd700be247ea215f8ff5590a9233a4
parent9b68fa12f583b155dd73e80318b783b071c9c688 (diff)
downloadaur-7dba3c962c285a40a2d938e881dabad3ac9211e4.tar.gz
version 6.9.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
-rw-r--r--stm32cubemx.sh2
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb889413c05f..ecaaa474ee27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = stm32cubemx
pkgdesc = graphical software configuration tool for STM32 microcontrollers that allows generating C initialization code
- pkgver = 6.9.0
+ pkgver = 6.9.1
pkgrel = 1
url = https://www.st.com/en/development-tools/stm32cubemx.html
arch = any
license = custom
makedepends = imagemagick
- depends = java-runtime=20
+ depends = java-runtime>=17
+ depends = java-runtime<21
depends = archlinux-java-run
depends = bash
options = !strip
- source = https://sw-center.st.com/packs/resource/library/stm32cube_mx_v690-lin.zip
+ source = https://sw-center.st.com/packs/resource/library/stm32cube_mx_v691-lin.zip
source = stm32cubemx.desktop
source = stm32cubemx.sh
- sha512sums = fb51da651c5ccfa0fcbd799d89d11ac202deed2938f7675f1f3b78b5b2fc0ebcad3554783489394d265160e157aa9d669962d8aa583defb4a306a93af142667e
+ sha512sums = 8545425ba395b643ff89a7e7ff5d9c57836696a3d0fc4cfe3d6761567d914d0db772afb249aee3226a2e7b9eab942e026615173968edf2ab2a4996453a3da0b7
sha512sums = 83c67bef3e8f8434903fe0c067442cc7473459386fdcb0225af1b3a75fd75e2be393f91f877c8410f1055ca4ec531b2df707fcab10663cae382a7f4066c8548b
- sha512sums = e5b604754fcfc62f8b745dea8c921cc72d1ca1bc81bd3a2cd26f8871a86fad3598b60a4b3f5ff2503c76e6c2dcb9c9ce37e63ba84718c2d427a8de8003a318f2
+ sha512sums = 8c46e1396e629733d4a692305e877a5b340b4a00ecc7add7e98973c7f216fa3f7128d7c23a9d37a832ac928a3b778d26ebfb0df9b9b49112b74e1dafe827ee98
pkgname = stm32cubemx
diff --git a/PKGBUILD b/PKGBUILD
index da7228bf59bb..33d2828447b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: laserK <echo 'Y29udGFjdEBrYXJzdGVucHVmYWhsLmRlCg==' | base64 -d>
pkgname=stm32cubemx
-pkgver=6.9.0
+pkgver=6.9.1
pkgrel=1
epoch=
pkgdesc="graphical software configuration tool for STM32 microcontrollers that allows generating C initialization code"
@@ -8,7 +8,8 @@ arch=(any)
url="https://www.st.com/en/development-tools/stm32cubemx.html"
license=('custom')
groups=()
-depends=('java-runtime=20'
+depends=('java-runtime>=17'
+ 'java-runtime<21'
'archlinux-java-run'
'bash')
makedepends=('imagemagick')
@@ -25,9 +26,9 @@ source=("https://sw-center.st.com/packs/resource/library/stm32cube_mx_v${pkgver/
"stm32cubemx.desktop"
"stm32cubemx.sh")
noextract=()
-sha512sums=('fb51da651c5ccfa0fcbd799d89d11ac202deed2938f7675f1f3b78b5b2fc0ebcad3554783489394d265160e157aa9d669962d8aa583defb4a306a93af142667e'
+sha512sums=('8545425ba395b643ff89a7e7ff5d9c57836696a3d0fc4cfe3d6761567d914d0db772afb249aee3226a2e7b9eab942e026615173968edf2ab2a4996453a3da0b7'
'83c67bef3e8f8434903fe0c067442cc7473459386fdcb0225af1b3a75fd75e2be393f91f877c8410f1055ca4ec531b2df707fcab10663cae382a7f4066c8548b'
- 'e5b604754fcfc62f8b745dea8c921cc72d1ca1bc81bd3a2cd26f8871a86fad3598b60a4b3f5ff2503c76e6c2dcb9c9ce37e63ba84718c2d427a8de8003a318f2')
+ '8c46e1396e629733d4a692305e877a5b340b4a00ecc7add7e98973c7f216fa3f7128d7c23a9d37a832ac928a3b778d26ebfb0df9b9b49112b74e1dafe827ee98')
validpgpkeys=()
package() {
diff --git a/stm32cubemx.sh b/stm32cubemx.sh
index 48d9ef64e334..cd1d5f5d0cf9 100644
--- a/stm32cubemx.sh
+++ b/stm32cubemx.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec archlinux-java-run --min 11 --max 20 -- -jar /opt/stm32cubemx/STM32CubeMX "$@"
+exec archlinux-java-run --min 17 --max 20 -- -jar /opt/stm32cubemx/STM32CubeMX "$@"