summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2015-07-07 22:16:29 +0100
committerAngelo Theodorou2015-07-07 22:16:29 +0100
commit7dc28a78dd6759e01e8bff0ae4a6ac0ba378e22e (patch)
tree5f96cbf9380447a042b87ccad0904edafb073a25
downloadaur-7dc28a78dd6759e01e8bff0ae4a6ac0ba378e22e.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
-rw-r--r--stratagus.changelog45
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6871928a856b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = stratagus
+ pkgdesc = A free cross-platform real-time strategy gaming engine
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://launchpad.net/stratagus
+ changelog = stratagus.changelog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = tolua++
+ depends = gcc-libs
+ depends = libgl
+ depends = sdl
+ depends = libpng
+ depends = libmng
+ depends = libvorbis
+ depends = libtheora
+ depends = libmikmod
+ depends = lua51
+ depends = sqlite
+ source = http://launchpad.net/stratagus/trunk/2.3/+download/stratagus_2.3.0.orig.tar.gz
+ md5sums = bf64b87f387c8281350e4b54327bc95f
+
+pkgname = stratagus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a63d705f56e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
+pkgname=stratagus
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="A free cross-platform real-time strategy gaming engine"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/stratagus"
+license=('GPL')
+depends=('gcc-libs' 'libgl' 'sdl' 'libpng' 'libmng' 'libvorbis' 'libtheora' 'libmikmod' 'lua51' 'sqlite')
+makedepends=('cmake' 'tolua++')
+changelog=stratagus.changelog
+source=(http://launchpad.net/stratagus/trunk/2.3/+download/stratagus_$pkgver.orig.tar.gz)
+md5sums=('bf64b87f387c8281350e4b54327bc95f')
+
+build() {
+ cd $srcdir
+
+ cmake ${pkgname}_$pkgver.orig \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGAMEDIR=/usr/bin \
+ -DSBINDIR=/usr/bin \
+ -DLUA_INCLUDE_DIR=/usr/include/lua5.1 \
+ -Bbuild
+
+ make -C build
+}
+
+package() {
+ cd ${srcdir}/build
+ make DESTDIR=${pkgdir} install
+
+ mkdir -p ${pkgdir}/usr/include
+ cp ${srcdir}/${pkgname}_$pkgver.orig/gameheaders/stratagus-game-launcher.h ${pkgdir}/usr/include
+}
diff --git a/stratagus.changelog b/stratagus.changelog
new file mode 100644
index 000000000000..394fc8f01048
--- /dev/null
+++ b/stratagus.changelog
@@ -0,0 +1,45 @@
+2015-04-08 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Moved post installation commands in the package() function
+
+2013-06-03 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Added SBINDIR definition to CMake build command
+
+2013-03-24 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Depends array updated for lua51
+
+2012-09-01 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Depends and makedepends arrays updated
+
+2011-12-27 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Added the changelog directive
+ Added a package() function
+ Depends and makedepends arrays updated
+
+2010-12-08 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ URL, source and dependencies updated
+ Removed compatibility patches
+
+2010-03-14 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Description changed
+ Added x86_64 to the arch array
+ Added a GCC 4.4 compatibility patch
+
+2008-05-09 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Using $srcdir and $pkgdir variables
+ Applying a GCC 4.3 compatibility patch