summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpixl2023-05-02 19:58:55 -0400
committerpixl2023-05-02 19:58:55 -0400
commit7dd07c9345eee388d6d51c383af73154ae205b02 (patch)
treed42fc8d7f360040d2780326b0e7e786e738575c4
parentc104922ec351f3ea42454c3c557dd3aaf323f96c (diff)
downloadaur-7dd07c9345eee388d6d51c383af73154ae205b02.tar.gz
Update to v0.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54a1df73e814..7cb7e2433e6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = logiops
pkgdesc = An unofficial driver for Logitech HID++>2.0 mice and keyboard
- pkgver = 0.2.3
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/PixlOne/logiops
arch = x86_64
@@ -15,10 +15,10 @@ pkgbase = logiops
depends = systemd-libs
depends = libconfig
depends = libudev.so
+ depends = glib2
provides = logiops
conflicts = logiops
- source = https://github.com/PixlOne/logiops/archive/v0.2.3.tar.gz
- sha256sums = 45147cacc5e75d461fa53e6f391aa6994cc724a422d1a8f8943e50186854f88f
+ source = git+https://github.com/PixlOne/logiops#tag=v0.3.0
+ sha256sums = SKIP
pkgname = logiops
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index c9724a9e995d..7444d6094d25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,23 @@
pkgname=logiops
_pkgname="logiops"
_gitpkgname="logiops"
-pkgver=0.2.3
+pkgver=0.3.0
pkgrel=1
pkgdesc="An unofficial driver for Logitech HID++>2.0 mice and keyboard"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/PixlOne/$_gitpkgname"
license=('GPL3')
-depends=('libevdev' 'systemd-libs' 'libconfig' 'libudev.so')
+depends=('libevdev' 'systemd-libs' 'libconfig' 'libudev.so' 'glib2')
makedepends=('cmake')
conflicts=("${_pkgname-*}")
provides=("${_pkgname-*}")
-source=("https://github.com/PixlOne/$_gitpkgname/archive/v$pkgver.tar.gz")
-sha256sums=('45147cacc5e75d461fa53e6f391aa6994cc724a422d1a8f8943e50186854f88f')
+source=("git+https://github.com/PixlOne/$_gitpkgname#tag=v$pkgver")
+sha256sums=('SKIP')
build() {
- cd "$_gitpkgname-$pkgver"
+ cd "$_gitpkgname"
mkdir -p build
cd build
- rm -rf *
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release
@@ -28,6 +27,6 @@ build() {
}
package() {
- cd "$_gitpkgname-$pkgver/build"
+ cd "$_gitpkgname/build"
make install DESTDIR="$pkgdir"
}