summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquietvoid2023-02-19 21:19:13 -0500
committerquietvoid2023-02-19 21:19:13 -0500
commit7dec53f0bcdd9a3ee2afbd18a784f20983b14dca (patch)
tree4b9c0c9b8da7bbc3b12a1af00e0f9f2202cdb92c
parentb73d26f22a37456f07a7b127095ef8b0e7320696 (diff)
downloadaur-7dec53f0bcdd9a3ee2afbd18a784f20983b14dca.tar.gz
Fix build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b455905d1671..df8cdb814789 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = vapoursynth-plugin-awsmfunc-git
pkgdesc = Plugin for VapourSynth: awsmfunc (GIT version)
- pkgver = 1.3.2.r3.g41cf38e
+ pkgver = 1.3.3.r6.ge2f9904
pkgrel = 1
url = https://github.com/OpusGang/awsmfunc
arch = x86_64
license = MIT
makedepends = git
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-wheel
depends = python-numpy
depends = vapoursynth-plugin-vsutil
diff --git a/PKGBUILD b/PKGBUILD
index 1ba736f11f43..6a34b1243b1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=awsmfunc
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=1.3.2.r3.g41cf38e
+pkgver=1.3.3.r6.ge2f9904
pkgrel=1
pkgdesc='Plugin for VapourSynth: awsmfunc (GIT version)'
arch=('x86_64')
@@ -14,7 +14,8 @@ depends=('python-numpy'
'vapoursynth-plugin-remapframes'
'vapoursynth-plugin-fillborders')
makedepends=('git'
- 'python-pip'
+ 'python-build'
+ 'python-installer'
'python-wheel')
optdepends=('vapoursynth-plugin-placebo: VapourSynth placebo plugin'
'vapoursynth-plugin-descale: VapourSynth descale plugin'
@@ -32,13 +33,13 @@ pkgver() {
build() {
cd "${_plug}"
- pip wheel --no-deps . -w dist
+ python -m build --wheel --no-isolation
}
package() {
cd "${_plug}"
- pip install -I --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/README.md"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}