summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-16 07:11:21 +1300
committercaltlgin2020-10-16 07:11:21 +1300
commit7e061c6c7a0a45c3df8c26daa64fe6381115d37c (patch)
tree04b79be29cafd2ad27849d667c8334c2c5c641dd
parent57807d22202f67c6bc24d9a1fd90f1df7d85e39b (diff)
downloadaur-7e061c6c7a0a45c3df8c26daa64fe6381115d37c.tar.gz
Correct pkgver function. Strip _pkgname from source.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfde98b9f5d8..bc299e035892 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bpytop-git
pkgdesc = Resource monitor that shows usage and stats for processor, memory, disks, network and processes
- pkgver = r226.adee413
+ pkgver = 1.0.42.r0.gadee413
pkgrel = 1
url = https://github.com/aristocratos/bpytop
arch = any
@@ -10,7 +10,7 @@ pkgbase = bpytop-git
depends = python-psutil
provides = bpytop
conflicts = bpytop
- source = bpytop::git+https://github.com/aristocratos/bpytop.git
+ source = git+https://github.com/aristocratos/bpytop.git
sha256sums = SKIP
pkgname = bpytop-git
diff --git a/PKGBUILD b/PKGBUILD
index 35fd9152292c..5843870e6ff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname='bpytop'
pkgname="${_pkgname}-git"
-pkgver=r226.adee413
+pkgver=1.0.42.r0.gadee413
pkgrel=1
pkgdesc='Resource monitor that shows usage and stats for processor, memory, disks, network and processes'
arch=('any')
@@ -12,12 +12,11 @@ depends=('python-psutil')
makedepends=('git' 'python-setuptools')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+${url}.git")
+source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {