summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiklós Tóth2024-03-07 00:02:43 +0000
committerMiklós Tóth2024-03-07 00:02:43 +0000
commit7e18952f37bc873e1160cb96560f49a6bbb18d05 (patch)
treec2298a299d2ad48e055eafca78fe95cf3dadebaa
parente3d55f1a978b6127b73004a1bd390f57dbf8a6fe (diff)
downloadaur-7e18952f37bc873e1160cb96560f49a6bbb18d05.tar.gz
automatic update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c9858821f79..cd136bf93782 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-anbox
pkgdesc = Linux Xanmod with ashmem and binder enabled for Anbox - Stable Mainline [MAIN]
- pkgver = 6.7.7
+ pkgver = 6.7.9
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -17,13 +17,13 @@ pkgbase = linux-xanmod-anbox
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.7.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.7.tar.sign
- source = patch-6.7.7-xanmod1.xz::https://sourceforge.net/projects/xanmod/files/releases/main/6.7.7-xanmod1/patch-6.7.7-xanmod1.xz/download
+ source = patch-6.7.9-xanmod1.xz::https://sourceforge.net/projects/xanmod/files/releases/main/6.7.9-xanmod1/patch-6.7.9-xanmod1.xz/download
source = choose-gcc-optimization.sh
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = ef31144a2576d080d8c31698e83ec9f66bf97c677fa2aaf0d5bbb9f3345b1069
sha256sums = SKIP
- sha256sums = 1bf862e6ba0feeffdf4a90068462abf35df524385f921d6adbaa9a147360fabc
+ sha256sums = ffa31e3d22f8bbcb44f99ba72399c7ba09e3387e57ca46cdc31d1b18b2e91903
sha256sums = a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f
pkgname = linux-xanmod-anbox
diff --git a/PKGBUILD b/PKGBUILD
index 5539b6362f14..4c3c0c690e89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -73,7 +73,7 @@ fi
pkgbase=linux-xanmod-anbox
_major=6.7
-pkgver=${_major}.7
+pkgver=${_major}.9
_branch=6.x
xanmod=1
_revision=
@@ -82,7 +82,6 @@ pkgrel=${xanmod}
pkgdesc='Linux Xanmod with ashmem and binder enabled for Anbox - Stable Mainline [MAIN]'
url="http://www.xanmod.org/"
arch=(x86_64)
-
license=(GPL2)
makedepends=(
bc
@@ -118,7 +117,7 @@ done
sha256sums=('ef31144a2576d080d8c31698e83ec9f66bf97c677fa2aaf0d5bbb9f3345b1069'
'SKIP'
- '1bf862e6ba0feeffdf4a90068462abf35df524385f921d6adbaa9a147360fabc'
+ 'ffa31e3d22f8bbcb44f99ba72399c7ba09e3387e57ca46cdc31d1b18b2e91903'
'a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -230,7 +229,9 @@ prepare() {
fi
fi
+ msg2 "make ${_compiler_flags} olddefconfig"
make ${_compiler_flags} olddefconfig
+ #diff -u CONFIGS/xanmod/gcc/${_config} .config || :
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
@@ -246,6 +247,7 @@ prepare() {
build() {
cd linux-${_major}
make ${_compiler_flags} all
+ make -C tools/bpf/bpftool vmlinux.h feature-clang-bpf-co-re=1
}
_package() {
@@ -298,7 +300,7 @@ _package-headers() {
msg2 "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
- localversion.* version vmlinux
+ localversion.* version vmlinux tools/bpf/bpftool/vmlinux.h
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
@@ -307,7 +309,7 @@ _package-headers() {
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# required when DEBUG_INFO_BTF_MODULES is enabled
- if [ -f "tools/bpf/resolve_btfids/resolve_btfids" ]; then install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids ; fi
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
msg2 "Installing headers..."
cp -t "$builddir" -a include