summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author3JlOy_PYCCKUI2022-01-14 03:55:42 +0300
committer3JlOy_PYCCKUI2022-01-14 03:55:42 +0300
commit7e2a8142582df6c73a91d64fef22360d7e23faf8 (patch)
treee2f845d7892e103f2738dc5acf7b467626d14fbf
parent65b65977960d4579e6a448c7fa1b66061f4e4da8 (diff)
downloadaur-7e2a8142582df6c73a91d64fef22360d7e23faf8.tar.gz
build with qt6
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3505c6601f99..270286dd5f0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kotatogram-dev-git
pkgdesc = Kotatogram – experimental Telegram Desktop fork - Dev branch
pkgver = k1.4.8.r174.g98f2683e5
- pkgrel = 2
+ pkgrel = 3
url = https://kotatogram.github.io
arch = x86_64
license = GPL3
@@ -13,6 +13,8 @@ pkgbase = kotatogram-dev-git
makedepends = tl-expected
makedepends = microsoft-gsl
makedepends = extra-cmake-modules
+ makedepends = wayland-protocols
+ makedepends = plasma-wayland-protocols
makedepends = webkit2gtk
makedepends = unzip
makedepends = yasm
@@ -24,10 +26,10 @@ pkgbase = kotatogram-dev-git
depends = minizip
depends = openal
depends = ttf-opensans
- depends = qt5-imageformats
- depends = qt5-svg
- depends = qt5-wayland
- depends = libdbusmenu-qt5
+ depends = qt6-imageformats
+ depends = qt6-svg
+ depends = qt6-wayland
+ depends = qt6-5compat
depends = xxhash
depends = kwayland
depends = glibmm
diff --git a/PKGBUILD b/PKGBUILD
index 6eb12f0baf9f..872249026b83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,18 +7,18 @@
pkgname=kotatogram-dev-git
_pkgname=kotatogram-desktop
pkgver=k1.4.8.r174.g98f2683e5
-pkgrel=2
+pkgrel=3
pkgdesc='Kotatogram – experimental Telegram Desktop fork - Dev branch'
arch=('x86_64')
url="https://kotatogram.github.io"
license=('GPL3')
provides=(kotatogram-desktop kotatogram-desktop-git)
depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
- 'qt5-imageformats' 'qt5-svg' 'qt5-wayland' 'libdbusmenu-qt5' 'xxhash' 'kwayland' 'glibmm'
+ 'qt6-imageformats' 'qt6-svg' 'qt6-wayland' 'qt6-5compat' 'xxhash' 'kwayland' 'glibmm'
'rnnoise' 'pipewire' 'libxtst' 'jemalloc' 'libxrandr' 'abseil-cpp' 'libjpeg-turbo' 'opus' 'openssl' 'libx11' 'libvpx' 'libxcomposite'
'libxdamage' 'libxext' 'libxfixes' 'zlib' 'wayland' 'glibc' 'libsigc++' 'glib2' 'xcb-util-keysyms' 'libxcb' 'gcc-libs')
makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl'
- 'extra-cmake-modules' 'webkit2gtk' 'unzip'
+ 'extra-cmake-modules' 'wayland-protocols' 'plasma-wayland-protocols' 'webkit2gtk' 'unzip'
'yasm' 'libtg_owt')
optdepends=('webkit2gtk: embedded browser features'
'xdg-desktop-portal: desktop integration')
@@ -104,7 +104,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- git submodule init
git config submodule.cmake.url "${srcdir}/${_pkgname}-cmake_helpers"
@@ -141,7 +140,7 @@ prepare() {
git config submodule.Telegram/ThirdParty/kwayland.url "${srcdir}/${_pkgname}-kwayland"
git config submodule.Telegram/ThirdParty/dispatch.url "${srcdir}/${_pkgname}-dispatch"
- git submodule update
+ git submodule update --init
#patches
patch -p1 < "${srcdir}/0001-Add-an-option-to-hide-messages-from-blocked-users-in.patch"
@@ -150,12 +149,12 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
+ export CXXFLAGS+=" -Wp,-U_GLIBCXX_ASSERTIONS"
cmake . \
-B build \
-G Ninja \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_BUILD_TYPE=Release \
- -DDESKTOP_APP_QT6=off \
-DTDESKTOP_API_TEST=ON
cmake --build build
}