aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Grimes2015-06-08 12:22:34 -0400
committerMark Grimes2015-06-08 12:23:56 -0400
commit7e4e224fa5eb3140afc141069b8cde5e6d59e459 (patch)
tree483e57f4cc9b9cb0548b6db26b11429041aaacee
parente21dc1b10b212f6d2fcd3a179b005942405ab847 (diff)
downloadaur-7e4e224fa5eb3140afc141069b8cde5e6d59e459.tar.gz
Updates for AUR4, add license, general improvements
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD26
3 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e96f5d6d12b9..56c892be3c60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = perl-nagios-plugin
pkgdesc = A family of perl modules to streamline writing Nagios plugins
pkgver = 0.36
- pkgrel = 1
- url = http://search.cpan.org/dist/Nagios-Plugin
+ pkgrel = 2
+ url = https://metacpan.org/release/Nagios-Plugin
arch = any
- license = unknown
+ license = GPL
+ license = PerlArtistic
depends = perl>=5.10.0
depends = perl-params-validate
depends = perl-class-accessor
depends = perl-config-tiny
depends = perl-math-calc-units
options = !emptydirs
+ options = purge
source = http://search.cpan.org/CPAN/authors/id/T/TO/TONVOON/Nagios-Plugin-0.36.tar.gz
md5sums = b897f6d5d66a655dde7caec579efcf2e
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2559e3b56323
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+Nagios-Plugin-*.tar.gz
+perl-nagios-plugin-*.src.tar.gz
+perl-nagios-plugin-*.pkg.tar.gz
+*.swp
diff --git a/PKGBUILD b/PKGBUILD
index 2cc0a5845a00..30ec258f3295 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,40 @@
# Maintainer: Mark Grimes <mgrimes at peculier.com>
+# https://github.com/mvgrimes/aur-perl-nagios-plugin
+
pkgname=perl-nagios-plugin
pkgver=0.36
-pkgrel=1
+pkgrel=2
pkgdesc="A family of perl modules to streamline writing Nagios plugins"
_dist=Nagios-Plugin
arch=('any')
-url="http://search.cpan.org/dist/$_dist"
-license=('unknown')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
depends=('perl>=5.10.0' 'perl-params-validate' 'perl-class-accessor' 'perl-config-tiny' 'perl-math-calc-units')
-options=(!emptydirs)
+options=('!emptydirs' purge)
source=(http://search.cpan.org/CPAN/authors/id/T/TO/TONVOON/$_dist-$pkgver.tar.gz)
md5sums=('b897f6d5d66a655dde7caec579efcf2e')
+# Setup environment to ensure installation in system perl and vender directory
+clean_env() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null PERL_AUTOINSTALL=--skipdeps
+}
+
build() (
cd "$srcdir/$_dist-$pkgver"
- unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ clean_env
/usr/bin/perl Makefile.PL
make
)
check() (
cd "$srcdir/$_dist-$pkgver"
- unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
- export PERL_MM_USE_DEFAULT=1
+ clean_env
make test
)
package() (
cd "$srcdir/$_dist-$pkgver"
- unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ clean_env
make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
)
-
-# vim:set ts=2 sw=2 et: