summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2016-10-29 13:56:13 -0700
committerEric Anderson2016-10-29 13:56:13 -0700
commit7e5db3e51b301ea81e574fae4652bc34f07d912b (patch)
tree65e1051a7675f3562f42758c70e106ea38752019
parentec2279b29069d6644a4be4abec89faf2bebdf5ca (diff)
downloadaur-7e5db3e51b301ea81e574fae4652bc34f07d912b.tar.gz
Update to 20160217
The fullscreen bug appears fixed, without any manual configuration. The binary now expects to find SuperHexagon.png, maybe for a window icon. Dependencies also changed a bit.
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD28
-rw-r--r--superhexagon.install14
-rwxr-xr-xsuperhexagon.sh6
-rw-r--r--superhexagonrc.example6
6 files changed, 21 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ac75f48e079..5a3e1242238b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,24 @@
# Generated by mksrcinfo v8
-# Sat Oct 29 19:42:08 UTC 2016
+# Sat Oct 29 20:04:51 UTC 2016
pkgbase = superhexagon
pkgdesc = A minimal action game by Terry Cavanagh, with music by Chipzel
- pkgver = 16
- pkgrel = 3
+ pkgver = 20160217
+ pkgrel = 1
url = http://superhexagon.com/
- install = superhexagon.install
arch = i686
arch = x86_64
license = custom
- depends = gcc-libs
- depends = freeglut
depends = libvorbis
depends = openal
- depends = glu
+ depends = sdl2
depends = glew1.6
- noextract = super-hexagon-linux-16-bin-1366677959
- source = hib://super-hexagon-linux-16-bin-1366677959
+ noextract = superhexagon-02172016-bin
+ source = hib://superhexagon-02172016-bin
source = superhexagon.sh
source = superhexagon.desktop
- source = superhexagon.install
- source = superhexagonrc.example
- sha256sums = 2c6dfba53cb0dd58bcbff519862af8bf7af67475845bb43207e9d32032efa104
- sha256sums = fecc1b8c99b3758ac705ed6f8eedb8a28434d2cdd91deec457e192b3be280273
+ sha256sums = a27df72e78e8e7b791d213ab3da5b18f38b26c2d3a5dca58c47172bef6278527
+ sha256sums = 03e3f570cb09c92980e24510846db477e5d61880d6457e4bb627df51058ea0f8
sha256sums = 6399b71d49dc5e313b6e882ae51b33df043b945ae102666c94a457cfaac15e4e
- sha256sums = 1f183c17982dd12f8a1ccd310d27c74eaf83f550571e8e6ff77cc735f29b55b7
- sha256sums = ff966f4106571ae7e5906bb2a47944d03c3ec73e280f43c1693da8121df80a81
pkgname = superhexagon
diff --git a/.gitignore b/.gitignore
index 2e37f905d198..36d7c56d3037 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@ src/
linux-*.tar.gz
patch.tar.bz2
super-hexagon-*-bin*
+superhexagon-*-bin*
diff --git a/PKGBUILD b/PKGBUILD
index 31ef148f0dc1..1a9c8548b6c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,22 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=superhexagon
-pkgver=16
-pkgrel=3
+pkgver=20160217
+_pkgver=02172016
+pkgrel=1
pkgdesc="A minimal action game by Terry Cavanagh, with music by Chipzel"
arch=('i686' 'x86_64')
url="http://superhexagon.com/"
license=('custom')
-depends=('gcc-libs' 'freeglut' 'libvorbis' 'openal' 'glu' 'glew1.6')
-install="${pkgname}.install"
-_binver="1366677959"
-_gamepkg="super-hexagon-linux-${pkgver}-bin-${_binver}"
+depends=('libvorbis' 'openal' 'sdl2' 'glew1.6')
+_gamepkg="${pkgname}-${_pkgver}-bin"
source=("hib://${_gamepkg}"
"${pkgname}.sh"
- "${pkgname}.desktop"
- "${pkgname}.install"
- "${pkgname}rc.example")
+ "${pkgname}.desktop")
noextract=("${_gamepkg}")
-sha256sums=('2c6dfba53cb0dd58bcbff519862af8bf7af67475845bb43207e9d32032efa104'
- 'fecc1b8c99b3758ac705ed6f8eedb8a28434d2cdd91deec457e192b3be280273'
- '6399b71d49dc5e313b6e882ae51b33df043b945ae102666c94a457cfaac15e4e'
- '1f183c17982dd12f8a1ccd310d27c74eaf83f550571e8e6ff77cc735f29b55b7'
- 'ff966f4106571ae7e5906bb2a47944d03c3ec73e280f43c1693da8121df80a81')
+sha256sums=('a27df72e78e8e7b791d213ab3da5b18f38b26c2d3a5dca58c47172bef6278527'
+ '03e3f570cb09c92980e24510846db477e5d61880d6457e4bb627df51058ea0f8'
+ '6399b71d49dc5e313b6e882ae51b33df043b945ae102666c94a457cfaac15e4e')
# You can download the Humble Indie Bundle file manually, or you can configure
# DLAGENTS in makepkg.conf to auto-download.
@@ -51,7 +46,7 @@ package()
install -d "${pkgdir}/opt/${pkgname}"
install -m644 -t "${pkgdir}/opt/${pkgname}" \
Linux.README \
- "${srcdir}/${pkgname}rc.example"
+ SuperHexagon.png
cp -r data "${pkgdir}/opt/${pkgname}"
rm "${pkgdir}/opt/${pkgname}/data/license.txt"
@@ -64,7 +59,8 @@ package()
fi
install -D -m755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
- install -D -m644 "SuperHexagon.png" \
+ install -d "${pkgdir}/usr/share/pixmaps"
+ ln -s "/opt/${pkgname}/SuperHexagon.png" \
"${pkgdir}/usr/share/pixmaps/${pkgname}.png"
install -D -m644 "${srcdir}/${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
diff --git a/superhexagon.install b/superhexagon.install
deleted file mode 100644
index d03ed1f1f8fc..000000000000
--- a/superhexagon.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install()
-{
- echo 'See /opt/superhexagon/superhexagonrc.example for how to configure'
- echo 'fullscreen resolution. This fixes fullscreen with multihead setups!'
-}
-
-post_upgrade()
-{
- if [ "${2%-*}" -le 16 ]; then
- echo 'Fullscreen resolution configuration has been moved to '
- echo '$HOME/.config/superhexagonrc to prevent overwriting during upgrade.'
- post_install
- fi
-}
diff --git a/superhexagon.sh b/superhexagon.sh
index c098283c4c95..b31a35e9a7d8 100755
--- a/superhexagon.sh
+++ b/superhexagon.sh
@@ -1,9 +1,3 @@
#!/bin/sh
-
-# Provide a chance to configure GLUT. For an example, see
-# /opt/superhexagon/superhexagonrc.example
-CONFIG="${XDG_CONFIG_HOME:-$HOME/.config}"
-test -f "$CONFIG" && . "$CONFIG"
-
cd /opt/superhexagon
exec ./superhexagon
diff --git a/superhexagonrc.example b/superhexagonrc.example
deleted file mode 100644
index 20549755729f..000000000000
--- a/superhexagonrc.example
+++ /dev/null
@@ -1,6 +0,0 @@
-# Example superhexagonrc. Place this file in $HOME/.config/superhexagonrc
-
-# Display settings, because GLUT is a derp
-# Thanks to BtbN for this idea!
-export HEX_WIDTH=1920
-export HEX_HEIGHT=1200