summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2021-02-24 21:04:13 -0500
committerBen Westover2021-02-24 21:04:13 -0500
commit7e6d2a4016fe4726102b1a604a9c476d52889c20 (patch)
tree61215d20edea717afa68f31930e453584c4de089
downloadaur-7e6d2a4016fe4726102b1a604a9c476d52889c20.tar.gz
Initial Commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD54
-rw-r--r--chia-gui.desktop9
-rwxr-xr-xchia-gui.sh5
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee9627106c23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = chia-git-gui
+ pkgdesc = A new blockchain and smart transaction platform that is easier to use, more efficient, and secure. - Also installs GUI
+ pkgver = 1.0rc2.r0.g6518b2bf
+ pkgrel = 1
+ url = https://www.chia.net/
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
+ license = Apache
+ makedepends = cmake
+ depends = git
+ depends = python
+ depends = npm
+ depends = nodejs
+ provides = chia
+ provides = chia-gui
+ conflicts = chia
+ conflicts = chia-gui
+ options = !strip
+ source = git+https://github.com/Chia-Network/chia-blockchain.git
+ source = git+https://github.com/Chia-Network/chia-blockchain-gui.git
+ source = chia-gui.desktop
+ source = chia-gui.sh
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 62693edb1a75f2a44b62d1a4f02b1ae755d40eb02dd7faf5f65ea6253e5e3645
+ sha256sums = f9f78823f67f79813cca27bb200d5608b5adc2a37c2a7ebd90a6e80e02245ade
+
+pkgname = chia-git-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41dddc10d0d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Ben Westover <kwestover.kw@gmail.com>
+
+pkgname='chia-git-gui'
+pkgver=1.0rc2.r0.g6518b2bf
+pkgrel=1
+pkgdesc="A new blockchain and smart transaction platform that is easier to use, more efficient, and secure. - Also installs GUI"
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
+url="https://www.chia.net/"
+license=('Apache')
+depends=('git' 'python' 'npm' 'nodejs')
+makedepends=('cmake')
+conflicts=('chia' 'chia-gui')
+provides=('chia' 'chia-gui')
+options=('!strip')
+source=("git+https://github.com/Chia-Network/chia-blockchain.git"
+ "git+https://github.com/Chia-Network/chia-blockchain-gui.git"
+ "chia-gui.desktop"
+ "chia-gui.sh")
+sha256sums=('SKIP'
+ 'SKIP'
+ '62693edb1a75f2a44b62d1a4f02b1ae755d40eb02dd7faf5f65ea6253e5e3645'
+ 'f9f78823f67f79813cca27bb200d5608b5adc2a37c2a7ebd90a6e80e02245ade')
+
+pkgver() {
+ cd chia-blockchain # using other repo since gui repo doesn't have any tags yet
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd chia-blockchain
+ python3 -m venv venv
+ ln -s venv/bin/activate .
+ . ./activate
+ pip install --upgrade pip
+ pip install wheel
+ pip install --extra-index-url https://download.chia.net/simple/ miniupnpc==2.1
+ pip install -e . --extra-index-url https://download.chia.net/simple/
+ cd ../chia-blockchain-gui
+ npm install
+ npm audit fix
+ npm run locale:extract
+ npm run locale:compile
+ npm run build
+}
+
+package() {
+ if [ -n "${_install-gui}" ]; then
+ install -Dm644 chia-blockchain-gui/src/assets/img/circle-cropped.png "$pkgdir"/usr/share/pixmaps/chia.png
+ install -Dm755 chia-gui.sh "$pkgdir"/usr/bin/chia-gui
+ install -Dm644 chia-gui.desktop "$pkgdir"/usr/share/applications/chia-gui.desktop
+ fi
+ mkdir -p "$pkgdir"/opt
+ mv chia-blockchain "$pkgdir"/opt
+}
diff --git a/chia-gui.desktop b/chia-gui.desktop
new file mode 100644
index 000000000000..84205121cbc6
--- /dev/null
+++ b/chia-gui.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=Chia
+Comment=A new blockchain and smart transaction platform that is easier to use, more efficient, and secure.
+Exec=chia-gui %u
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/chia.png
+Categories=Finance;P2P;Network;
diff --git a/chia-gui.sh b/chia-gui.sh
new file mode 100755
index 000000000000..8bbdb393ac2a
--- /dev/null
+++ b/chia-gui.sh
@@ -0,0 +1,5 @@
+#!/bin/bash
+cd /opt/chia-blockchain
+. ./activate
+cd /opt/chia-blockchain-gui
+npm run electron