summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2022-03-15 11:32:35 -0300
committerGonzalo Exequiel Pedone2022-03-15 11:32:35 -0300
commit7ea534b8d35f274f34f03ab162e07c1db35099b7 (patch)
tree0985a725e19a524112eff7a0aec6c8fcf6171553
parentccfaacc13dada10ed2f09e5badaccb8b98d91b80 (diff)
downloadaur-7ea534b8d35f274f34f03ab162e07c1db35099b7.tar.gz
Updated to 2.9.13.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5ee4bba72e5..dcdc7a4fee56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = android-armv7a-eabi-libxml2
pkgdesc = XML parsing library, version 2 (android)
- pkgver = 2.9.12
+ pkgver = 2.9.13
pkgrel = 1
url = http://www.xmlsoft.org/
arch = any
+ groups = android-libxml2
license = LGPL
makedepends = android-configure
depends = android-ndk
@@ -14,7 +15,7 @@ pkgbase = android-armv7a-eabi-libxml2
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://xmlsoft.org/sources/libxml2-2.9.12.tar.gz
- md5sums = f433a39be087a9f0b197eb2307ad9f75
+ source = https://gitlab.gnome.org/GNOME/libxml2/-/archive/v2.9.13/libxml2-v2.9.13.tar.gz
+ md5sums = 99dbd55a77c09edeeaaef5412e98769b
pkgname = android-armv7a-eabi-libxml2
diff --git a/PKGBUILD b/PKGBUILD
index a7039e01d303..1c9a64c98ed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_android_arch=armv7a-eabi
pkgname=android-${_android_arch}-libxml2
-pkgver=2.9.12
+pkgver=2.9.13
pkgrel=1
pkgdesc="XML parsing library, version 2 (android)"
arch=('any')
@@ -14,13 +14,14 @@ depends=('android-ndk'
"android-${_android_arch}-libiconv"
"android-${_android_arch}-zlib"
"android-${_android_arch}-xz")
+groups=(android-libxml2)
options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-configure')
-source=("http://xmlsoft.org/sources/libxml2-${pkgver}.tar.gz")
-md5sums=('f433a39be087a9f0b197eb2307ad9f75')
+source=("https://gitlab.gnome.org/GNOME/libxml2/-/archive/v${pkgver}/libxml2-v${pkgver}.tar.gz")
+md5sums=('99dbd55a77c09edeeaaef5412e98769b')
prepare () {
- cd "${srcdir}"/libxml2-${pkgver}
+ cd "${srcdir}"/libxml2-v${pkgver}
source android-env ${_android_arch}
# disable doc & examples
@@ -30,7 +31,7 @@ prepare () {
build()
{
- cd "${srcdir}"/libxml2-${pkgver}
+ cd "${srcdir}"/libxml2-v${pkgver}
source android-env ${_android_arch}
android-${_android_arch}-configure \
@@ -47,7 +48,7 @@ build()
package()
{
- cd "${srcdir}"/libxml2-${pkgver}
+ cd "${srcdir}"/libxml2-v${pkgver}
source android-env ${_android_arch}
make DESTDIR="$pkgdir" install