summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2021-09-30 23:53:15 +0200
committerJoan Figueras2021-09-30 23:53:15 +0200
commit7ea967c46b82a1311f372bea30efdd4a387d1a1a (patch)
treeadce296dc8740d44b6af4c3cf9f0a9f8bb6ee4c3
parent33590ea921f2ff8834c59f645a1d4082357c471d (diff)
downloadaur-7ea967c46b82a1311f372bea30efdd4a387d1a1a.tar.gz
Introducing new variable to compress modules with ZSTD
-rw-r--r--PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74eb8d0e3f19..0164ac9e131e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,6 +39,11 @@ if [ -z ${_compiler+x} ]; then
_compiler=gcc
fi
+# Compress modules with ZSTD (to save disk space)
+if [ -z ${_compress_modules+x} ]; then
+ _compress_modules=n
+fi
+
# Compile ONLY used modules to VASTLY reduce the number of modules built
# and the build time.
#
@@ -152,6 +157,11 @@ prepare() {
scripts/config --disable CONFIG_NUMA
fi
+ # Compress modules by default (following Arch's kernel)
+ if [ "$_compress_modules" = "y" ]; then
+ scripts/config --enable CONFIG_MODULE_COMPRESS_ZSTD
+ fi
+
# Let's user choose microarchitecture optimization in GCC
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture