aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuuki Galaxy2018-08-29 19:07:38 +0800
committerYuuki Galaxy2018-08-29 19:07:38 +0800
commit7eadb10d4dc8edde10ed399107551a280185f140 (patch)
tree5c48dcb2aa96dd01c1446706c7d7abf323e54ad1
parentc31e5fd4ad7db9a4cab0ea0119762862cadb81c8 (diff)
downloadaur-7eadb10d4dc8edde10ed399107551a280185f140.tar.gz
Add patch from seawright
-rw-r--r--PKGBUILD3
-rw-r--r--README.md2
-rw-r--r--seawright.patch29
3 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4344be2afd7..90b6a91ffb10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,6 +18,7 @@ license=(GPL2)
makedepends=(gtk2 git)
source=(oss::git://git.code.sourceforge.net/p/opensound/git
oss4_sys-libs_glibc-2.23_ossdetect_fix_git.patch
+ seawright.patch
oss.service
remove-hal.patch
rm-init-scripts.patch
@@ -26,6 +27,7 @@ source=(oss::git://git.code.sourceforge.net/p/opensound/git
ossvermagic.patch)
sha512sums=('SKIP'
'5599f75ac2784aca7d0367e88705938d2680e7a0eb7ae7300080e3fc0ea0c9d3b183554a9e208ed8359f675028024e8de62baa5f8dbc79e9f3bd942db6aa6157'
+ 'a1696a8775613d77d2602b9b0288b112401162b3ee8d5b487a9662521e91f5bf2daab7d1dc2e7aed5edc4d01cfd354abc3c5aaad0ceab73d8eaad7fc8f66dc3c'
'355e1380432947c0e9caa21114b2c3debeb162fb5abcf845125ec281ce52b437ad1ee1db04d37e9b7a5ac79816c4dcbc21b4ed4cf8191f71218d99acd7bab70e'
'6956e5e2e9323b568bb18e80bbee591b0e5ffd3d4612a50df09879941b2733c31d6b3178dc9a46c283bd1629f76b7ff5e2b54893a42a47f6379eaee4731fd9be'
'64e6d9d8eb5320f737d3a0698a245da2b2d141b68cfb2f02e448144d1c610aa8b8a6c38b56fcca364d63171a49afe93161a00545cdb90086b5328997b3096690'
@@ -55,6 +57,7 @@ prepare() {
# - no longer required (from commit 891ddd)
# patch -p0 < "$srcdir/linux-4.8-usercopy.patch"
patch -p0 < "$srcdir/ossvermagic.patch"
+ patch -p1 < "$srcdir/seawright.patch"
# make OSS compile with glibc >= 2.23
patch -p1 < "$srcdir/oss4_sys-libs_glibc-2.23_ossdetect_fix_git.patch"
diff --git a/README.md b/README.md
index c041ae091025..77847ca4cc1a 100644
--- a/README.md
+++ b/README.md
@@ -4,5 +4,7 @@ Original Source: <https://aur.archlinux.org/packages/oss-git>.
Fix Compile error with ossdetect with glibc starting with version 2.23 accroding to <http://ossnext.trueinstruments.com/forum/viewtopic.php?t=5855>.
+Also added patch from seawright [commented on 2018-07-23 00:08](https://aur.archlinux.org/pkgbase/oss-git/#comment-655283).
+
See also: <https://forums.gentoo.org/viewtopic-t-1039602-start-0.html>.
diff --git a/seawright.patch b/seawright.patch
new file mode 100644
index 000000000000..28d34b0d1bc9
--- /dev/null
+++ b/seawright.patch
@@ -0,0 +1,29 @@
+--- a/setup/Linux/oss/build/osscore.c 2018-07-22 16:35:24.559690072 +0100
++++ b/setup/Linux/oss/build/osscore.c 2018-07-22 16:39:42.948338371 +0100
+@@ -32,6 +32,7 @@
+ #include <linux/sched.h>
+ #include <linux/interrupt.h>
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(3,10,0)
++#include <linux/cred.h>
+ #include <linux/uidgid.h>
+ #endif
+ #undef strlen
+@@ -475,13 +476,17 @@
+ unsigned int
+ oss_get_uid (void)
+ {
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,10,0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,13,0)
++ return current->cred->uid.val;
++#else
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,14,0)
+ return __kuid_val(current->cred->uid);
+ #elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,29)
+ return current->cred->uid;
+ #else
+ return current->uid;
+ #endif
++#endif
+ return 0;
+ }
+