summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshwin V. Mohanan2021-12-03 15:20:16 +0100
committerAshwin V. Mohanan2021-12-03 15:41:59 +0100
commit7eb0b27bb2b28dda02f813ec04a859c1ca0211ac (patch)
tree220e7fd74af05664180545f24b2e0b6ab8ca89d2
parent79f815ed7b9e2734f6fbda5bc9145a32030aec90 (diff)
downloadaur-7eb0b27bb2b28dda02f813ec04a859c1ca0211ac.tar.gz
Version 8.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3180d3335359..480e4c88f8b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,30 @@
pkgbase = ipython-ipyparallel
pkgdesc = Interactive Parallel Computing in Python
- pkgver = 7.1.0
+ pkgver = 8.0.0
pkgrel = 1
url = https://github.com/ipython/ipyparallel
arch = any
license = BSD
makedepends = python-setuptools
+ makedepends = jupyterlab
+ makedepends = python-packaging
+ makedepends = npm
depends = ipython
- depends = python-setuptools
+ depends = python-dateutil
+ depends = python-decorator
+ depends = python-entrypoints
+ depends = python-ipykernel
depends = python-jupyter_client
+ depends = python-psutil
+ depends = python-pyzmq
+ depends = python-setuptools
depends = python-tornado
- depends = python-decorator
+ depends = python-tqdm
+ depends = python-traitlets
optdepends = openmpi: to use the MPI Launchers in ipcluster command
conflicts = ipython2-ipyparallel
replaces = ipython-ipyparallel
- source = https://files.pythonhosted.org/packages/source/i/ipyparallel/ipyparallel-7.1.0.tar.gz
- sha256sums = ea756df0d2485bac19cccb0dbf4cafbc855c922b9b5905b4906e6cfac8b3c648
+ source = https://files.pythonhosted.org/packages/source/i/ipyparallel/ipyparallel-8.0.0.tar.gz
+ sha256sums = 95305a886f2c42e9603c034ea684e5c031d9d4222c66ed6d85eb3ae15d631e4b
pkgname = python-ipyparallel
diff --git a/PKGBUILD b/PKGBUILD
index 32fc43c13318..24f8638c2bbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,30 @@
_name=ipyparallel
pkgbase=ipython-${_name}
pkgname=python-${_name}
-pkgver=7.1.0
+pkgver=8.0.0
pkgrel=1
pkgdesc="Interactive Parallel Computing in Python"
url="https://github.com/ipython/ipyparallel"
arch=(any)
license=('BSD')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'jupyterlab' 'python-packaging' 'npm')
optdepends=('openmpi: to use the MPI Launchers in ipcluster command')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('ea756df0d2485bac19cccb0dbf4cafbc855c922b9b5905b4906e6cfac8b3c648')
-depends=('ipython' 'python-setuptools' 'python-jupyter_client' 'python-tornado' 'python-decorator')
+sha256sums=('95305a886f2c42e9603c034ea684e5c031d9d4222c66ed6d85eb3ae15d631e4b')
+depends=(
+ 'ipython'
+ 'python-dateutil'
+ 'python-decorator'
+ 'python-entrypoints'
+ 'python-ipykernel'
+ 'python-jupyter_client'
+ 'python-psutil'
+ 'python-pyzmq'
+ 'python-setuptools'
+ 'python-tornado'
+ 'python-tqdm'
+ 'python-traitlets'
+)
conflicts=('ipython2-ipyparallel')
replaces=('ipython-ipyparallel')