summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2020-11-05 21:20:58 -0600
committerkyechou2020-11-05 21:20:58 -0600
commit7eb878fbfe68b28844fc8737c66d2cd71b82d150 (patch)
tree4aed2bfef37a4a4e0a34db814e3b673edbfded3b
parent7a436aeac9349f20acf0618a2abfda399518fef7 (diff)
downloadaur-7eb878fbfe68b28844fc8737c66d2cd71b82d150.tar.gz
Update to 1.6.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8da0e6a4aba9..3324b5f78da3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = bgpdump
- pkgdesc = A C library designed to help with analyzing dump files produced by Zebra/Quagga or MRT
- pkgver = 1.6.0
+ pkgdesc = Utility and C Library for parsing MRT files
+ pkgver = 1.6.2
pkgrel = 1
- url = https://bitbucket.org/ripencc/bgpdump
+ url = https://github.com/RIPE-NCC/bgpdump
arch = x86_64
- license = GPL
- makedepends = autoconf
+ license = GPL2
depends = zlib
depends = bzip2
- provides = bgpdump
- source = https://bitbucket.org/ripencc/bgpdump/get/1.6.0.tar.gz
- sha512sums = 04883a01fbc2829a4298b3f280d1a6c023f57fbabca082ea8578130235a088c0f326888c523b1e59485cc889b9c18888beb1a5bc3ecd0fe1054200c390251153
+ source = https://github.com/RIPE-NCC/bgpdump/archive/v1.6.2.tar.gz
+ sha256sums = 415692c173a84c48b1e927a6423a4f8fd3e6359bc3008c06b7702fe143a76223
pkgname = bgpdump
diff --git a/PKGBUILD b/PKGBUILD
index de1b5279099f..a043a17d126b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,28 @@
-# Maintainer: Kuan-Yen Chou <forendef2846 at gmail dot com>
+# Maintainer: Kuan-Yen Chou <kuanyenchou at gmail dot com>
pkgname=bgpdump
-pkgver=1.6.0
+pkgver=1.6.2
pkgrel=1
-pkgdesc='A C library designed to help with analyzing dump files produced by Zebra/Quagga or MRT'
-depends=('zlib' 'bzip2')
-makedepends=('autoconf')
+pkgdesc='Utility and C Library for parsing MRT files'
arch=('x86_64')
-url="https://bitbucket.org/ripencc/bgpdump"
-license=('GPL')
-provides=('bgpdump')
-source=("https://bitbucket.org/ripencc/bgpdump/get/${pkgver}.tar.gz")
-sha512sums=('04883a01fbc2829a4298b3f280d1a6c023f57fbabca082ea8578130235a088c0f326888c523b1e59485cc889b9c18888beb1a5bc3ecd0fe1054200c390251153')
+url="https://github.com/RIPE-NCC/bgpdump"
+license=('GPL2')
+depends=('zlib' 'bzip2')
+makedepends=()
+source=("https://github.com/RIPE-NCC/bgpdump/archive/v${pkgver}.tar.gz")
+sha256sums=('415692c173a84c48b1e927a6423a4f8fd3e6359bc3008c06b7702fe143a76223')
build() {
- cd "${srcdir}"/ripencc-bgpdump-*
+ cd "${srcdir}/${pkgname}-${pkgver}"
autoheader
autoconf
- ./configure \
- --prefix="${pkgdir}/usr" \
- --sbindir="${pkgdir}/usr/bin"
+ ./configure --prefix=/usr --sbindir=/usr/bin
make
}
package() {
- cd "$srcdir"/ripencc-bgpdump-*
- make install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}