summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-01-21 18:53:23 +0900
committerhayao2021-01-21 18:53:23 +0900
commit7ebe35fc44aef74b8bbac982ee2254d64cb39b1d (patch)
tree8376cb2b5c84b7e8274552791a2de38e82112e00
parent71b1ce682eab04297461b87ba93090032ad11255 (diff)
downloadaur-7ebe35fc44aef74b8bbac982ee2254d64cb39b1d.tar.gz
[fix] : Fixed pulseaudio version (get from libpulse)
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD12
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c621b877d8f..2e439e335480 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulseaudio-modules-bt
pkgdesc = PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support
pkgver = 1.4_14.2
- pkgrel = 4
+ pkgrel = 1
url = https://github.com/EHfive/pulseaudio-modules-bt
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 91b35e498685..8b28116f0a43 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,18 @@
# Contributor: EHfive <eh5@sokka.cn>
# Contributar: tleydxdy https://aur.archlinux.org/packages/pulseaudio-modules-bt/#comment-786420
+get_pulseaudio_version() {
+ printf "$(pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/')"
+}
+
#-- PulseAudio --#
pulseaudio_pkgname="pulseaudio"
-pulseaudio_ver="$(pacman -Q "$(basename "${pulseaudio_pkgname}")" | cut -d ' ' -f 2 | cut -d '-' -f 1)"
+pulseaudio_ver="$(get_pulseaudio_version)"
pkgname="pulseaudio-modules-bt"
module_ver="1.4"
pkgver="${module_ver}_${pulseaudio_ver}"
-pkgrel="4"
+pkgrel="1"
pkgdesc="PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support"
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/EHfive/pulseaudio-modules-bt"
@@ -39,6 +43,10 @@ sha512sums=(
"SKIP"
)
+pkgver() {
+ printf "%s_%s" "${module_ver}" "$(get_pulseaudio_version)"
+}
+
prepare() {
cd "${srcdir}/pulseaudio-modules-bt-${module_ver}"
rm -rf pa