summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-01-10 13:46:28 -0200
committerDaniel Bermond2018-01-10 13:46:28 -0200
commit7ebe906e6fee3bde97f21aa77e11e4faa8280513 (patch)
tree83390dc9460b24463b14ab830743ffb812610e37
parent603c9de8a1499581a1f2cafb410e83eb4e910c52 (diff)
downloadaur-7ebe906e6fee3bde97f21aa77e11e4faa8280513.tar.gz
Change IM dependency, add missing sdl depend, disable directfb.
directfb was dropped from official repositories and currently there is no AUR package.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ffa5961a624..304bb76a2b7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jan 10 14:35:30 UTC 2018
+# Wed Jan 10 15:44:01 UTC 2018
pkgbase = xine-lib-hg
pkgdesc = A multimedia playback engine (Mercurial version with all possible libs)
- pkgver = 1.2.7.r12910.d24c69278026
- pkgrel = 2
+ pkgver = 1.2.8.r13412.8771dec9e368
+ pkgrel = 1
url = https://www.xine-project.org/
arch = i686
arch = x86_64
@@ -12,14 +12,11 @@ pkgbase = xine-lib-hg
makedepends = mercurial
makedepends = a52dec
makedepends = aalib
- makedepends = directfb
- makedepends = esound
makedepends = faad2
makedepends = ffmpeg
makedepends = gdk-pixbuf2
makedepends = glu
- makedepends = gnome-vfs-nosmb
- makedepends = imagemagick<7.0.0.0
+ makedepends = libmagick6
makedepends = jack
makedepends = libcaca
makedepends = libcdio
@@ -33,10 +30,14 @@ pkgbase = xine-lib-hg
makedepends = libvdpau
makedepends = libxinerama
makedepends = libxvmc
+ makedepends = sdl
makedepends = smbclient
makedepends = v4l-utils
makedepends = vcdimager
makedepends = wavpack
+ makedepends = esound
+ makedepends = gnome-vfs-nosmb
+ makedepends = sndio
depends = fontconfig
optdepends = a52dec: for using the a52 plugin
optdepends = aalib: for using the aalib plugin
diff --git a/PKGBUILD b/PKGBUILD
index 841e750e302e..0190f9d7bcd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
-# AUR dependencies: esound gnome-vfs-nosmb sndio
-
-# NOTE:
-# '--with-imagemagick' works only with ImageMagick 6 and will not work with IM7
-# (and IM git version). If you have IM7 installed, please change it to
-# '--without-magick'.
-
pkgname=xine-lib-hg
-pkgver=1.2.7.r12910.d24c69278026
-pkgrel=2
+pkgver=1.2.8.r13412.8771dec9e368
+pkgrel=1
pkgdesc='A multimedia playback engine (Mercurial version with all possible libs)'
arch=('i686' 'x86_64')
url='https://www.xine-project.org/'
license=('GPL2' 'LGPL2.1')
depends=('fontconfig')
-makedepends=('mercurial' 'a52dec' 'aalib' 'directfb' 'esound' 'faad2' 'ffmpeg'
- 'gdk-pixbuf2' 'glu' 'gnome-vfs-nosmb' 'imagemagick<7.0.0.0' 'jack'
- 'libcaca' 'libcdio' 'libbluray' 'libdca' 'libdvdnav' 'libmad'
- 'libmng' 'libmpcdec' 'libpulse' 'libvdpau' 'libxinerama' 'libxvmc'
- 'smbclient' 'v4l-utils' 'vcdimager' 'wavpack'
+makedepends=(
+ # official repositories:
+ 'mercurial' 'a52dec' 'aalib' 'faad2' 'ffmpeg' 'gdk-pixbuf2' 'glu'
+ 'libmagick6' 'jack' 'libcaca' 'libcdio' 'libbluray' 'libdca'
+ 'libdvdnav' 'libmad' 'libmng' 'libmpcdec' 'libpulse' 'libvdpau'
+ 'libxinerama' 'libxvmc' 'sdl' 'smbclient' 'v4l-utils' 'vcdimager'
+ 'wavpack'
+ # AUR:
+ 'esound' 'gnome-vfs-nosmb' 'sndio'
)
optdepends=('a52dec: for using the a52 plugin'
'aalib: for using the aalib plugin'
@@ -76,6 +73,8 @@ pkgver() {
build() {
cd "$pkgname"
+ export PKG_CONFIG_PATH="${PKG_CONFIG_PATH:+${PKG_CONFIG_PATH}:}/usr/lib/imagemagick6/pkgconfig"
+
./autogen.sh
./configure \
@@ -97,7 +96,7 @@ build() {
--enable-sndio \
--enable-aalib \
--disable-dha-kmod \
- --enable-directfb \
+ --disable-directfb \
--enable-dxr3 \
--enable-fb \
--disable-macosx-video \