summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManoel Vilela2016-10-01 23:03:40 -0300
committerManoel Vilela2016-10-01 23:03:40 -0300
commit7ecb84cb071a923027fe09d82e345a0a5b3a6e5d (patch)
tree0aafbfc8906ac725404c8ffb9c93eed0bf078fbb
parent0cdeef3aaeb01c4ebb93eae9f54bd47931cec46f (diff)
downloadaur-7ecb84cb071a923027fe09d82e345a0a5b3a6e5d.tar.gz
Keep the installation more idiomatically
Use `install` script instead `cp`. We has a problem yet about the /usr/local/include/brain/io lib because we got a GIANT side effect during the make build process of brain source. This maybe did be done because, in some way, seems more easily to execute. But I think is a worse decision. Why just split the process into two procedures? `make build` and `make install`. Would be really more easy to handle this shit.
-rw-r--r--PKGBUILD4
-rw-r--r--brain.install4
2 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6896f57bb25..88b16b5bce7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,5 +31,7 @@ build() {
package() {
cd "$pkgname-$pkgver"
- sudo cp bin/brain /usr/bin/brain
+ # Creating need directories
+ install -dm755 "$pkgdir/usr/bin"
+ install -Dm755 "bin/brain" $pkgdir/usr/bin/brain
} \ No newline at end of file
diff --git a/brain.install b/brain.install
index ee9ba38851ad..c600398500fd 100644
--- a/brain.install
+++ b/brain.install
@@ -8,5 +8,7 @@ post_upgrade() {
}
post_remove() {
- sudo rm /usr/bin/brain
+ echo "Brain removed successfully? No. We need remove another cancer too."
+ echo "I blame Rafael Nunes and Luiz Peres about this cancer routine."
+ rm -rf -v /usr/local/include/brain/io
}