summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjahway6032021-02-28 20:51:24 -0500
committerjahway6032021-02-28 20:51:24 -0500
commit7f045359eb8903b26e7922c58731bce203cfa244 (patch)
tree5461d7702bf34834fdd4f41ae6928e7587b3422b
downloadaur-7f045359eb8903b26e7922c58731bce203cfa244.tar.gz
updated release to Nextcloud 20.0.8 from upstream
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD60
-rw-r--r--apache.example.conf17
-rw-r--r--nextcloud.hook13
4 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a6c9745494b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = nextcloud20
+ pkgdesc = A cloud server to store your files centrally on a hardware controlled by you
+ pkgver = 20.0.8
+ pkgrel = 1
+ url = https://nextcloud.com
+ arch = any
+ license = AGPL
+ optdepends = php7-apache: to use the Apache web server
+ optdepends = php7-sqlite: to use the SQLite database backend
+ optdepends = php7-pgsql: to use the PostgreSQL database backend
+ optdepends = php7-ldap: LDAP authentication
+ optdepends = php7-intl
+ optdepends = php7-apcu
+ optdepends = mariadb: to use the MySQL database backend
+ optdepends = smbclient: to mount SAMBA shares
+ optdepends = ffmpeg: file preview
+ optdepends = libreoffice: file preview
+ conflicts = nextcloud
+ options = !strip
+ backup = etc/webapps/nextcloud/apache.example.conf
+ backup = etc/webapps/nextcloud/config/config.php
+ source = https://download.nextcloud.com/server/releases/nextcloud-20.0.8.tar.bz2
+ source = https://download.nextcloud.com/server/releases/nextcloud-20.0.8.tar.bz2.asc
+ source = apache.example.conf
+ source = nextcloud.hook
+ validpgpkeys = 28806A878AE423A28372792ED75899B9A724937A
+ sha256sums = 85746a4bda87bf754be5834cdb6489c365dc847653bab8ff3afccdaac3b356b5
+ sha256sums = SKIP
+ sha256sums = 30a8ad62b0dc9523ca7f0387b1f0483d196c1e011ec7e3a5b98e7d33c721d4bf
+ sha256sums = b8794c6b357c762f6d4e6f099d8073bd465d6cd87d6d07341568d9509720e6e8
+
+pkgname = nextcloud20
+ depends = php7>=7.4.0
+ depends = php7<7.5.0
+ depends = php7-gd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88c080bc9d23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Jah Way <jahway603 at protonmail dot com>
+# Previous Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+pkgname=nextcloud20
+_pkgname=nextcloud
+pkgver=20.0.8
+pkgrel=1
+pkgdesc="A cloud server to store your files centrally on a hardware controlled by you"
+arch=('any')
+url="https://nextcloud.com"
+license=('AGPL')
+depends=()
+optdepends=('php7-apache: to use the Apache web server'
+ 'php7-sqlite: to use the SQLite database backend'
+ 'php7-pgsql: to use the PostgreSQL database backend'
+ 'php7-ldap: LDAP authentication'
+ 'php7-intl'
+ 'php7-apcu'
+ 'mariadb: to use the MySQL database backend'
+ 'smbclient: to mount SAMBA shares'
+ 'ffmpeg: file preview'
+ 'libreoffice: file preview')
+options=('!strip')
+backup=('etc/webapps/nextcloud/apache.example.conf'
+ 'etc/webapps/nextcloud/config/config.php')
+validpgpkeys=('28806A878AE423A28372792ED75899B9A724937A') # Nextcloud Security <security@nextcloud.com>
+conflicts=('nextcloud')
+source=("https://download.nextcloud.com/server/releases/nextcloud-${pkgver}.tar.bz2"{,.asc}
+ 'apache.example.conf'
+ 'nextcloud.hook')
+sha256sums=('85746a4bda87bf754be5834cdb6489c365dc847653bab8ff3afccdaac3b356b5'
+ 'SKIP'
+ '30a8ad62b0dc9523ca7f0387b1f0483d196c1e011ec7e3a5b98e7d33c721d4bf'
+ 'b8794c6b357c762f6d4e6f099d8073bd465d6cd87d6d07341568d9509720e6e8')
+
+package() {
+ depends=('php7>=7.4.0' 'php7<7.5.0' 'php7-gd')
+
+ # install project
+ install -d "$pkgdir"/usr/share/webapps/
+ cp -R "$srcdir"/${_pkgname} "$pkgdir"/usr/share/webapps/.
+
+ # install apache config file
+ install -d "$pkgdir"/etc/webapps/${_pkgname}
+ install -m 644 "$srcdir"/apache.example.conf "$pkgdir"/etc/webapps/${_pkgname}
+
+ # move config to /etc
+ install -d "$pkgdir"/etc/webapps/${_pkgname}
+ mv "$pkgdir"/usr/share/webapps/${_pkgname}/config "$pkgdir"/etc/webapps/${_pkgname}/config
+ chown -R 33:33 "$pkgdir"/etc/webapps/${_pkgname}
+ ln -s /etc/webapps/${_pkgname}/config "$pkgdir"/usr/share/webapps/${_pkgname}/config
+ chown -R root:33 "$pkgdir"/usr/share/webapps/${_pkgname}
+
+ find "$pkgdir"/usr/share/webapps/${_pkgname} -type f -exec chmod 0644 {} \;
+ find "$pkgdir"/usr/share/webapps/${_pkgname} -type d -exec chmod 0755 {} \;
+
+ chmod a+x "$pkgdir"/usr/share/webapps/${_pkgname}/occ
+
+ # this was commented out from Nextcloud 20.0.7 release, so retaining for now
+# install -Dm0644 "$srcdir"/nextcloud.hook "$pkgdir"/usr/share/libalpm/hooks/nextcloud.hook
+}
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..2c6e2f7b92f2
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,17 @@
+<IfModule mod_alias.c>
+ Alias /nextcloud /usr/share/webapps/nextcloud/
+</IfModule>
+
+<Directory /usr/share/webapps/nextcloud/>
+ Options FollowSymlinks
+ AllowOverride all
+ Require all granted
+</Directory>
+
+<VirtualHost *:80>
+ ServerAdmin foo@foofarm.com
+ DocumentRoot /usr/share/webapps/nextcloud
+ ServerName nextcloud.foo.com
+ ErrorLog /var/log/httpd/nextcloud.foo.info-error_log
+ CustomLog /var/log/httpd/nextcloud.foo.info-access_log common
+</VirtualHost>
diff --git a/nextcloud.hook b/nextcloud.hook
new file mode 100644
index 000000000000..c9ae16d02b17
--- /dev/null
+++ b/nextcloud.hook
@@ -0,0 +1,13 @@
+# Update Nextcloud when core or -apps are touched
+
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Type = Package
+Target = nextcloud
+Target = nextcloud-app-*
+
+[Action]
+Description = Updating Nextcloud installation
+When = PostTransaction
+Exec = /usr/bin/runuser -u http -- /usr/bin/php7 /usr/share/webapps/nextcloud/occ upgrade