summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-04-16 19:23:43 -0500
committerCarlos Aznarán2024-04-16 19:23:43 -0500
commit7f299f45bdf844870ea89d5747496fcb5129995d (patch)
treec518358998a327ec3551788d1eb1068ba9c54cae
parent79713fcfb067e2936fa4600fa915f27f786deb2a (diff)
downloadaur-7f299f45bdf844870ea89d5747496fcb5129995d.tar.gz
Bump version to 0.18.1
-rw-r--r--.SRCINFO8
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD6
3 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16ea78c49aa1..34cc1a6510a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-vt-py
pkgdesc = Official Python client library for VirusTotal's REST API
- pkgver = 0.18.0
+ pkgver = 0.18.1
pkgrel = 1
url = https://github.com/virustotal/vt-py
arch = any
- license = Apache
+ license = Apache-2.0
checkdepends = python-pytest-asyncio
checkdepends = python-pytest-httpserver
makedepends = python-build
@@ -15,7 +15,7 @@ pkgbase = python-vt-py
depends = python-aiohttp
provides = python-virustotal
replaces = python-virustotal-api
- source = python-vt-py-0.18.0.tar.gz::https://github.com/virustotal/vt-py/archive/0.18.0.tar.gz
- sha512sums = b5ad6f1ef6401a46b4cdcc4f1b7a8696bc9c6ba6f4012cf497c65e469d2d569054f02224c0b914622aea06d7d39a6a8704fa20eae757d1dbdadce2a0eb65abf6
+ source = python-vt-py-0.18.1.tar.gz::https://github.com/virustotal/vt-py/archive/0.18.1.tar.gz
+ sha512sums = 56282322beb12bf36a7d34dc2ae4d6423586f9d7daec774e007519eb8f5d38a67d14ccd370baf5fbb9099a3b1912247f8f03748097c4aa31dd5de31c18c24283
pkgname = python-vt-py
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..bb3017045e9f
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[python-vt-py]
+source = "github"
+github = "virustotal/vt-py"
+use_latest_release = "true"
diff --git a/PKGBUILD b/PKGBUILD
index 60665644e48f..f2097c32baec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
_base=vt-py
pkgname=python-${_base}
-pkgver=0.18.0
+pkgver=0.18.1
pkgrel=1
pkgdesc="Official Python client library for VirusTotal's REST API"
arch=(any)
url="https://github.com/virustotal/${_base}"
-license=(Apache)
+license=(Apache-2.0)
depends=(python-aiohttp)
makedepends=(python-build python-installer python-setuptools python-wheel python-sphinx)
checkdepends=(python-pytest-asyncio python-pytest-httpserver)
provides=(python-virustotal)
replaces=(python-virustotal-api)
source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
-sha512sums=('b5ad6f1ef6401a46b4cdcc4f1b7a8696bc9c6ba6f4012cf497c65e469d2d569054f02224c0b914622aea06d7d39a6a8704fa20eae757d1dbdadce2a0eb65abf6')
+sha512sums=('56282322beb12bf36a7d34dc2ae4d6423586f9d7daec774e007519eb8f5d38a67d14ccd370baf5fbb9099a3b1912247f8f03748097c4aa31dd5de31c18c24283')
prepare() {
sed -i '/setup_requires/d' ${_base}-${pkgver}/setup.py